Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подсчет количества проведенных документов (1С 7.7)  (Прочитано 4705 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alienz

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-07
  • Сайт: 
  • Профессия: Программист 7.7
Добрый день. Платформа 7.7 (7.70.025)
Я делаю в 1С 7.7 ИС для работы аэропортов, аэрофлота и т.п.
У меня есть справочник рейс (реквизиты - ИзГорода, ВГород, ДатаОтправки, КоличествоМест)
Есть документ Билет (реквизиты - Пассажир, ЦенаБилета, НомерБилета, Рейс)

Как мне сделать чтобы считалось количество свободных мест?
Тобишь чтобы считалось сколько всего проведенных документов на тот или иной рейс, и из Справочник.Рейс.КоличествоМест отнималось количество проведенных документов.



Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Выбирайшь документы (период указываешь например "год назад" по текущую дату.  функция Проведен() проверяешь проведен ли документ. И если проведен то ищешь в нем реквизит нужный "Рейс". Сумируешь все проданные билеты в котором есть нужный рейс (если для одного пасажира резервируется только одно место). Вот и будет количество зарезервированных билетов

Оффлайн alienz

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-07
  • Сайт: 
  • Профессия: Программист 7.7
Выбирайшь документы (период указываешь например "год назад" по текущую дату.  функция Проведен() проверяешь проведен ли документ. И если проведен то ищешь в нем реквизит нужный "Рейс". Сумируешь все проданные билеты в котором есть нужный рейс (если для одного пасажира резервируется только одно место). Вот и будет количество зарезервированных билетов

Не могли бы вы написать кодом? Я просто не очень хорошо разбираюсь в 1С.

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Я так понял из описания задачи- это не реальный заказ, а всего лишь студенческая работа.. Для Аэрофлота это как-то мелковато.
Вот по быстрому прикинул "кодом" как это примерно должно выглядить то что я написал выше.
Хотя для реального решения то как ты придумал не годится.

		 КоличествоБилетов=0;					 
    Нужныйрейс=РеквизитДркументаНаКоторомСейчасДелаешьНовыйБилет;
  Дата1=НачГода(НачГода(ТекущаяДата())-1);// начало прошлого года
  Док=СоздатьОбъект("Документ.Билет");
Док.ВыбратьДокументы(Дата1,ТекущаяДата());
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Проведен()=1 Тогда
  Если Док.Рейс=Нужныйрейс тогда
КоличествоБилетов=КоличествоБилетов+1;
  КонецЕсли;
   КонецЕсли;
КонецЦикла;
СвободныхМест=Нужныйрейс.КоличествоМест-КоличествоБилетов;

Оффлайн alienz

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-07
  • Сайт: 
  • Профессия: Программист 7.7
Да, это просто студенческая работа. Сейчас попробую, спасибо.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 330
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal