Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 12:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: РольДоступна не работает в Модуле управляемого приложения  (Прочитано 7710 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rasul

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-21
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день!
В УТ 11 ред. в моделе управляемого приложения написал следующий код:

Процедура ПриНачалеРаботыСистемы()
   //Проверка роли
   Если РольДоступна("Роль1") тогда
      ОтрытьФорму = ПолучитьФорму("Обработка.ЭлектронныеДокументы.Форма.АрхивЭлектронныхДокументов");   
    КонецЕсли;

///////////////////////////////////

Проверка модуля выдает ошибку :{МодульУправляемогоПриложения(85,7)}: Процедура или функция с указанным именем не определена (РольДоступна)
   Если <<?>>РольДоступна("Роль1") тогда  (Проверка: Тонкий клиент)
Модуль управляемого приложения выполняется на клиенте?

   


Оффлайн Rasul

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-21
  • Сайт: 
  • Профессия: Разработчик 1С
Как мне проверить доступность роли пользователю в модуле приложения?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПриНачалеРаботыСистемы()
   //Проверка роли
   Если ПроверятьНужноНаСервереБЛИН() тогда
      ОтрытьФорму = ПолучитьФорму("Обработка.ЭлектронныеДокументы.Форма.АрхивЭлектронныхДокументов");   
    КонецЕсли;

В общем модуле с галочкой СЕРВЕР пишешь:
Функция ПроверятьНужноНаСервереБЛИН() Экспорт
    _РольДоступна = Ложь;
    Если РольДоступна("Роль1") тогда
         _РольДоступна = Истина; 
    КонецЕсли;
    Возврат _РольДоступна;
КонецФункции
     
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 277
Последний ответ 21 Сен 2017, 10:33
от Insider
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4092
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Не работает кнопка "установить интервал дат"

Автор depp_juniorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3661
Последний ответ 11 Июл 2014, 18:07
от LexaK
не работает отчет "Выработка сотрудника" в ЗУП2.5.35.3

Автор a_a2001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3757
Последний ответ 20 Июн 2011, 11:14
от Zvezo
Работает ли программа "1С:Управление торговлей 8" на реальных предприятиях?

Автор БоняРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3110
Последний ответ 25 Июл 2008, 15:23
от Мерзлов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 854
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal