Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как убрать поле Договор с макета? чтобы он не отражался в отчете  (Прочитано 1987 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rayrat

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-05
  • Сайт: 
  • Профессия: Бухгалтер
Как убрать поле Договор с макета? чтобы он не отражался в отчете, мозгов не хватает как это корректно реализовать..
подскажите пожалуйста
В СКД же можно использовать не все поля которые выбрал в запрос, как это тут сделать можно?


Как убрать поле Договор из отчета? чтобы оно в отчете не отражалось
Вопрос наверно простой, но мозгов не хватает корректно это сделать

=================================================================================
Процедура КнопкаВыполнитьНажатие(Кнопка)

//Макет = ВнешниеОбработки.ВыгрузкаЗадолженности.ПолучитьМакет("Макет");

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ХозрасчетныйОстатки.Субконто1 КАК Контрагент,
| ХозрасчетныйОстатки.Субконто1.КодЭлюдии КАК КодКонтрагента,
| ХозрасчетныйОстатки.Субконто2 КАК ДоговорСпр,
| ХозрасчетныйОстатки.Субконто2.Наименование КАК ДоговорНаименование,
| ХозрасчетныйОстатки.Субконто2.Номер КАК НомерДоговора,
| ХозрасчетныйОстатки.Субконто2.Дата КАК ДатаДоговора,
| ХозрасчетныйОстатки.Субконто2.Подразделение КАК Подразделение,
| СУММА(ХозрасчетныйОстатки.СуммаОстатокДт) КАК СуммаДт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(
| &ДатаКон,
| Счет В ИЕРАРХИИ (&СписокСчетов),
| ,
| Организация = &Организация
| И Субконто1 В ИЕРАРХИИ (&Контрагент)) КАК ХозрасчетныйОстатки
|
|СГРУППИРОВАТЬ ПО
| ХозрасчетныйОстатки.Субконто1,
| ХозрасчетныйОстатки.Субконто2,
| ХозрасчетныйОстатки.Субконто1.ИНН,
| ХозрасчетныйОстатки.Субконто1.КПП,
| ХозрасчетныйОстатки.Субконто1.КодЭлюдии,
| ХозрасчетныйОстатки.Субконто2.КодЭлюдии,
| ХозрасчетныйОстатки.Субконто2.Номер,
| ХозрасчетныйОстатки.Субконто2.Дата,
| ХозрасчетныйОстатки.Субконто2.Подразделение,
| ХозрасчетныйОстатки.Субконто2.Наименование
|
|УПОРЯДОЧИТЬ ПО
| Контрагент,
| Подразделение,
| ДоговорСпр
|ИТОГИ
| СУММА(СуммаДт)
|ПО
| Контрагент,
| ДоговорСпр";

Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("ДатаКон", КонецДня(ДатаКон));
Запрос.УстановитьПараметр("СписокСчетов", СписокСчетов);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Запрос.УстановитьПараметр("Подразделение", Подразделение);

Результат = Запрос.Выполнить();

Макет = ПолучитьМакет("МакетВыгрузки");
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
ТабДокумент = Новый ТабличныйДокумент();
ТабДокумент.Вывести(ОбластьШапка);

Парам = ОбластьСтрока.Параметры;

ВыборкаКонтрагент = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаКонтрагент.Следующий() Цикл

Если не ВыборкаКонтрагент.Контрагент = Справочники.Контрагенты.ПустаяСсылка() Тогда

//Парам.Заполнить(ВыборкаКонтрагент);
//
//Парам.Контрагент = ВыборкаКонтрагент.Контрагент.НаименованиеПолное;
////Если ВыборкаКонтрагент.СуммаВзаиморасчетов > 0 Тогда
////
//Парам.СуммаДт = Формат(ВыборкаКонтрагент.СуммаДт,"ЧДЦ=2; ЧГ=0");
//Парам.СуммаКт = Формат(ВыборкаКонтрагент.СуммаКт,"ЧДЦ=2; ЧГ=0");

//ИначеЕсли ВыборкаКонтрагент.СуммаВзаиморасчетов < 0 Тогда
// Парам.СуммаДт = 0;
// Парам.СуммаКт = Формат(-ВыборкаКонтрагент.СуммаВзаиморасчетов,"ЧДЦ=2; ЧГ=0");
//ИначеЕсли ВыборкаКонтрагент.СуммаВзаиморасчетов = 0 Тогда
//
// Парам.СуммаДт = 0;
// Парам.СуммаКт = 0;
//КонецЕсли;

//Сч = 0;
Парам.УчетнаяСистема = "";

ВыборкаДоговор = ВыборкаКонтрагент.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаДоговор.Следующий() Цикл

Если не ВыборкаДоговор.ДоговорСпр = Справочники.ДоговорыКонтрагентов.ПустаяСсылка() Тогда

Парам.Заполнить(ВыборкаДоговор);

Парам.Контрагент = ВыборкаДоговор.Контрагент.НаименованиеПолное;
Парам.СуммаДт = Формат(ВыборкаДоговор.СуммаДт,"ЧДЦ=2; ЧГ=0");
Парам.УчетнаяСистема = "";


Парам.Дата = Формат(ДатаКон, "ДЛФ=Д");
//Если не ПустаяСтрока(ВыборкаДоговор.ДоговорНаименование) Тогда
// Парам.Договор = ВыборкаДоговор.ДоговорНаименование;
Если (ВыборкаДоговор.НомерДоговора = Null)
и (ВыборкаДоговор.ДатаДоговора = Null) Тогда
Парам.Договор = ВыборкаДоговор.ДоговорНаименование;
ИначеЕсли (ПустаяСтрока(ВыборкаДоговор.НомерДоговора))
и (ВыборкаДоговор.ДатаДоговора = Дата(1,1,1)) Тогда
Парам.Договор = ВыборкаДоговор.ДоговорНаименование;
Иначе
Парам.Договор = ВыборкаДоговор.НомерДоговора+ " от " + Формат(ВыборкаДоговор.ДатаДоговора, "ДЛФ=Д");
КонецЕсли;

ТабДокумент.Вывести(ОбластьСтрока);
КонецЕсли;

КонецЦикла;

//ТабДокумент.Вывести(ОбластьСтрока);
КонецЕсли;
КонецЦикла;
ТабДокумент.Защита = Истина;
ТабДокумент.Показать();

ТекстДок = Новый ТекстовыйДокумент();

ИмяФ = КаталогВыгрузки;

ИмяФайла = ИмяФ+ "\debts.csv";
СимволРазделитель = " ";

КонечнаяСтрока = ТабДокумент.ВысотаТаблицы;
КонечнаяКолонка = ТабДокумент.ШиринаТаблицы;

Для строка = 1 по КонечнаяСтрока Цикл
СтрКа = "";
Для колонка = 1 по КонечнаяКолонка Цикл

ОбластьЯчейки = ТабДокумент.Область(Строка,Колонка);
ОбластьТекст = ОбластьЯчейки.Текст;
СтрКа = СтрКа+ОбластьТекст+СимволРазделитель;

КонецЦикла;
СтрКа = СтрКа + строка;
ТекстДок.ДобавитьСтроку(СтрКа)
КонецЦикла;
ТекстДок.Записать(ИмяФайла, "windows-1251");


КонецПроцедуры

Процедура КаталогВыгрузкиНачалоВыбора(Элемент, СтандартнаяОбработка)
// Вставить содержимое обработчика.

СтандартнаяОбработка = Ложь;

ДиалогВыбораКаталогВыгрузки = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
ДиалогВыбораКаталогВыгрузки.Заголовок = "Открытие каталога для передачи файлов в систему Элюдия";
// ДиалогВыбораКаталогЭкспорта.ПроверятьСуществованиеФайла = Истина;
ДиалогВыбораКаталогВыгрузки.Каталог = КаталогВыгрузки;

Если Не ДиалогВыбораКаталогВыгрузки.Выбрать() Тогда
Возврат;
КонецЕсли;

КаталогВыгрузки = ДиалогВыбораКаталогВыгрузки.Каталог;

КонецПроцедуры

Процедура ПриОткрытии()
// Вставить содержимое обработчика.
Организация = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнаяОрганизация");
//Подразделение = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновноеПодразделение");

СписокСчетов.Очистить();
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.РасчетыСПоставщикамиИПодрядчиками);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.РасчетыСПокупателямиИЗаказчиками);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.РасчетыПоИмущественномуИЛичномуСтрахованию);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.РасчетыПоПретензиям);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.РасчетыПоПричитающимсяДивидендам);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПокупателямиИЗаказчиками);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПрочиеРасчетыСРазнымиДебиторамиИКредиторами);
СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.КорректировкаРасчетовПрошлогоПериода);

ДатаКон = ТекущаяДата();
КаталогВыгрузки = "";
КонецПроцедуры
==================================================­=================================
[+] [−]


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Перед

ТабДокумент.Вывести(ОбластьСтрока);

напишите

Парам.Договор = "";
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Rayrat

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-05
  • Сайт: 
  • Профессия: Бухгалтер


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6946
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2289
Последний ответ 09 Дек 2015, 19:33
от Oks
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 314
Последний ответ 10 Окт 2017, 12:33
от kiksi
Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6413
Последний ответ 10 Июл 2014, 15:16
от virtus
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1084
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 235
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal