Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание отчета!  (Прочитано 7366 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!!! Помогите разобраться в коде. Создаю отчет с нуля.

вот код:


 Процедура ДействиеФормыОтчетВагоныСформировать (Кнопка)
   
   Макет = ОтчетОбъект.ПолучитьМакет("ОтчетВагоны");
   ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;
   
   запрос = Новый Запрос;
   запрос.Текст = "ВЫБРАТЬ
                |   РЦ_РеализацияЦемента.ДокументОтгрузки,
                |   РЦ_РеализацияЦемента.Контрагент,
                |   РЦ_РеализацияЦемента.СпособОтправки
                |ИЗ
                |   РегистрНакопления.РЦ_РеализацияЦемента КАК РЦ_РеализацияЦемента";
            
            
            
    ОбластьЗаголовок  = Макет.ПолучитьОбласть("Пояснение");
   ОбластьДетали     = Макет.ПолучитьОбласть("Детали");
   
   Результат = запрос.Выполнить();
   
КонецПроцедуры

Когда запускаю форма появляется. Жму Формировать, в Табличном Поле Документа ни че не появляется?!
Может че не хватает или не дописал!!! Заранее благодарю!


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #1: 04 Июн 2012, 10:12 »
Где обход результата запроса?
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #2: 04 Июн 2012, 10:14 »
   Результат = запрос.Выполнить();
После нужно вставить обход результата запроса, и еще не увидела вывода ни одной строки...
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #3: 04 Июн 2012, 10:16 »
либо воспользоваться СКД
Тазовод)

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #4: 04 Июн 2012, 10:17 »
этот отчет нужно программно сделать а не через СКД!!!
Подскажи как написать вывод строки?!

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #5: 04 Июн 2012, 10:33 »
1) попробуйте воспользоваться констуктором запроса с обработкой результата.. далее во смотрите пример:
	ТабДок = Новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
Шапка = Макет.ПолучитьОбласть("Заголовок");
ТабДок.Вывести(Шапка);
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПланыПродажПоГруппамОбороты.Организация,
| ПланыПродажПоГруппамОбороты.КоличествоОборот,
| ПланыПродажПоГруппамОбороты.ТорговаяМарка
|ИЗ
| РегистрНакопления.ПланыПродажПоГруппам.Обороты(&НачалоПериода, &КонецПериода, Авто, ) КАК ПланыПродажПоГруппамОбороты";

Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Строка = Макет.ПолучитьОбласть("Строка");
Строка.Параметры.Организация = ВыборкаДетальныеЗаписи.Организация;
Строка.Параметры.ТорговаяМарка = ВыборкаДетальныеЗаписи.ТорговаяМарка;
Строка.Параметры.КоличествоОборот = ВыборкаДетальныеЗаписи.КоличествоОборот;
ТабДок.Вывести(Строка);
КонецЦикла;

ТабДок.Показать();

Тазовод)

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #6: 04 Июн 2012, 10:37 »
Хорошо, благодарю. Посмотрю сейчас

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #7: 04 Июн 2012, 12:02 »
Таблицу Выводит, но почему то пустую?

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #8: 04 Июн 2012, 12:03 »
Процедура ДействиеФормыОтчетВагоныСформировать (Кнопка)
   
   Макет = ОтчетОбъект.ПолучитьМакет("ОтчетВагоны");
   ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;
   
   запрос = Новый Запрос;
   запрос.Текст = "ВЫБРАТЬ
                  |   РЦ_РеализацияЦемента.ДокументОтгрузки,
                  |   РЦ_РеализацияЦемента.Контрагент,
                  |   РЦ_РеализацияЦемента.СпособОтправки
                  |ИЗ
                  |   РегистрНакопления.РЦ_РеализацияЦемента КАК РЦ_РеализацияЦемента
                  |
                  |СГРУППИРОВАТЬ ПО
                  |   РЦ_РеализацияЦемента.СпособОтправки,
                  |   РЦ_РеализацияЦемента.ДокументОтгрузки,
                  |   РЦ_РеализацияЦемента.Контрагент";
            
            
            
    ОбластьЗаголовок  = Макет.ПолучитьОбласть("Пояснение");
   ОбластьДетали     = Макет.ПолучитьОбласть("Детали");
   
   Результат = запрос.Выполнить();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Строка = Макет.ПолучитьОбласть("Детали");
      ТабДок.Вывести(ОбластьДетали);
   КонецЦикла;
   ТабДок.Показать();
            
   
КонецПроцедуры

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Создание отчета!
« Ответ #9: 04 Июн 2012, 12:05 »
Процедура ДействиеФормыОтчетВагоныСформировать (Кнопка)
   
   Макет = ОтчетОбъект.ПолучитьМакет("ОтчетВагоны");
   ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;
   
   запрос = Новый Запрос;
   запрос.Текст = "ВЫБРАТЬ
                  |   РЦ_РеализацияЦемента.ДокументОтгрузки,
                  |   РЦ_РеализацияЦемента.Контрагент,
                  |   РЦ_РеализацияЦемента.СпособОтправки
                  |ИЗ
                  |   РегистрНакопления.РЦ_РеализацияЦемента КАК РЦ_РеализацияЦемента
                  |
                  |СГРУППИРОВАТЬ ПО
                  |   РЦ_РеализацияЦемента.СпособОтправки,
                  |   РЦ_РеализацияЦемента.ДокументОтгрузки,
                  |   РЦ_РеализацияЦемента.Контрагент";
           
           
           
    ОбластьЗаголовок  = Макет.ПолучитьОбласть("Пояснение");
    ТабДок.Вывести( ОбластьЗаголовок);
   
   Результат = запрос.Выполнить();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      ОбластьДетали     = Макет.ПолучитьОбласть("Детали");
      ОбластьДетали.Параметры.ИмяПарметра = "";
      ТабДок.Вывести(ОбластьДетали);
   КонецЦикла;
   ТабДок.Показать();
           
   
КонецПроцедуры

а где присвоение параметров?
Тазовод)


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7047
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2993
Последний ответ 27 Май 2015, 10:02
от casper009
Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4467
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4093
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1953
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 821
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal