Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 21:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Дайте пожалуйста совет!  (Прочитано 7265 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Пишу обработку по загрузке файлов dbf.При выполнении выгрузки выходит ошибка:{Форма.Форма.Форма(56)}: Ошибка при вызове метода контекста (Первая)
      ДБФ.Первая();
по причине:
Перед выполнением операции нужно открыть базу!!!

Путь находит,файл с данными dbf есть.

Вот кусок кода:

Перем ТекстСообщенияОшибки;

Процедура ПутьКФайлуНачалоВыбора(Элемент, СтандартнаяОбработка)
   СтандартнаяОбработка=ложь;
   Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
   Диалог.Заголовок = "Выберите файл";
   Диалог.ПолноеИмяФайла = "";
   Фильтр = "(*.dbf)|*.dbf";
   Диалог.Фильтр = Фильтр;
    Диалог.МножественныйВыбор = Ложь;
   Диалог.Каталог = "\\report\ExportCRM";
   Если Диалог.Выбрать() Тогда
      //Элемент.значение = Диалог.ПолноеИмяФайла;
      ПутьКФайлу = Диалог.ПолноеИмяФайла;
   КонецЕсли;

КонецПроцедуры


Процедура НоменклатураНажатие(Элемент)
       НоменклатуруЗагрузить();

КонецПроцедуры

Функция НоменклатуруЗагрузить()
        ДБФ = Новый XBase;
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      ДБФ.Кодировка=КодировкаXBase.OEM;
      //Проверка на наличие записей
   //Если ДБФ.КоличествоЗаписей() = 0 Тогда
   //   Сообщить("Файл данных пуст");
   //   ДБФ.ЗакрытьФайл();
   //   //Возврат   
   //КонецЕсли;
      СпрНоменклатура=Справочники.Номенклатура;                   
      СпрВидыНоменклатуры=Справочники.ВидыНоменклатуры;
      СпрЕдиницыИзмерения=Справочники.КлассификаторЕдиницИзмерения;
      ДБФ.Первая();
      Пока Истина Цикл
         
      Код=СокрЛП(ДБФ.KOD);
   Если СпрНоменклатура.НайтиПоКоду(Код)=СпрНоменклатура.ПустаяСсылка() Тогда
        Номенклатура = СпрНоменклатура.СоздатьЭлемент();
      //Если ЗначениеЗаполнено(ДБФ.KOD) Тогда
      //Код=СокрЛП(ДБФ.KOD);
      //   Если Код Тогда
          Номенклатура.Наименование = СокрЛП(ДБФ.NAMEN);
        Номенклатура.Артикул = СокрЛП(ДБФ.ART);
      Номенклатура.ВидНоменклатуры = СпрВидыНоменклатуры.НайтиПоНаименованию(СокрЛП(ДБФ.VID),Истина);
      Номенклатура.БазоваяЕдиницаИзмерения=СпрЕдиницыИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED),Истина);   
      Номенклатура.Код=Код;
       Номенклатура.Записать();
      КонецЕсли;

      Если Не ДБФ.Следующая()Тогда
         Прервать;
      КонецЕсли;
      КонецЦикла;


  КонецФункции




Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Можно перед вызовом
ДБФ.Первая();
проверить, удалось ли открыть dbf
Если НЕ ДБФ.Открыта()  Тогда
      // всё же есть какие-то проблемы с файлом
КонецЕсли;

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Проверила.открывает

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
проверила загружать разные файлы dbf.не загружает(((До этого делала обработку,указывая конкретный путь.все хорошо загружало.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
разобралась

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Если не сложно...

напишите, КАК ИМЕННО...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Если не сложно...напишите, КАК ИМЕННО...
Может быть что-то было не так с диалогом выбора файла? Ведь
...До этого делала обработку,указывая конкретный путь.все хорошо загружало.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
да.с путем проблемы.когда файлы dbf копирую на свой комп и обращаюсь к ним-все работает.когда обращаюсь к файлам,которые лежат на сервере-доступа нет((


Теги:
 

Подскажите пожалуйста код проверки заполнения реквизита док или реквизита ТЧ

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 969
Последний ответ 22 Июл 2016, 16:17
от Fedor_Safonchik
Здраствуйте! Помогите пожалуйста мне ! - "Очёт Валовая Прибыль"

Автор lipvРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2061
Последний ответ 05 Июн 2014, 16:30
от ADMBD
Помогите пожалуйста сделать итог по колонке "начислено"

Автор kot-1012Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2138
Последний ответ 05 Сен 2011, 10:14
от has
Перешли на 8УТ с ТИСа, работаем первую неделю. Есть много вопросов. На те, что не нашел ответы в интернете подскажите пожалуйста, опытом поделитесь))

Автор KofffeРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1202
Последний ответ 02 Ноя 2015, 12:34
от AIFrame
Всем привет, подскажите пожалуйста как загрузить в БП 3.0 стандартные справочники(например виды номенклатур), буду премного благодарен

Автор DemlifeРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 696
Последний ответ 21 Мар 2016, 11:37
от Demlife

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 327
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal