Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 08:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Корректировочный счет-фактура в старом релизе 1с 7.70.310  (Прочитано 1614 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GovMPE

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-07
  • Сайт: 
  • Профессия: Ученик 1С
Вообщем проблема в следующем: Добавил корр. с-ф из нового релиза в старый, кое-как адаптировал, чтоб работал.  Но никак не могу заставить его брать Ставку НДС из док.основания (счет-фактуры). Все суммы, наименования, все идет кроме СтавкиНДС.
Код:

Процедура ЗаполнитьТабЧастьНаОсн()
   
   Если глЕстьРеквизитШапки("ДокументОснование", ДокОснование.Вид()) = Да Тогда
      
      ДокОсн = ДокОснование.ДокументОснование;
      
      Если ПустоеЗначение(ДокОсн) = 1 Тогда
         Возврат;
      КонецЕсли;   
      
      Если (ДокОсн.Вид() = "ОтчетКомиссионера") или
         (ДокОсн.Вид() = "РасходнаяНакладная") или
         (ДокОсн.Вид() = "РеализацияРозница") Тогда
         
         СуммаВклНДС = 1;   
            
         ДокОсн.ВыбратьСтроки();
         Пока ДокОсн.ПолучитьСтроку()=1 Цикл
            
            НоваяСтрока();
         
            Если ТипЗначенияСтр(ДокОсн.товар) = "Справочник" Тогда      
               НазначитьТип("Наименование", "Справочник." + ДокОсн.Товар.Вид());
                Наименование = ДокОсн.Товар;
            КонецЕсли;
            
            Единица                 = ДокОсн.Единица;
            Коэффициент             = ДокОсн.Коэффициент;
            КоличествоДоИзменения   = ДокОсн.Сумма / ?(ДокОсн.Цена <> 0, ДокОсн.Цена, 1);
            Количество              = ДокОсн.Сумма / ?(ДокОсн.Цена <> 0, ДокОсн.Цена, 1);
            СтавкаНДС             = ДокОсн.СтавкаНДС;
            ЦенаДоИзменения       = ДокОсн.Цена;
            Цена                  = ДокОсн.Цена;
            СуммаНДСДоИзменения    = ДокОсн.НДС;
              СуммаНДС                = ДокОсн.НДС;     //добавил, чтобы меньше править руками.
            СуммаДоИзменения       = ДокОсн.Сумма;
            Сумма                    = ДокОсн.Сумма;
            
            ПересчетТаблЧасти();
            
         КонецЦикла;
      
Идентификаторы в док.оновании на месте, называются как положено, но все равно не берет эту чертову Ставку :angry:. подскажите, куда копать?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 180
  • Точка Скрытых: 1
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal