Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 18:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перехитрить платформу  (Прочитано 1210 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ololo9

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-05-28
  • Сайт: 
  • Профессия: Программист 7.7
В конфигурации есть 2 справочника: собств.продукция и покупн.продукция (требование бухов). Имеется документ ТоварныйЧек, в котором в графе наименование можно выбрать наименование как с одного так и другого справочника. Наименованию присвоен тип Справочник. Вопрос: можно ли допустим при нажатии флажка СобствПродукция или ПокупнПродукция при выборе НАименования избавиться от процедуры выбора справочника, а сразу спозиционироваться на нужном, т.е. СобствПродукция (ПокупнПродукция) и как это реализовать???
На данном этапе удалось только спозиционироваться на текущем элементе каждого справочника  :^454^:


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Процедура ПриНачалеВыбораЗначения(ЭлементДиалога,ФСО)
   Перем НазвКолонки, Спр;
   
   НазвКолонки = "Товар"; //  ваше название колонки "наименования"
   
   Если ЭлементДиалога = НазвКолонки Тогда
      Если ФлСобств = 1 Тогда // выбран переключатель собственная продукция
    Спр=создатьОбъект("Справочник.ТоварыСобстПродукция"); // здесь должно быть название вашего справочника
      иначе // выбран переключатель покупная продукция
    Спр=создатьОбъект("Справочник.ТоварыПокупПродукция"); // здесь должно быть название вашего справочника
      КонецЕсли;
      
      Если Спр.Выбрать(,)=1 Тогда
    Товар = спр.ТекущийЭлемент();  // товар - это название реквизита табл. части, с типом неопределенного   
                                                        // справочника
     КонецЕсли;
      
     ФСО=0; // отключение выбора справочника
   КонецЕсли;
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 247
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal