Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение табличной части документа списание материалов из эксплуатации по МОЛ  (Прочитано 2572 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн slavabatov

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-12
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Есть ли у кого внешняя обработка для заполнения ТЧ документа Списание материалов из эксплуатации? У меня написана обработка которая без проблем заполняет (по МОЛ) Перемещение материалов и Возврат материалов, но хоть убей не хочет правильно заполнять (по МОЛ) (часть материалов не попадает, те которые были перемещены) Списание.
Процедура Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт

Если Объект.Модифицированность() Тогда
Сообщить("Документ должен быть записан!");
Возврат;
КонецЕсли;

МОЛ = Справочники.ФизическиеЛица.ПустаяСсылка();

Если ВвестиЗначение(МОЛ, "Выберите получателя") Тогда

Объект.Материалы.Очистить();

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| МатериалыВЭксплуатацииОстатки.Подразделение,
| МатериалыВЭксплуатацииОстатки.Номенклатура,
| МатериалыВЭксплуатацииОстатки.ХарактеристикаНоменклатуры,
| МатериалыВЭксплуатацииОстатки.СерияНоменклатуры,
| МатериалыВЭксплуатацииОстатки.ФизЛицо,
| СУММА(МатериалыВЭксплуатацииОстатки.КоличествоОстаток) КАК КоличествоОстаток,
| СУММА(МатериалыВЭксплуатацииОстатки.бтСуммаОстаток) КАК бтСуммаОстаток,
| ВложенныйЗапрос.НазначениеИспользование КАК НазначениеИспользования
|ИЗ
| РегистрНакопления.МатериалыВЭксплуатации.Остатки(&Период, ФизЛицо = &ФизЛицо) КАК МатериалыВЭксплуатацииОстатки
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| МАКСИМУМ(НазначенияИспользования.Ссылка) КАК НазначениеИспользование,
| НазначенияИспользования.Владелец КАК Номенклатура
| ИЗ
| Справочник.НазначенияИспользования КАК НазначенияИспользования
|
| СГРУППИРОВАТЬ ПО
| НазначенияИспользования.Владелец) КАК ВложенныйЗапрос
| ПО МатериалыВЭксплуатацииОстатки.Номенклатура = ВложенныйЗапрос.Номенклатура
|
|СГРУППИРОВАТЬ ПО
| МатериалыВЭксплуатацииОстатки.Подразделение,
| МатериалыВЭксплуатацииОстатки.Номенклатура,
| МатериалыВЭксплуатацииОстатки.ХарактеристикаНоменклатуры,
| МатериалыВЭксплуатацииОстатки.СерияНоменклатуры,
| МатериалыВЭксплуатацииОстатки.ФизЛицо,
| ВложенныйЗапрос.НазначениеИспользование";

Запрос.УстановитьПараметр("Период", Объект.Дата);
Запрос.УстановитьПараметр("ФизЛицо", МОЛ);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

СтрокаТЧ = Объект.Материалы.Добавить();

СтрокаТЧ.Номенклатура = Выборка.Номенклатура;
СтрокаТЧ.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;
СтрокаТЧ.СерияНоменклатуры = Выборка.СерияНоменклатуры;
СтрокаТЧ.ФизЛицо = Выборка.ФизЛицо;
СтрокаТЧ.Количество = Выборка.КоличествоОстаток;
СтрокаТЧ.ЕдиницаИзмерения = Выборка.Номенклатура.ЕдиницаХраненияОстатков;
СтрокаТЧ.Коэффициент = Выборка.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент;
СтрокаТЧ.НазначениеИспользования = Выборка.НазначениеИспользования;
СтрокаТЧ.ТипСтоимости = Перечисления.ВидыНормативнойСтоимостиПроизводства.Рассчитывается;

КонецЦикла; 

КонецЕсли;

КонецПроцедуры



Оффлайн slavabatov

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-12
  • Сайт: 
  • Профессия: Ученик 1С
что то я с ВВ кодом перемудрил


Процедура Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт
   
   Если Объект.Модифицированность() Тогда
      Сообщить("Документ должен быть записан!");
      Возврат;
   КонецЕсли;
   
   МОЛ = Справочники.ФизическиеЛица.ПустаяСсылка();
   
   Если ВвестиЗначение(МОЛ, "Выберите получателя") Тогда
      
      Объект.Материалы.Очистить();
      
      Запрос = Новый Запрос;
      Запрос.Текст =
      "ВЫБРАТЬ
      |   МатериалыВЭксплуатацииОстатки.Подразделение,
      |   МатериалыВЭксплуатацииОстатки.Номенклатура,
      |   МатериалыВЭксплуатацииОстатки.ХарактеристикаНоменклатуры,
      |   МатериалыВЭксплуатацииОстатки.СерияНоменклатуры,
      |   МатериалыВЭксплуатацииОстатки.ФизЛицо,
      |   СУММА(МатериалыВЭксплуатацииОстатки.КоличествоОстаток) КАК КоличествоОстаток,
      |   СУММА(МатериалыВЭксплуатацииОстатки.бтСуммаОстаток) КАК бтСуммаОстаток,
      |   ВложенныйЗапрос.НазначениеИспользование КАК НазначениеИспользования
      |ИЗ
      |   РегистрНакопления.МатериалыВЭксплуатации.Остатки(&Период, ФизЛицо = &ФизЛицо) КАК МатериалыВЭксплуатацииОстатки
      |      ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
      |         МАКСИМУМ(НазначенияИспользования.Ссылка) КАК НазначениеИспользование,
      |         НазначенияИспользования.Владелец КАК Номенклатура
      |      ИЗ
      |         Справочник.НазначенияИспользования КАК НазначенияИспользования
      |      
      |      СГРУППИРОВАТЬ ПО
      |         НазначенияИспользования.Владелец) КАК ВложенныйЗапрос
      |      ПО МатериалыВЭксплуатацииОстатки.Номенклатура = ВложенныйЗапрос.Номенклатура
      |
      |СГРУППИРОВАТЬ ПО
      |   МатериалыВЭксплуатацииОстатки.Подразделение,
      |   МатериалыВЭксплуатацииОстатки.Номенклатура,
      |   МатериалыВЭксплуатацииОстатки.ХарактеристикаНоменклатуры,
      |   МатериалыВЭксплуатацииОстатки.СерияНоменклатуры,
      |   МатериалыВЭксплуатацииОстатки.ФизЛицо,
      |   ВложенныйЗапрос.НазначениеИспользование";
      
      Запрос.УстановитьПараметр("Период", Объект.Дата);
      Запрос.УстановитьПараметр("ФизЛицо", МОЛ);
      
      Выборка = Запрос.Выполнить().Выбрать();
      
      Пока Выборка.Следующий() Цикл
         
         СтрокаТЧ = Объект.Материалы.Добавить();
         
         СтрокаТЧ.Номенклатура             = Выборка.Номенклатура;
         СтрокаТЧ.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;
         СтрокаТЧ.СерияНоменклатуры          = Выборка.СерияНоменклатуры;
         СтрокаТЧ.ФизЛицо                = Выборка.ФизЛицо;
         СтрокаТЧ.Количество             = Выборка.КоличествоОстаток;
         СтрокаТЧ.ЕдиницаИзмерения          = Выборка.Номенклатура.ЕдиницаХраненияОстатков;
         СтрокаТЧ.Коэффициент             = Выборка.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент;
         СтрокаТЧ.НазначениеИспользования   = Выборка.НазначениеИспользования;
         СтрокаТЧ.ТипСтоимости            = Перечисления.ВидыНормативнойСтоимостиПроизводства.Рассчитывается;
         
      КонецЦикла; 
      
   КонецЕсли;
   
КонецПроцедуры


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4490
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7764
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4795
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8572
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7357
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 344
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal