Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 16:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка реквизитов справочника из внешней БД  (Прочитано 1648 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yoja

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-05-22
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте!
Подключен на прямую к базе (т.е. на форме обработчика указываю путь к БД, Имя пользователя и Пароль)

Открываю
1С:Підприємство 8.2 (8.2.13.219)
Управление небольшой фирмой для Украины, редакция 1.3
ЗАПУСКАЮ, внешнюю обработку

Подключаюсь напрямую к БД
1С:Підприємство 8.2 (8.2.13.219)
Бухгалтерия для Украины, редакция 1.2.

Процедура Кнопка1Нажатие(Элемент)
    //строим запрос к контрагентам
//Запрос1С = Новый Запрос;
Запрос1С.Текст =
"ВЫБРАТЬ
 | Контрагенты.Ссылка,
 | Контрагенты.ВерсияДанных,
 | Контрагенты.ПометкаУдаления,
 | Контрагенты.Предопределенный,
 | Контрагенты.Родитель,
 | Контрагенты.ЭтоГруппа,
 | Контрагенты.Код,
 | Контрагенты.Наименование,
 | Контрагенты.ОсновнойДоговорКонтрагента,
 | Контрагенты.Комментарий,
 | Контрагенты.ГоловнойКонтрагент,
 | Контрагенты.ЮрФизЛицо,
 | Контрагенты.ИНН,
 | Контрагенты.НаименованиеПолное,
 | Контрагенты.ОсновнойБанковскийСчет,
 | Контрагенты.ДокументУдостоверяющийЛичность,
 | Контрагенты.ОсновноеКонтактноеЛицо,
 | Контрагенты.КодПоЕДРПОУ,
 | Контрагенты.НомерСвидетельства,
 | Контрагенты.НеЯвляетсяРезидентом,
 | Контрагенты.Представление
 |ИЗ
 | Справочник.Контрагенты КАК Контрагенты";

РезультатЗапроса = Запрос1С.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
Счетчик = 1;
Пока Выборка.Следующий() Цикл
Сообщить("Выборка.ПометкаУдаления "+Выборка.ПометкаУдаления);
Сообщить("Выборка.Предопределенный "+Выборка.Предопределенный);
Сообщить("Выборка.ЭтоГруппа "+Выборка.ЭтоГруппа);
Сообщить("Выборка.Код "+Выборка.Код);
Сообщить("Выборка.Наименование "+Выборка.Наименование);
Сообщить("Выборка.ИНН "+Строка(Выборка.ИНН));
Сообщить("Выборка.НаименованиеПолное "+Выборка.НаименованиеПолное);
Сообщить("Выборка.КодПоЕДРПОУ "+Строка(Выборка.КодПоЕДРПОУ));
Сообщить("Выборка.НомерСвидетельства "+Выборка.НомерСвидетельства);
Сообщить("Выборка.НеЯвляетсяРезидентом "+Выборка.НеЯвляетсяРезидентом);
Сообщить("Выборка.Представление "+Выборка.Представление);
Сообщить("Выборка.Комментарий "+Выборка.Комментарий);
Сообщить("Выборка.ДокументУдостоверяющийЛичность "+Выборка.ДокументУдостоверяющийЛичность);
Сообщить("---------------------------------------------");

Сообщить("Выборка.Ссылка "+Выборка.Ссылка);
Сообщить("Выборка.ВерсияДанных "+Выборка.ВерсияДанных);
Сообщить("Выборка.Родитель "+Выборка.Родитель);
Сообщить("Выборка.ОсновнойДоговорКонтрагента "+Выборка.ОсновнойДоговорКонтрагента);
Сообщить("Выборка.ГоловнойКонтрагент "+Выборка.ГоловнойКонтрагент);
Сообщить("Выборка.ЮрФизЛицо "+Выборка.ЮрФизЛицо);
Сообщить("Выборка.ОсновнойБанковскийСчет "+Выборка.ОсновнойБанковскийСчет);
Сообщить("Выборка.ОсновноеКонтактноеЛицо "+Выборка.ОсновноеКонтактноеЛицо);
Сообщить("***********************************************************************************");
Сообщить(" ");

Счетчик = Счетчик + 1;
#Если Клиент Тогда
ОбработкаПрерыванияПользователя();
#КонецЕсли
КонецЦикла;
КонецПроцедуры

Результат:
Выборка.ПометкаУдаления Ні
Выборка.Предопределенный Ні
Выборка.ЭтоГруппа Ні
Выборка.Код 000000012
Выборка.Наименование СельхозТехника
Выборка.ИНН 340000026000
Выборка.НаименованиеПолное Товариство з обмеженою відповідальністю "ПУПОК"
Выборка.КодПоЕДРПОУ 12345678
Выборка.НомерСвидетельства 123456789
Выборка.НеЯвляетсяРезидентом Ні
Выборка.Представление Ашан
Выборка.Комментарий ТЦ СельхозТехника, комментарий
Выборка.ДокументУдостоверяющийЛичность Паспорт
---------------------------------------------
Выборка.Ссылка COMОбъект
Выборка.ВерсияДанных AAAAYAAAAAE=
Выборка.Родитель COMОбъект
Выборка.ОсновнойДоговорКонтрагента COMОбъект
Выборка.ГоловнойКонтрагент COMОбъект
Выборка.ЮрФизЛицо COMОбъект
Выборка.ОсновнойБанковскийСчет COMОбъект
Выборка.ОсновноеКонтактноеЛицо COMОбъект
***********************************************************************************

Как сделать правильно, чтобы вторая половина результата была не COMОбъект, а правильные ответ запроса.
Что нужно делать и куда копать? Может править сам запрос?
Если кто знает, подскажите.
Заранее спасибо.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Так это же объект ЧУЖОЙ базы
получай представления (примитивные типы, а не ссылки)

Например Выборка.Ссылка.Наименование
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6507
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4214
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 650
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2055
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 278
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
AIFrame
69 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 734
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal