Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 17:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как определить наличие нужного измерения во всех регистрах  (Прочитано 2482 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KolyaProger

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-05-18
  • Сайт: 
  • Профессия: Программист 1С
Как определить наличие нужного измерения во всех регистрах накопления?
По имени измерения "СерияНоменклатуры"...

Для каждого регистр из метаданные.РегистрыНакопления Цикл

    // вот это использовать? НайтиПоПолномуИмени();

КонецЦикла;


Оффлайн sixis

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 4
  • КПД: 33%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 1С
Для каждого регистр из метаданные.РегистрыНакопления Цикл
Для каждого реквизит из метаданные.РегистрыНакопления[Регистр.Имя].Измерения Цикл
Если Реквизит.Имя = "Номенклатура" Тогда
Сообщить(РегистрыНакопления[Регистр.Имя]);
КонецЕсли;
КонецЦикла;
КонецЦикла;

Оффлайн sixis

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 4
  • КПД: 33%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 1С
Для каждого регистр из метаданные.РегистрыНакопления Цикл
Для каждого реквизит из метаданные.РегистрыНакопления#Регистр.Имя#.Измерения Цикл
Если Реквизит.Имя = "Номенклатура" Тогда
Сообщить(РегистрыНакопления#Регистр.Имя#);
КонецЕсли;
КонецЦикла;
КонецЦикла;


#-квадратные скобки

Оффлайн KolyaProger

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-05-18
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

В разделе "Перейти"панели навигации ВСЕХ управляемых форм (новых, старых, вновь создаваемых) конфигурации появляется одна и та же команда. Как избавиться?

Автор CrazyHorseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1295
Последний ответ 23 Июн 2015, 16:49
от CrazyHorse
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4303
Последний ответ 24 Дек 2015, 15:34
от дфтын
Для всех документов нужно сделать проверку при проведении. Где это можно сделать?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 645
Последний ответ 04 Сен 2016, 04:20
от cska-fanat-kz
Часть вторая: переход на «1С ЗУП» версии «3.0». Работа с «Параметрами учета» и проверка всех настроек программы после транспортировки из предыдущей редакции

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4275
Последний ответ 16 Мар 2015, 16:19
от 1cwiki
Если стоимость отгруженного товара изменилась, нужно выдавать корректировочную или обычную счет-фактуру с учетом всех изменений

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1107
Последний ответ 17 Июл 2014, 12:25
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
59 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 319
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal