Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удалить пометку удаления. Не работает обработка.  (Прочитано 1266 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
Вот, написал:
Цитировать
Процедура СтартНажатие(Элемент)
   ТаблицаСсылок = НайтиПоСсылкам(НайтиПомеченныеНаУдаление());
   КоличествоЗаписей = ТаблицаСсылок.Количество();
   
   Состояние("Данные помечаются на удаление...");        
   
   ФормаИндикации = ПолучитьОбщуюФорму("ХодВыполненияОбработкиДанных");
   ФормаИндикации.НаименованиеОбработкиДанных = "Снятие пометок";
   ФормаИндикации.КомментарийОбработкиДанных  = "Снимаютс пометки на удаление";
   ФормаИндикации.МаксимальноеЗначение        = КоличествоЗаписей;
   
   Ответ = Вопрос("Снять "+КоличествоЗаписей+" пометок?", РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Да);
   Если Ответ = КодВозвратаДиалога.Нет Тогда
         Сообщить("Обработка отменена: " + ТекущаяДата());
         Возврат;
   КонецЕсли;   
   Сообщить("Обработка начата: " + ТекущаяДата());

   ФормаИндикации.Открыть();
   
   Н = 0;
   Неудача = 0;
      
   Для каждого СтрокаТаблицы Из ТаблицаСсылок Цикл
      
      ОбработкаПрерыванияПользователя();
      
      Н = Н + 1;
      
      ФормаИндикации.КомментарийЗначения = "Обработано: " + Н + " объектов " + " из " + КоличествоЗаписей + " (Неудача: "+Неудача+")";
      ФормаИндикации.Значение            = Н;
      
      Попытка
         Объект = СтрокаТаблицы.Данные.ПолучитьОбъект();
         Объект.УстановитьПометкуУдаления(Ложь);
      Исключение
          Неудача = Неудача + 1;
         Сообщить(ОписаниеОшибки());
      КонецПопытки; 
      
   КонецЦикла;
   
   Сообщить("Обработка завершена: " + ТекущаяДата());

КонецПроцедуры
Пишет, что удаляет 250 из 260 пометок. Но ничего не меняется.
Групповую обработку не предлагать. Хочу разобраться с этим...


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
не
Объект = СтрокаТаблицы.Данные.ПолучитьОбъект();
а
Объект = СтрокаТаблицы.Ссылка.ПолучитьОбъект();

а вообще плохо написана процедура, я поставил бы тройку.

Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 159
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal