Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Фев 2018, 05:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с макетом  (Прочитано 1367 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TamKar

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-28
  • Сайт: 
ЗапросОрг = новый Запрос;
         ЗапросОрг.Текст = "ВЫБРАТЬ
                           |   РасчетыйСчетОстаткиИОбороты.Организация КАК Организация,
                           |   РасчетыйСчет.ВидДвижения КАК ВидДвижения,
                           |   РасчетыйСчетОстаткиИОбороты.ВидДеятельности КАК ВидДеятельности,
                           |   РасчетыйСчетОстаткиИОбороты.Статья.Родитель КАК Родитель,
                           |   РасчетыйСчетОстаткиИОбороты.Статья КАК Статья,
                           |   РасчетыйСчетОстаткиИОбороты.СуммаПриход КАК СуммаПриход,
                           |   РасчетыйСчетОстаткиИОбороты.СуммаРасход КАК СуммаРасход,
                           |   РасчетыйСчет.Организация КАК Организация1,
                           |   РасчетыйСчет.Статья КАК Статья1
                           |ИЗ
                           |   РегистрНакопления.РасчетыйСчет КАК РасчетыйСчет
                           |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.РасчетыйСчет.ОстаткиИОбороты(&ДатаН, &ДатаК, , , ) КАК РасчетыйСчетОстаткиИОбороты
                           |      ПО РасчетыйСчет.Организация = РасчетыйСчетОстаткиИОбороты.Организация
                           |         И РасчетыйСчет.Статья = РасчетыйСчетОстаткиИОбороты.Статья
                           |         И РасчетыйСчет.ВидДеятельности = РасчетыйСчетОстаткиИОбороты.ВидДеятельности
                           |ГДЕ
                           |   РасчетыйСчет.Период >= &ДатаН
                           |   И РасчетыйСчет.Период <= &ДатаК
                           |   И РасчетыйСчет.Организация = &Организация
                           |
                           |СГРУППИРОВАТЬ ПО
                           |   РасчетыйСчетОстаткиИОбороты.Организация,
                           |   РасчетыйСчетОстаткиИОбороты.Статья,
                           |   РасчетыйСчет.ВидДвижения,
                           |   РасчетыйСчет.Организация,
                           |   РасчетыйСчет.Статья,
                           |   РасчетыйСчетОстаткиИОбороты.ВидДеятельности,
                           |   РасчетыйСчетОстаткиИОбороты.СуммаПриход,
                           |   РасчетыйСчетОстаткиИОбороты.СуммаРасход,
                           |   РасчетыйСчетОстаткиИОбороты.Статья.Родитель
                           |ИТОГИ
                           |   СУММА(СуммаПриход),
                           |   СУММА(СуммаРасход)
                           |ПО
                           |   Организация,
                           |   ВидДвижения,
                           |   ВидДеятельности,
                           |   Родитель,
                           |   Статья" ;
         ЗапросОрг.УстановитьПараметр("ДатаН",НачалоДня(ДатаНачала));
         ЗапросОрг.УстановитьПараметр("ДатаК",КонецДня(ДатаОканчание));
         ЗапросОрг.УстановитьПараметр("Организация",Организация);

   
   
РезультатОрг = ЗапросОрг.Выполнить();
      ВыборкаОрг = РезультатОрг.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Организация");
      
      Пока ВыборкаОрг.Следующий() Цикл
         ДоходОрганизация.Параметры.Заполнить(ВыборкаОрг);
         ТабДок.Вывести(Доход);
         ТабДок.Вывести(ДоходОрганизация, ВыборкаОрг.Уровень());
         РасходОрганизации.Параметры.Заполнить(ВыборкаОрг);
         ТабДок.Вывести(Расход);
         ТабДок.Вывести(РасходОрганизации,ВыборкаОрг.Уровень());
      ВыборкаДеятельностьОрг = ВыборкаОрг.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ВидДеятельности");
      Пока ВыборкаДеятельностьОрг.Следующий() Цикл
          ОбластьДеятельность.Параметры.Заполнить(ВыборкаДеятельностьОрг);
          ТабДок.Вывести(ОбластьДеятельность,ВыборкаДеятельностьОрг.Уровень());
          ОбластьДеятельностьРасход.Параметры.Заполнить(ВыборкаДеятельностьОрг);
          ТабДок.Вывести(ОбластьДеятельностьРасход,ВыборкаДеятельностьОрг.Уровень());
      ВыборкаРодительОрг = ВыборкаДеятельностьОрг.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Родитель");
      Пока ВыборкаРодительОрг.Следующий() Цикл
          ОбластьРодитель.Параметры.Заполнить(ВыборкаРодительОрг);
          ТабДок.Вывести(ОбластьРодитель,ВыборкаРодительОрг.Уровень());
          ОбластьРодительРасход.Параметры.Заполнить(ВыборкаРодительОрг);
          ТабДок.Вывести(ОбластьРодительРасход,ВыборкаРодительОрг.Уровень());
      ВыборкаСтатьяОрг = ВыборкаРодительОрг.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Статья");
      Пока ВыборкаСтатьяОрг.Следующий() Цикл
          ОбластьСтатья.Параметры.Заполнить(ВыборкаСтатьяОрг);
          ТабДок.Вывести(ОбластьСтатья,ВыборкаСтатьяОрг.Уровень());
          ОбластьСтатьяРасход.Параметры.Заполнить(ВыборкаСтатьяОрг);
          ТабДок.Вывести(ОбластьСтатьяРасход,ВыборкаСтатьяОрг.Уровень());
      КонецЦикла;
      КонецЦикла;   
      КонецЦикла;   
      КонецЦикла;   
         
   
   
   ТабДок.ЗакончитьАвтогруппировкуСтрок();
   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.ФиксацияСверху = 11;
   ТабДок.Защита = Истина;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать(Истина);
Выводи в строки макета в расходную часть и данные доходной части, помогите как мне вывести данные приходной части в приходной, где делаю я ошибку?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Наведите порядок в коде с помощью тех же комментариев
чтобы было видно, где, в каком месте, какая часть отчета выводится...

можете секции еще осмысленно поназывать...

в итоге будет проще разобраться.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн TamKar

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-28
  • Сайт: 
   Пояснение к макету


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4468
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5735
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6068
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4741
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2082
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
189 Сообщений
AIFrame AIFrame
81 Сообщений
alexandr_ll
41 Сообщений
BuhRust
29 Сообщений
wise wise
27 Сообщений
oleg-x
26 Сообщений
MuI_I_Ika MuI_I_Ika
25 Сообщений
pavl_vs
22 Сообщений
Кейли Кейли
21 Сообщений
andron81_81
20 Сообщений

* Кто онлайн

  • Точка Гостей: 153
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal