Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 23:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вылет приложения при установке галочки табличной части  (Прочитано 2968 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн fokas

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Программист 8.1
Дали мне документ и говорят - вылетает :xfbnsdfb: Удивленный, полез смотреть. В нем табличная часть с двумя реквизитами, где один из них номенклатура, а второй булево. Для колонки установлено редактирование непосредственно - чтобы сразу галочку ставить. При выборе номенклатуры, если она - группа, в таблицу тянется вся вложенная иерахия. И вот после такого подтягивания, галочка становится очень нежной и при нажатии сводит с ума приложение :nhsrm: Вылетает в прямом смысле...
Всякими шаманствами с бубном (фотография прилагается), заметил, если войти в режим редактирования любой строки, дальше всё работает как надо. Ну и как-то догадался программно заканчивать редактирование строки. Помогло.
А в чем проблема-то была? Подскажите плиз, для развития

Процедура ТаблицаНоменклатураОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)

Если ВыбранноеЗначение.ЭтоГруппа тогда
СтандартнаяОбработка = Ложь;

Таблица.Удалить(ЭлементыФормы.Таблица.ТекущаяСтрока);

НоменклатураВыборка = Справочники.Номенклатура.ВыбратьИерархически(ВыбранноеЗначение);
Пока НоменклатураВыборка.Следующий() Цикл
Если НоменклатураВыборка.ЭтоГруппа Тогда
Продолжить;
Иначе
НоваяСтрокаТаблицы = Таблица.Добавить();
НоваяСтрокаТаблицы.Номенклатура = НоменклатураВыборка.Ссылка;
НоваяСтрокаТаблицы.Флажек = Ложь;
КонецЕсли;
КонецЦикла;

ЭлементыФормы.Таблица.ЗакончитьРедактированиеСтроки(Ложь); // решение проблемы
КонецЕсли;

КонецПроцедуры

Наименования элементов изменил для наглядности :)


Оффлайн 1Cnastroika

Я несколько раз встречался с случаями, когда 1С закрывается в некоторой ситуации. Я думаю, что при правильной работе платформы и ошибках в конфигурации должны вызываться исключения и выдаваться сообщения об ошибках. Я думаю, что закрытие 1С связано с ошибками в платформе 1С.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Какая вложенность иерархии? Какой Релиз платформы?
Наблюдалось аварийное завершение при вложенности более 2х групп и если группа развернута, на платформах начиная 8.2.14 по 8.2.15.301 (на 8.2.15.310 не получилось воспроизвести ошибку)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1961
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3066
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3100
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 672
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 257
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 286
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal