Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 18:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура ТоварыОбработкаВыбора  (Прочитано 4017 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
У меня есть форма документа. На ней расположены 2 кнопки. При нажатии на каждую из них выполняется свое действие. Первая кнопка отвечает за подбор. Вторая кнопка за загрузку из Excel.
Проблема заключается в том что Процедура ТоварыОбработкаВыбора относится и к 1-ой и ко 2-ой кнопке и сделать 2 разных процедуры не возможно. На данный момент у меня пока при нажатии на подбор и загрузку из Excel выполняется одно и то же действие, а это не правильно.
Что мне надо прописать в процедуре чтоб в зависимости от того на какую кнопку я нажимаю выполнялся нужный мне код?


Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Помогите мне разобраться как обращаться к той или иной кнопке в одной процедуре? Как в 2х разных процедурах я знаю, но в данном случае мне только 1 процедуру можно использовать, так как она системная.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Есть 2 кнопки, соответственно 2 обработчика события КнопкаНажатие().
В ней вызывайте процедуру с соответствующим параметром...

Процедура КнопкаПодборНажатие()
ВыполнитьЗагрузку(1);
КонецПроцедуры

Процедура КнопкаЗагрузкаИзЭксельНажатие()
ВыполнитьЗагрузку(2);
КонецПроцедуры

В ТоварыОбработкаВыбора() вы обрабатываете ВыбранноеЗначение...
А вот поместить в него можно все, что угодно...
Например структуру: первый ключ - признак, откуда получен список номенклатуры (из подбора или из экселя), а второй - сам список номенклатуры...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Либо я  вас не понял, либо вы меня.
Поясняю снова. У 2-ух кнопок на одной форме которые относятся к табличной части есть обработка выбора. Как мне в одной процедуре обращаться к 2ум разным кнопкам, в зависимости от того какую нажимаю?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В ОбработкеВыбора() вы не "обращаетесь к кнопкам" а обрабатываете параметр ВыбранноеЗначение, правильно же?
Только вам нужно определить, какая из процедур "положила" туда список номенклатуры.
Или я действительно что-то не понимаю?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
В Форме я через свойстве я для кнопки указываю процедуру ОбработкаВыбора. В итоге у меня для 2-ух кнопок процедура с одинаковым названием.
Как мне в одной процедуре обращаться к 2ум разным кнопкам, в зависимости от того какую нажимаю?

У меня все работает. Мне нужна доработка. Например при нажатие на подбор выполняется одно, а при загрузке из excel другое. Как мне в одной процедуре это сделать?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Процедура КнопкаПодборНажатие(Элемент)
ОбработкаВыбора(1);
КонецПроцедуры

Процедура КнопкаЗагрузкаИзЭксельНажатие(Элемент)
ОбработкаВыбора(2);
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Уже на правильном понимание вещей.
А теперь представь что в одной процедуре две обработки выбора. Мне надо так сделать. Как мне в зависимости от ситуации сделать что нужная обработка выбора срабатывала?

Еще 2 небольших вопроса.
Где сохрнаяются картинки которые в конфу загружаются?
При загрузке сначала появляется окно а потом заход в конфу. Как в это окне сделать надпись и картинку? Я про окно в котором определяется какая это конфа)))

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Если у тебя обработчик события нажатия один и тот же - что ессно возможно, но не рекомендуется методологически (читай на диске ИТС) - то обрабатывай параметр "Элемент".
Из него можно узнать например ИМЯ кнопки, которая вызвала событие...

В свойствах конфигурации есть 2 свойства: "Логотип" и "Заставка"...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн fokas

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Программист 8.1
Процедура НажатиеКнопки(Элемент)

Если Элемент.Имя = "Кнопка1" Тогда
 // действия при нажатии на кнопку с именем "Кнопка1"
ИначеЕсли Элемент.Имя = "Кнопка2" Тогда
 // действия при нажатии на кнопку с именем "Кнопка2"
КонецЕсли;

КонецПроцедуры

Такой подход вполне себя может оправдать, чтобы там в ИТС не говорили :) У нас для документов и справочников программно добавляется подменю "Дополнительно" со всякими отчетами и прочими приятностями. Добавлять процедуры для каждой кнопки из подменю - только код засорять зазря. А так, всего пару строк


Теги:
 

Процедура "ОбработкаПроведения"

Автор demon3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1272
Последний ответ 22 Июн 2016, 14:46
от demon3
Процедура "Подсчет площади"

Автор Seregin63Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2618
Последний ответ 28 Ноя 2013, 13:00
от Seregin63
1c 8.2: как называется процедура/функция, которая вызывается при вводе значения в поле на форме?

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1570
Последний ответ 08 Сен 2014, 08:28
от cska-fanat-kz
Процедура госрегистрации ИП и юрлиц будет проходить в течение трех дней

Автор newsРаздел Новости

Ответов: 0
Просмотров: 750
Последний ответ 03 Апр 2014, 15:16
от news
Процедура Инициализации при создании внешней обработки таб. частей

Автор crow1983Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 11699
Последний ответ 23 Авг 2010, 16:51
от crow1983

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 349
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal