Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 14:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не хочет записывать набор записей регистра  (Прочитано 7220 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
Пошагово проверял - в конце процедуры Набор содержит заполненные колонки СуммаРуб и СуммаДол, но после Набор.Записать() они остаются пустые. В чём может быть проблема?
Цитировать
Процедура РасчетОН(Ссылка) Экспорт
   Набор = РегистрыРасчета.ОсновныеНачисления.СоздатьНаборЗаписей();
   Набор.Отбор.Регистратор.Установить(Ссылка);
   
   Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
   |   ОсновныеНачисленияДанныеГрафика.НомерСтроки,
   |   ОсновныеНачисленияДанныеГрафика.ВидРасчета,
   |   ОсновныеНачисленияДанныеГрафика.Сотрудник,
   |   ОсновныеНачисленияДанныеГрафика.Подразделение,
   |   ОсновныеНачисленияДанныеГрафика.Размер,
   |   ОсновныеНачисленияДанныеГрафика.ЗначениеФактическийПериодДействия,
   |   Ставки.Сумма
   |ИЗ
   |   РегистрРасчета.ОсновныеНачисления.ДанныеГрафика(Регистратор = &Регистратор) КАК ОсновныеНачисленияДанныеГрафика
   |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.Ставки КАК Ставки
   |      ПО ОсновныеНачисленияДанныеГрафика.ЗначениеФактическийПериодДействия >= Ставки.Мин
   |         И ОсновныеНачисленияДанныеГрафика.ЗначениеФактическийПериодДействия < Ставки.Макс
   |         И ОсновныеНачисленияДанныеГрафика.Подразделение = Ставки.Подразделение";
   Запрос.УстановитьПараметр("Регистратор", Ссылка);
   Результат = Запрос.Выполнить();
   
   Выборка = Результат.Выбрать();
   Отбор = Новый Структура;
   Отбор.Вставить("Валюта", Справочники.Валюты.НайтиПоНаименованию("Доллар"));
   КурсДоллара = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(Ссылка.Дата, Отбор).Курс;   
   Отбор.Удалить("Валюта");
   Отбор.Вставить("НомерСтроки");
   Для каждого Стр Из Набор Цикл
      Отбор.НомерСтроки = Стр.НомерСтроки;
      Выборка.Сбросить();
      Если Выборка.НайтиСледующий(Отбор) Тогда
         Если Выборка.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисления.Оклад Тогда
            Стр.СуммаРуб = Выборка.ЗначениеФактическийПериодДействия * Выборка.Сумма;
            Стр.СуммаДол = стр.СуммаРуб / КурсДоллара;
         КонецЕсли;    
      КонецЕсли;
   КонецЦикла;
   Набор.Записать();
   
КонецПроцедуры


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
РегистрыРасчета.ОсновныеНачисления.Записывать = Истина; не помогает?
Кнопочка Спасибо - слева!

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
Такого свойства нет.
Оно только у Движения.ОсновныеНач...
Но Движения доступны только в модуле объекта-регистратора. В обработке проведения, перед вызовом этой процедуры, установлено
Движения.ОсновныеНачисления.Записывать = Истина;

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Точно, Движения.....
Передай Движеня из объекта регистратора в свою процедуру Процедура РасчетОН(Ссылка, Движения) Экспорт
Кнопочка Спасибо - слева!

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
Нет, не работает..
У меня скоро психоз начнётся...

Буду очень признателен, если кто-то соизволит посмотреть выгрузку (документ НачислениеЗарплаты) или предложит какой-нибудь выход..

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
В обработке проведения надо было убрать "Движения.ОсновныеНачисления.Записывать = Истина;"
Ну и бред...

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Набор = РегистрыРасчета.ОсновныеНачисления.СоздатьНаборЗаписей();
Набор.Отбор.Регистратор.Установить(Ссылка);
Набор.Прочитать();
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
как то так вышло
Кнопочка Спасибо - слева!

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
Набор = РегистрыРасчета.ОсновныеНачисления.СоздатьНаборЗаписей();
Набор.Отбор.Регистратор.Установить(Ссылка);
Набор.Прочитать();
У меня в модуле стояло прочитать) Но если в модуле стоит "Движения.ОсновныеНачисления.Записывать = Истина;", то он потом не запишет набор. Но за уделённое время спасибо)

sergejK74, оригинально) Спасибо


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10968
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Остатки из бух. регистра в разрезе "добавленного" реквизита.

Автор ef0dinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 132
Последний ответ 20 Апр 2018, 17:06
от ef0din
Можно ли програмно изменить одну из колонок таблицы формы регистра сведений при создании формы

Автор RassvetniyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1603
Последний ответ 21 Фев 2016, 17:00
от vitasw
Запрос к виртуальной таблице регистра накопления: что писать в "Произвольном Выражении"?

Автор Светлана РождественскаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 323
Последний ответ 27 Окт 2017, 21:02
от MuI_I_Ika
Заполнение регистра сведений "Авансы сотрудникам организаций"

Автор rielter_alРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1944
Последний ответ 02 Дек 2015, 11:50
от rielter_al

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
73 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
41 Сообщений
wise wise
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
Анюта17
26 Сообщений

* Кто онлайн

  • Точка Гостей: 777
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal