Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с запросом  (Прочитано 4865 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Помогите доделать запрос чтоб в подвал выводилась сумма прописью, количество наименований.
А еще нужно чтоб в область товары выводился номер строки.   
Я добавил выгрузку базы чтоб могли помочь мне. Весит меньше 100кб - так что помогите пожалуйста.

Макет = Документы.РеализацияТоваров.ПолучитьМакет("Печать");

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   РеализацияТоваров.Номер,
      |   РеализацияТоваров.Дата
      |ИЗ
      |   Документ.РеализацияТоваров КАК РеализацияТоваров
      |ГДЕ
      |   РеализацияТоваров.Ссылка В(&Ссылка)
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   РеализацияТоваровТовары.Номенклатура КАК Номенклатура,
      |   СУММА(РеализацияТоваровТовары.Количество) КАК Количество,
      |   РеализацияТоваровТовары.ЕдиницаИзмерения,
      |   СУММА(РеализацияТоваровТовары.Сумма) КАК Сумма,
      |   СУММА(РеализацияТоваровТовары.Цена) КАК Цена
      |ИЗ
      |   Документ.РеализацияТоваров.Товары КАК РеализацияТоваровТовары
      |ГДЕ
      |   РеализацияТоваровТовары.Ссылка В(&Ссылка)
      |
      |СГРУППИРОВАТЬ ПО
      |   РеализацияТоваровТовары.Номенклатура,
      |   РеализацияТоваровТовары.ЕдиницаИзмерения,
      |ИТОГИ
      |   СУММА(Сумма)
      |ПО
      |   ОБЩИЕ";
        Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Результат = Запрос.ВыполнитьПакет();

   Шапка = Макет.ПолучитьОбласть("Шапка");
   ОбластьШапка = Макет.ПолучитьОбласть("ТоварыШапка");
   ОбластьТовары = Макет.ПолучитьОбласть("Товары");
   ОбластьИтог = Макет.ПолучитьОбласть("Подвал");
   ТабДок.Очистить();
   ВставлятьРазделительСтраниц = Ложь;
   ВыборкаШапка = Результат[0].Выбрать();
   ВыборкаШапка.Следующий();
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;


      Шапка.Параметры.Заполнить(ВыборкаШапка);
      ТабДок.Вывести(Шапка, ВыборкаШапка.Уровень());

      ТабДок.Вывести(ОбластьШапка);
   
      ВыборкаОбщийИтог = Результат[1].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

       ВыборкаОбщийИтог.Следующий();   
      ВыборкаТЧ = ВыборкаОбщийИтог.Выбрать();
         Пока ВыборкаТЧ.Следующий() Цикл
         ОбластьТовары.Параметры.Заполнить(ВыборкаТЧ);
         ТабДок.Вывести(ОбластьТовары, ВыборкаТЧ.Уровень());
   
      КонецЦикла;

      ОбластьИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
      ТабДок.Вывести(ОбластьИтог);


Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
ВыборкаШапка = Результат[0].Выбрать();
   ВыборкаШапка.Следующий();
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;


      Шапка.Параметры.Заполнить(ВыборкаШапка);
      ТабДок.Вывести(Шапка, ВыборкаШапка.Уровень());

      ТабДок.Вывести(ОбластьШапка);
   
      ВыборкаОбщийИтог = Результат[1].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

       ВыборкаОбщийИтог.Следующий();   
      ВыборкаТЧ = ВыборкаОбщийИтог.Выбрать();
         Пока ВыборкаТЧ.Следующий() Цикл
         ОбластьТовары.Параметры.Заполнить(ВыборкаТЧ);
         ТабДок.Вывести(ОбластьТовары, ВыборкаТЧ.Уровень());
   
      КонецЦикла;

      ОбластьИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
      ТабДок.Вывести(ОбластьИтог);

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
омогите доделать запрос чтоб в подвал выводилась сумма прописью, количество наименований.
А еще нужно чтоб в область товары выводился номер строки.   
Я добавил выгрузку базы чтоб могли помочь мне. Весит меньше 100кб - так что помогите пожалуйста.

Макет = Документы.РеализацияТоваров.ПолучитьМакет("Печать");

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   РеализацияТоваров.Номер,
      |   РеализацияТоваров.Дата
      |ИЗ
      |   Документ.РеализацияТоваров КАК РеализацияТоваров
      |ГДЕ
      |   РеализацияТоваров.Ссылка В(&Ссылка)
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   РеализацияТоваровТовары.Номенклатура КАК Номенклатура,
      |   СУММА(РеализацияТоваровТовары.Количество) КАК Количество,
      |   РеализацияТоваровТовары.ЕдиницаИзмерения,
      |   СУММА(РеализацияТоваровТовары.Сумма) КАК Сумма,
      |   СУММА(РеализацияТоваровТовары.Цена) КАК Цена
      |ИЗ
      |   Документ.РеализацияТоваров.Товары КАК РеализацияТоваровТовары
      |ГДЕ
      |   РеализацияТоваровТовары.Ссылка В(&Ссылка)
      |
      |СГРУППИРОВАТЬ ПО
      |   РеализацияТоваровТовары.Номенклатура,
      |   РеализацияТоваровТовары.ЕдиницаИзмерения,
      |ИТОГИ
      |   СУММА(Сумма)
      |ПО
      |   ОБЩИЕ";
        Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Результат = Запрос.ВыполнитьПакет();

   Шапка = Макет.ПолучитьОбласть("Шапка");
   ОбластьШапка = Макет.ПолучитьОбласть("ТоварыШапка");
   ОбластьТовары = Макет.ПолучитьОбласть("Товары");
   ОбластьИтог = Макет.ПолучитьОбласть("Подвал");
   ТабДок.Очистить();
   ВставлятьРазделительСтраниц = Ложь;
   ВыборкаШапка = Результат(0).Выбрать();
   ВыборкаШапка.Следующий();
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;


      Шапка.Параметры.Заполнить(ВыборкаШапка);
      ТабДок.Вывести(Шапка, ВыборкаШапка.Уровень());

      ТабДок.Вывести(ОбластьШапка);
   
      ВыборкаОбщийИтог = Результат[1].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

       ВыборкаОбщийИтог.Следующий();   
      ВыборкаТЧ = ВыборкаОбщийИтог.Выбрать();
         Пока ВыборкаТЧ.Следующий() Цикл
         ОбластьТовары.Параметры.Заполнить(ВыборкаТЧ);
         ТабДок.Вывести(ОбластьТовары, ВыборкаТЧ.Уровень());
   
      КонецЦикла;

      ОбластьИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
      ТабДок.Вывести(ОбластьИтог);

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
ВыборкаШапка = Результат(0).Выбрать();
   ВыборкаШапка.Следующий();
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;


      Шапка.Параметры.Заполнить(ВыборкаШапка);
      ТабДок.Вывести(Шапка, ВыборкаШапка.Уровень());

      ТабДок.Вывести(ОбластьШапка);
   
      ВыборкаОбщийИтог = Результат(1).Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

       ВыборкаОбщийИтог.Следующий();   
      ВыборкаТЧ = ВыборкаОбщийИтог.Выбрать();
         Пока ВыборкаТЧ.Следующий() Цикл
         ОбластьТовары.Параметры.Заполнить(ВыборкаТЧ);
         ТабДок.Вывести(ОбластьТовары, ВыборкаТЧ.Уровень());
   
      КонецЦикла;

      ОбластьИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
      ТабДок.Вывести(ОбластьИтог);

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Извините за повторение с первого раза не получилось нормально код выложить. Проблема все еще актуальна. Жду помощи.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Вот и база на всякий случай!

Оффлайн AntonB

  • Модератор
  • *****
  • Сообщений: 402
  • РЕПУТАЦИЯ: 74
  • КПД: 18%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 8.1
а чего в УТ не посмотреть, как Реализации печатаются?
Предлагаю полный ИТ сервис небольшой организации в Москве (приходящий сисадмин+1С7.7,1С8.x)

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
О номере строки не может быть и речи. Тыже группируешь одинаковые товары.
А чтобы получить количество, в итоги добавь количество номенклатуры:
ИТОГИ
   СУММА(Сумма),
   КОЛИЧЕСТВО(Номенклатура)
ПО
   ОБЩИЕ

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
А как вывести тогда мне Количество?
И как мне вывести Сумма прописью в подвал и номер строки в табличную часть?

Оффлайн DirecTwiX

  • ***
  • Сообщений: 185
  • РЕПУТАЦИЯ: 19
  • КПД: 10%
  • Регистрация: 2012-03-27
  • Сайт: 
  • Профессия: Программист 1С
А как вывести тогда мне Количество?
И как мне вывести Сумма прописью в подвал и номер строки в табличную часть?
Количество выводить так же как и выводил.
Если нужен номер строки, то убери группировку по номенклатуре и выбирай из документа ещё и номер строки.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5552
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5888
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4367
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1979
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 377
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal