Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""  (Прочитано 6081 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lindelu

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-28
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте!
Возникла проблема при создании нового пользователя с новой ролью. Может, кто сталкивался с подобным?
1с 8.2.14.540 конф.- "Управление торговлей и взаимоотношениями с клиентами (CRM)", редакция 1.1 (1.1.10.2) .Надо сделат так, чтобы в удаленном подразделении видели только свои документы.
Решила установить ограничения доступа к данным на уровне записей по подразделениям, поскольку в этой конфе предусмотрено только ограничение по организациям и контрагентам, стала воять сама. Сделала по такому алгоритму:

Ограничения доступа по подразделениям

В конфигураторе:

Перечисления/ВидыОбъектовДоступа/Значение - добавить Подразделения

РегистрыСведений/ОбъектыДоступаДокументов/Измерения/ОбъектДоступа - добавить тип Справочник.Подразделения

РегистрыСведений/НастройкиПравДоступаПользователей/Измерения/ОбъектДоступа - добавить тип Справочник.Подразделения
РегистрыСведений/НастройкиПравДоступаПользователей/Измерения/ВладелецПравДоступа - добавить тип Справочник.Подразделения

Общие модули/НастройкаПравДоступа/ПолучитьВидОбъектаДоступа:
Функция ПолучитьВидОбъектаДоступа(ОбъектДоступа) Экспорт

Если ТипЗнч(ОбъектДоступа) = Тип("СправочникСсылка.Организации") Тогда
Возврат Перечисления.ВидыОбъектовДоступа.Организации;
//ДОБАВЛЯЕМ ТЕКСТ   
ИначеЕсли ТипЗнч(ОбъектДоступа) = Тип("СправочникСсылка.Подразделения") Тогда
Возврат Перечисления.ВидыОбъектовДоступа.Подразделения;
//ДОБАВЛЯЕМ ТЕКСТ   
ИначеЕсли ТипЗнч(ОбъектДоступа) = Тип("СправочникСсылка.ГруппыДоступаККонтрагентам") Тогда
Возврат Перечисления.ВидыОбъектовДоступа.Контрагенты;
Иначе
Возврат Перечисления.ВидыОбъектовДоступа.ПустаяСсылка();
КонецЕсли;

КонецФункции

Для интерактивной настройки прав доступа - необязательная часть

Обработки/НастройкаПравДоступа/Формы/НастройкаПравДоступа/Форма - добавить копированием страницу "Поразделения", добавить копированием на страницу табличное поле ТаблицаПравДоступа_Подразделения

Обработки/НастройкаПравДоступа/Формы/НастройкаПравДоступа/Форма/ПередОткрытием:
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

Если НЕ ПараметрыСеанса.ИспользоватьОграниченияПравДоступаНаУровнеЗаписей Тогда
Предупреждение("В конфигурации отключено использование ограничения прав доступа не уровне записей.");
Отказ = Истина;
Возврат;
КонецЕсли;

ТипыОбъектовДоступа = Новый Структура;

ТипыОбъектовДоступа.Вставить("Организации", Тип("СправочникСсылка.Организации"));
ТипыОбъектовДоступа.Вставить("Контрагенты", Тип("СправочникСсылка.ГруппыДоступаККонтрагентам"));
//ДОБАВЛЯЕМ ТЕКСТ
ТипыОбъектовДоступа.Вставить("Кассы", Тип("СправочникСсылка.Подразделения"));
//ДОБАВЛЯЕМ ТЕКСТ


СсылкаОбъекта = ЭтаФорма.КлючУникальности;
МетаданныеОбъекта = СсылкаОбъекта.Метаданные();

Если Не НаличиеПраваНаЧтениеСсылки(СсылкаОбъекта) Тогда
Предупреждение("Отсутствует право на чтение объекта!");
Отказ = Истина;
Возврат;
КонецЕсли;

НастройкаПользователя = ТипЗнч(СсылкаОбъекта) = Тип("СправочникСсылка.ГруппыПользователей");

СформироватьЗакладки();
ОбновитьОтборПоНаследуемымЗаписям();

ПраваДоступаПользователей = РегистрыСведений.НастройкиПравДоступаПользователей.СоздатьНаборЗаписей();
НастройкаПравДоступа.ПрочитатьПраваДоступаКОбъекту(ПраваДоступаПользователей, СсылкаОбъекта);
ПрочитатьТаблицыПравДоступа(ПраваДоступаПользователей);

Заголовок = Заголовок + ": " + ?(НЕ ЗначениеЗаполнено(МетаданныеОбъекта.Синоним), МетаданныеОбъекта.Имя, МетаданныеОбъекта.Синоним) + ": " + ?(НЕ ЗначениеЗаполнено(СсылкаОбъекта),"<Весь справочник>", Строка(СсылкаОбъекта));

КонецПроцедуры


Дальше создала новую роль "Менеджер1" копированием роли "Полные права" и добавила ограничения доступа к данным для документов по аналогии с шаблонами ограничений по организации. В пользовательском режиме добавила нового пользователя и присвоила ему роли "Менеджер1" и "Пользователь", добавила его в группу пользователей для которой будут действовать ограничения, определила некоторые дополнительные права. Открываю документ Приходный Кассовый Ордер все отрабатывает супер: и добавляет новые документы, и проводит, и отображает только те документ, которые надо. А , например, документ Реализация товаров не дает даже создать, выдает ошибку: "{ОбщийМодуль.ОбщегоНазначения.Модуль(1958)}: Невозможно обработать параметр "ПрофильПолномочийПользователя" для получения значения  ВызватьИсключение СтрокаИсключения;" Также не получается под этим пользователем зайти в Сервис-Настройки пользователя - та же ошибка. Скорее всего и еще где-то вылезает, просто пока только на этих объектах эксперименты проводила.  Помогите советом, пожалуйста, если есть идеи. Заранее спасибо)


Оффлайн lindelu

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-28
  • Сайт: 
  • Профессия: Программист 8.1
Откликнитесь, плизззз!!!! Ломаю голову, ошибку устранить не получается((

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ну ты посмотри что обрабатывается тут - ОбщийМодуль.ОбщегоНазначения - строка 1958
"ctrl+g - перейти к строке"
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн lindelu

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-28
  • Сайт: 
  • Профессия: Программист 8.1
Прошу прощения,я в 1С и  впринципе в программировании новичок, поэтому всех тонокостей не знаю. В общий модуль.ОбщегоНазначения зашла, ошибка в функции ПолучитьЗначениеПеременной. Запускаю отладчик эта функция, например, возвращает значение переменной "ЗначенияДополнительныхПравПользователя", а затем пытается получить значение переменной "ПрофильПолномочийПользователя" и вылетает в ветку:
 Иначе
СтрокаИсключения = "Невозможно обработать параметр " + """" + ИмяПараметра + """" + " для получения значения";
ВызватьИсключение СтрокаИсключения;

Дальше пока разобраться не получается, при этом попробовала другие роли (кроме Полные права) вместе с ролью "пользователь" подключить пользователю - результат тот же. Я нашла информацию, что при новом подходе в 1с 8.2 используется не роль "пользователь" в качестве роли дающей права на вход в систему, а роль "Базовые права", у меня 1с 8.2, но конфа то старая. Может это чушь, но я  уже даже не знаю в чем искать ошибку((

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ужс...
Наверное в структуре "ЗначенияДополнительныхПравПользователя" нету свойства "ПрофильПолномочийПользователя" соответственно его туда нужно либо добавить либо не получать это свойство...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн lindelu

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-28
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо большое за помощь! Косяк был в обновлениях Раруса, после обновления все заработало)


Теги:
 

Закрытие месеца, ошибка при закрытие 26сч

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4119
Последний ответ 26 Июл 2013, 11:00
от Gendelf
ОШИБКА 1С 8.3. Файл не найден в хранилище файлов. Возможно файл удален антивирусной программой. Обратитесь к администратору

Автор Сергей БатуринРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 6353
Последний ответ 18 Май 2016, 18:18
от Сергей Батурин
При попытке проведения документов по НДФЛ (справка 2 НДФЛ ) вылезает ошибка:

Автор klaus38Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2818
Последний ответ 19 Фев 2015, 20:54
от vitasw
При входе пользователя 1с77 по RDP (Server2008) выдается ошибка и выпадает 1с77

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1655
Последний ответ 07 Дек 2016, 09:17
от alex0402
Как создать в 1С 8.2 группы контроагентов когда при ножатие папочки с плюсом выходит ошибка при устоновке значения атрибута текста (ОсновнойМенеджерПокупателя)

Автор fat001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2766
Последний ответ 02 Апр 2014, 23:11
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 225
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal