Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 07:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сделать окно с предупреждением?  (Прочитано 2982 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Spacer21

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Купили 1С 8.2, но бухгалтер "тормозит" переход на нее с 7.7 вот хочу чтобы при запуске 7.7. выходило окно с сообщением типа: "срок действия ключа (лицензии) истекает через Х дней". Помогите это сделать.


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Добавь константу КолДнейДоКонца тип Число.

в 7ке в глобальном модуле:
ищим:
ПРоцедура ПриНачалеРаботыСистемы()
*** много строчек много букв***
//вот тут
скДней = Константа.КолДнейДоКонца;
Если скДней >=1 Тогда
Предупреждение("Через " + СкДней +  " запусков закроемся!!!");
Константа.КолДнейДоКонца = Константа.КолДнейДоКонца - 1;
Иначе

ЗавершитьработуСистемы();
КонецЕсли;
КонецПроцедуры

Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Добавь константу КолДнейДоКонца тип Число.

в 7ке в глобальном модуле:
ищим:
ПРоцедура ПриНачалеРаботыСистемы()
*** много строчек много букв***
//вот тут
скДней = Константа.КолДнейДоКонца;
Если скДней >=1 Тогда
Предупреждение("Через " + СкДней +  " запусков закроемся!!!");
Константа.КолДнейДоКонца = Константа.КолДнейДоКонца - 1;
Иначе

ЗавершитьработуСистемы();
КонецЕсли;
КонецПроцедуры



т.е. при каждом новом сеансе у нас константа будет уменьшаться?
дни нужно считать, а не количество входов в систему.

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Вам идею подкинули. можете заменить константу "число" на "Дату" и немного переделать вичисление. Непомню можно сразу вічислять разность дат или нет. Если нет то перевести дату в число (функция  НомерДняГода(<?>))  и вычеслять радность этих чисел.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
41 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 343
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal