Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Методы  (Прочитано 4251 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Методы
« Первое сообщение: 27 Апр 2012, 09:07 »
{Документ.ПоступлениеТоваров.МодульМенеджера(139)}: Метод объекта не обнаружен (Выбрать)
   ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
В упор не пойму почему вылазиет такая ошибка. Метод этот в 1с как я понимаю есть. Исправьте мне пожалуйста.   

Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ПоступлениеТоваров.Номер,
      |   ПоступлениеТоваров.Дата,
      |   ПоступлениеТоваров.Контрагент,
      |   ПоступлениеТоваров.Договор,
      |   ПоступлениеТоваров.Склад
      |ИЗ
      |   Документ.ПоступлениеТоваров КАК ПоступлениеТоваров
      |ГДЕ
      |   ПоступлениеТоваров.Ссылка В(&Ссылка)
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   ПоступлениеТоваровТовары.НомерСтроки,
      |   ПоступлениеТоваровТовары.Номенклатура,
      |   ПоступлениеТоваровТовары.ЕдиницаИзмерения,
      |   ПоступлениеТоваровТовары.Количество,
      |   ПоступлениеТоваровТовары.СтавкиНДС,
      |   ПоступлениеТоваровТовары.ЦенаЗакупочная,
      |   ПоступлениеТоваровТовары.СуммаЗакупочная КАК СуммаЗакупочная,
      |   ПоступлениеТоваровТовары.ПроцентНаценки,
      |   ПоступлениеТоваровТовары.СуммаНаценки КАК СуммаНаценки,
      |   ПоступлениеТоваровТовары.ЦенаРозница,
      |   ПоступлениеТоваровТовары.СуммаРозница КАК СуммаРозница
      |ИЗ
      |   Документ.ПоступлениеТоваров.Товары КАК ПоступлениеТоваровТовары
      |ГДЕ
      |   ПоступлениеТоваровТовары.Ссылка В(&Ссылка)
      |ИТОГИ
      |   СУММА(СуммаЗакупочная),
      |   СУММА(СуммаНаценки),
      |   СУММА(СуммаРозница)
      |ПО
      |   ОБЩИЕ";
   
   Запрос.Параметры.Вставить("Ссылка", Ссылка);   
   Результат = Запрос.ВыполнитьПакет();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
   ОбластьТоварыШапка = Макет.ПолучитьОбласть("ТоварыШапка");
   ОбластьТовары = Макет.ПолучитьОбласть("Товары");
   ОбластьИтог = Макет.ПолучитьОбласть("Подвал");
   ТабДок.Очистить();
   ВставлятьРазделительСтраниц = Ложь;
   ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

    ВыборкаОбщийИтог.Следующий();      // Общий итог

    //Вставить обработку выборки ВыборкаОбщийИтог

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;

      ТабДок.Вывести(ОбластьЗаголовок);

      ОбластьШапка.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
      ТабДок.Вывести(ОбластьШапка, ВыборкаДетальныеЗаписи.Уровень());

      ТабДок.Вывести(ОбластьТоварыШапка);
      //ВыборкаТовары = ВыборкаДетальныеЗаписи.Выбрать();
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
       ОбластьТовары.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
       ТабДок.Вывести(ОбластьТовары, ВыборкаДетальныеЗаписи.Уровень());
    КонецЦикла;
   
       ВыборкаДетальныеЗаписи = ВыборкаОбщийИтог.Выбрать();
       ОбластьИтог.Параметры.СуммаРозница = ВыборкаДетальныеЗаписи.СуммаРозница;
       ОбластьИтог.Параметры.СуммаНаценки = ВыборкаДетальныеЗаписи.СуммаНаценки;
       ОбластьИтог.Параметры.СуммаЗакупочная = ВыборкаДетальныеЗаписи.СуммаЗакупочная;
    ТабДок.Вывести(ОбластьИтог);
   КонецЦикла;
   


Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Методы
« Ответ #1: 27 Апр 2012, 09:17 »
Помогите решить интересную задачу

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Методы
« Ответ #2: 27 Апр 2012, 09:30 »
ВыполнитьПАКЕТ()!!!

в переменной "Результат" хранится МАССИВ результатов запроса!
Т.е. надо

Выборка = Результат[0].Выбрать(...);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Методы
« Ответ #3: 27 Апр 2012, 10:12 »
получилось...тема закрыта


Теги:
 

Методы обложения НДФЛ компенсации за использование работником личного имущества в служебных целях

Автор newsРаздел Новости

Ответов: 0
Просмотров: 812
Последний ответ 05 Май 2015, 21:05
от news
Обновление формы по событию, методы Оповестить() + ОбработкаОповещения()

Автор mixqnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 19840
Последний ответ 28 Сен 2012, 17:55
от mixqn
Как получить методы и свойства стандартных объектов

Автор tmpniklРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1666
Последний ответ 20 Мар 2015, 14:56
от cska-fanat-kz
Методы распределения общехозяйственных и общепроизводственных расходов

Автор artem5Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 242
Последний ответ 29 Май 2017, 15:55
от Геннадий ОбьГЭС
Методы распределение прямых расходов в 1с 8.3

Автор Юлия ЗавадскаяРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 916
Последний ответ 21 Янв 2016, 15:53
от Юлия Завадская

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 770
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal