Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 11:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: шаблон excel  (Прочитано 3747 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
 
Здравствуйте. Мне нужно загружать шаблон . Заранее какая строка и колонка первой будет при считывание и загрузки данных не известна. Каждый раз будет разный шаблон. Как мне реализовать код для такого случая?


Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: шаблон excel
« Ответ #1: 25 Апр 2012, 14:19 »

Пожалуйста помогите

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Re: шаблон excel
« Ответ #2: 25 Апр 2012, 14:41 »
если у тебя алгоритм загрузки будет одинаков, то в обработке загрузки можешь сделать настройки типа "ПутьКфайлуШаблона" - строка, "НомерПервойСтрокиДляОбработки" - число и "НомерПервойКолонкиДляОбработки" - число и в процедуре загрузки использовать значения этих настроек

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: шаблон excel
« Ответ #3: 25 Апр 2012, 21:14 »
Есть такой код. В нем прописано с условием что известно в какой строке определенная колонка.  А если заранее не известно, то какой код должен быть. Мне надо чтоб автоматически определяло 1-ые данные это 1,1 или 1,2 или 2,1 и т.п. - как сделать?

Док = ПолучитьCOMОбъект(ПутьКФайлу);

   Наименование= Док.Sheets(1).Cells(1,2).Value;
    счСтроки = 1;
   
   Пока СокрЛП(Наименование) <> "" Цикл   
      
      Артикул = Док.Sheets(1).Cells(СчСтроки,1).Value;
       //Наименование= Док.Sheets(1).Cells(СчСтроки,2).Value;                        
      Выборка = ПолучитьНоменклатуру(Наименование, Артикул);
      Если ЗначениеЗаполнено(Выборка) Тогда
         НоваяСтрока = ТаблицаЗначений.Добавить();
         НоваяСтрока.Номенклатура = Выборка.Ссылка;
         НоваяСтрока.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
         НоваяСтрока.Количество = Док.Sheets(1).Cells(СчСтроки,3).Value;
         НоваяСтрока.ЦенаЗакупочная = Число(Док.Sheets(1).Cells(СчСтроки,4).Value);
         НоваяСтрока.СуммаЗакупочная = Число(Док.Sheets(1).Cells(СчСтроки,5).Value);
         НоваяСтрока.ПроцентНаценки = ПолучитьПроцент(ДоговорКонтрагента, Контрагент, НоваяСтрока.ЦенаЗакупочная);
         НоваяСтрока.СуммаНаценки = НоваяСтрока.ПроцентНаценки /100 * НоваяСтрока.ЦенаЗакупочная;
         НоваяСтрока.ЦенаРозница = НоваяСтрока.ПроцентНаценки /100 * НоваяСтрока.ЦенаЗакупочная + НоваяСтрока.ЦенаЗакупочная;
          НоваяСтрока.СуммаРозница = НоваяСтрока.ПроцентНаценки /100 * НоваяСтрока.СуммаЗакупочная + НоваяСтрока.СуммаЗакупочная;
      КонецЕсли;   
      
      счСтроки = счСтроки + 1;
      Наименование= Док.Sheets(1).Cells(СчСтроки,2).Value;
      
   КонецЦикла;

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: шаблон excel
« Ответ #4: 25 Апр 2012, 21:30 »
жду помощи пожалуйста

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: шаблон excel
« Ответ #5: 25 Апр 2012, 23:38 »
ExcelПриложение = Новый COMObject("Excel.Application");
ExcelФайл = ExcelПриложение.WorkBooks.Open(ИмяФайла);
ExcelЛист = ExcelФайл.Sheets(1);
ExcelПоследняяКолонка = ExcelЛист.Cells.SpecialCells(11).Column;

Для Сч=1 По 10 Цикл //Цикл по шапке проверяя первые 10 строк
     Для к=1 По ExcelПоследняяКолонка Цикл
          Если ExcelЛист.Cells(Сч,к).Value = "Наименование твоей колонки" Тогда //Или шаблону или еще чему то
                НомермоейКолонки = К;
                Прервать;
          КонецЕсли;
      КонецЦикла;
      Если ЗначениеЗаполнено(НомермоейКолонки) Тогда
            прервать;
      КонецЕсли;
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Круглый стол "Автоматизация учета и отчетности по МСФО: Excel против программных продуктов"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1692
Последний ответ 10 Сен 2014, 10:25
от mixqn
работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2797
Последний ответ 11 Фев 2016, 12:49
от Rasty
Внешняя компонента для прямого чтения файлов Excel всех версий

Автор CrazyDaveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2101
Последний ответ 01 Мар 2012, 16:23
от CrazyDave
Не создается COM объект Excel.Application, хотя всё установлено и права есть

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7171
Последний ответ 23 Июл 2015, 14:25
от vitasw
Алгоритм загрузки изображений из excel по ссылке URL в реквизит основное изображение

Автор nikioioioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 995
Последний ответ 23 Мар 2016, 05:43
от nikioioio

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 859
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal