Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 09:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя обработка. Нарушение прав доступа.  (Прочитано 10533 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ko$tello

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-25
  • Сайт: 
  • Профессия: Ученик 1С
Всем доброго времени суток. Прошу помочь новичку.
Столкнулся со следующей проблемой:
Имеется 1С Предприятие 8.2 Комплексная автоматизация 1.1
Имеется внешняя обработка, которая делает выборку из базы. Вот код:

Процедура КоманднаяПанель1Прочитать(Кнопка)
НаборЗаписей=РегистрыСведений.ДляВыпискиЗаказов.СоздатьНаборЗаписей();
Если ЗначениеЗаполнено(Организация) ТОгда
НаборЗаписей.Отбор.Организация.установить(Организация);
КонецЕсли;

Если ЗначениеЗаполнено(Контрагент) ТОгда
НаборЗаписей.Отбор.Контрагент.установить(Контрагент);
КонецЕсли;
Если ЗначениеЗаполнено(Договор) ТОгда
НаборЗаписей.Отбор.Договор.установить(Договор);
КонецЕсли;
Если ЗначениеЗаполнено(Номенклатура) ТОгда
НаборЗаписей.Отбор.Номенклатура.установить(Номенклатура);
КонецЕсли;

НаборЗаписей.Прочитать();
ТаблЗнач=НаборЗаписей.Выгрузить();
ТаблЗнач.Колонки.Добавить("НомСтрок");
НомСтрок=0;
Для Каждого ТекДанные из ТаблЗнач Цикл
НомСтрок=НомСтрок+1;
ТекДанные.НомСтрок=НомСтрок;
Если ТекДанные.Договор.Владелец<>ТекДанные.Контрагент Тогда
Сообщить("В строке "+ТекДанные.НомСтрок+" для контрагента "+ТекДанные.Контрагент+" не верно указан договор!!!!",СтатусСообщения.Важное);
ТекДанные.Договор=Справочники.ДоговорыКонтрагентов.ПустаяСсылка();
КонецЕсли;
КонецЦикла;

КонецПроцедуры

Проблема в том что обработка выполняется только если у пользователя имеются полные права.

Под ограниченным пользователем выдается ошибка:
{Форма.Форма.Форма(46)}: Ошибка при вызове метода контекста (Прочитать)
НаборЗаписей.Прочитать();
по причине:
Нарушение прав доступа!

Права у пользователя на все справочники есть. Подскажите каких прав не хватает? В каком направлении копать?

Заранее спасибо...


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
РегистрыСведений.ДляВыпискиЗаказов Проверь права для регистра?
Помогли, отблагодари!

Оффлайн Ko$tello

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-25
  • Сайт: 
  • Профессия: Ученик 1С
РегистрыСведений.ДляВыпискиЗаказов Проверь права для регистра?

Спасибо за помощь. Дело было именно в этом.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 761
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal