Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: внешний отчет  (Прочитано 7094 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Сейчас пытаюсь создать внешний отчет в котором должен быть виден финансовый контролер дата и текущее время..но у меня вышли следующие ошибки и не пойму как исправить..:
Таб<<?>>.ВывестиСекцию("Шапка");
{D:\1s_Bases\work\pb_hvat\ExtForms\Финики.ert(12)}: Переменная не определена (Таб)
Таб<<?>>.ВывестиСекцию("Строка");
{D:\1s_Bases\work\pb_hvat\ExtForms\Финики.ert(23)}: Переменная не определена (Таб)
Таб<<?>>.Показать();
{D:\1s_Bases\work\pb_hvat\ExtForms\Финики.ert(25)}: Переменная не определена (Таб)
При проверке модуля обнаружены синтаксические ошибки!

Вот код отчета:
Процедура Сформировать() 

   Табл=СоздатьОбъект("ТаблицаЗначений");
   Табл.НоваяКолонка("ФК");
//   ТАбл.НоваяКолонка("Дата");
   Табл.НоваяКолонка("Время");
      Табл=СоздатьОбъект("Таблица");
   Табл.ИсходнаяТаблица("Таблица");
   Док=СоздатьОбъект("Документ.ПКО");
   Док.ВыбратьДокументы(ДатаНач,ДатаКон);
   Таб.ВывестиСекцию("Шапка");
      Если ПустоеЗначение(ФК)=1 Тогда
       Пока Док.ПолучитьДокумент()=1 Цикл
          ТАбл.НоваяСтрока();
          Табл.ФК=Док.Фин;
       //   Табл.Дата=Док.;
          ТАбл.Время=Док.ТекВремя;
       КонецЦикла; 
        ТАбл.Сортировать("ФК,Время",1);
       ТАбл.ВыбратьСтроки();
       Пока Табл.ПолучитьСтроку()=1 Цикл
          Таб.ВывестиСекцию("Строка");
       КонецЦикла;
       Таб.Показать();
       КонецЕсли;
КонецПроцедуры
                       
Процедура ПриОткрытии()
   ДатаКон=Дата(ТекущаяДата()+1);
   ДатаНач=ДатаКон;
КонецПроцедуры   


В общем данные (Фамилию финансового контролера и текущее время) я беру из реквизитов шапки документа Приходно кассавый ордер... Подскажите где я ошиблась?  конфигурация Торговля и склад 7.7


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #1: 23 Апр 2012, 19:38 »
сравните
      Табл=СоздатьОбъект("Таблица");
   Табл.ИсходнаяТаблица("Таблица");
и
   Таб.ВывестиСекцию("Шапка"); 

и сделайте одинаково
Кнопочка Спасибо - слева!

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #2: 24 Апр 2012, 00:05 »
Ооо..и снова спасибо Сергей :* Ошибка ушла) еще вопрос...я нажала на кнопку Сформировать, после того как выблала период и ФК из справочника физлиц..но она не реагирует...может я чтото упустила?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #3: 24 Апр 2012, 07:08 »
Если ПустоеЗначение(ФК)=1 Тогда

Если значение ФК заполнено - то ПустоеЗначение(ФК)=0 и внутрь условия мы не попадаем. Наверно так.




Кнопочка Спасибо - слева!

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #4: 24 Апр 2012, 09:19 »
Сергей, заменила на 0. Задала период, выбрала ФК..но вышло такое сообщение:
ТАбл.НоваяСтрока();
{D:\1S_BASES\WORK\PB_HVAT\EXTFORMS\ФИНИКИ.ERT(15)}: Поле агрегатного объекта не обнаружено (НоваяСтрока)

Если бы он не видел какой либо реквизит документа..я бы еще поняла..а тут ругается на "НоваяСтрока"

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #5: 24 Апр 2012, 09:44 »
Наведи порядок с именами переменных.
У тебя Табл - это таблица или таблица значений?
Кнопочка Спасибо - слева!

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #6: 24 Апр 2012, 10:00 »
Исправила все :) ошибка пропала..но табличка формируется без данных..только шапка

Процедура Сформировать() 

   ТабЗ=СоздатьОбъект("ТаблицаЗначений");
   ТабЗ.НоваяКолонка("ФК");

   ТабЗ.НоваяКолонка("Время");
      Таб=СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица");
   Док=СоздатьОбъект("Документ.ПКО");
   Док.ВыбратьДокументы(ДатаНач,ДатаКон);
   Таб.ВывестиСекцию("Шапка");
      Если ПустоеЗначение(ФК)=0 Тогда
       Пока Док.ПолучитьДокумент()=1 Цикл
          ТАбЗ.НоваяСтрока();
          ТабЗ.ФК=Док.Фин;
      
          ТАбЗ.Время=Док.ТекВремя;
       КонецЦикла; 
        ТАбЗ.Сортировать("ФК,Время",1);
       ТАбЗ.ВыбратьСтроки();
       Пока ТабЗ.ПолучитьСтроку()=1 Цикл
          Таб.ВывестиСекцию("Строка");
          КонецЦикла;
       Таб.Показать();
   
       КонецЕсли;
КонецПроцедуры
                       
Процедура ПриОткрытии()
   ДатаКон=Дата(ТекущаяДата()+1);
   ДатаНач=ДатаКон;
КонецПроцедуры   

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #7: 24 Апр 2012, 10:02 »
ой..и естественно в самой таблице выражения сменила на ТабЗ.ФК и ТабЗ.Время )

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #8: 24 Апр 2012, 10:15 »
вроде все исправила..но не формирует данные таблицы..

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: внешний отчет
« Ответ #9: 24 Апр 2012, 10:36 »
ФК выбран?
   ДатаКон=Дата(ТекущаяДата()+1);
   ДатаНач=ДатаКон;

Дата выбрана не завтра?

Документы в этом периоде есть?
Кнопочка Спасибо - слева!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 208
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal