Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 05:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос по "операции"  (Прочитано 3813 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн didigo

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-02
  • Сайт: 
  • Профессия: Программист 7.7
После проведения документа, в операциях субконто Кт и Дб почему то не показывает...
спасибо...

Пока ПолучитьСтроку() = 1 Цикл
Операция.НоваяПроводка();
Операция.Дебет.Счет = Сотрудник.Подразделение.Получить(ДатаДок).СчетЗатрат;

Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если Спр.Текущийэлемент().Наименование = "Начислена зарплата" Тогда
Операция.Дебет.ЭлементыЗатрат = Спр.ТекущийЭлемент();
// Иначе Операция.Дебет.ЭлементыЗатрат = Справочники.ЭлементыЗатрат;
КонецЕсли;
КонецЦикла;

Операция.Кредит.Счет = Сотрудник.Подразделение.Получить(ДатаДок).СчетЗП;
Операция.Кредит.Сотрудники = Сотрудник;
Операция.Кредит.Подразделения = Сотрудник.Подразделение.Получить(ДатаДок);
Операция.Сумма = Начислено;
Операция.СодержаниеПроводки = "Начислено";
Операция.НомерЖурнала = "ЗП"; 

Операция.НоваяПроводка();
    Операция.Кредит.Сотрудники = Сотрудник;
Операция.Кредит.Подразделения = Сотрудник.Подразделение.Получить(ДатаДок);
Операция.Дебет.Счет = СчетПоКоду(681.2);
Операция.Кредит.Счет = СчетПоКоду(653.1);
Операция.Сумма = ОПВ;
Операция.СодержаниеПроводки = "ОПВ";
Операция.НомерЖурнала = "ЗП";

Операция.НоваяПроводка();
Операция.Кредит.Сотрудники = Сотрудник;
Операция.Кредит.Подразделения = Сотрудник.Подразделение.Получить(ДатаДок);
Операция.Дебет.Счет = СчетПоКоду(681.2);
Операция.Кредит.Счет = СчетПоКоду(862);
Операция.Сумма = СуммаШтрафа;
Операция.СодержаниеПроводки = "СуммаШтрафа";
Операция.НомерЖурнала = "ЗП";
КонецЦикла;   


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Документ хотя бы проводится?
        Операция.НоваяПроводка();
        Операция.Кредит.Сотрудники = Сотрудник;
        Операция.Кредит.Подразделения = Сотрудник.Подразделение.Получить(ДатаДок);
        Операция.Дебет.Счет = СчетПоКоду(681.2);
        Операция.Кредит.Счет = СчетПоКоду(653.1);
Если так располагать выбор счета и субконто, то система должна ругаться на Для счета  вид субконто Сотрудники неопределен!

Тип значения у субконто определен?
СчетПоКоду(681.2) код счета кажется в кавычках пишется?

Кнопочка Спасибо - слева!

Оффлайн didigo

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-02
  • Сайт: 
  • Профессия: Программист 7.7
Документ без этого проводится!

                Операция.Кредит.Сотрудники = ТекущийЭлемент(Сотрудник);
      Операция.Кредит.Подразделения = Сотрудник.Подразделение.Получить(ДатаДок);

И в операциях вместо Субконто Дб Кт <...>

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Посмотри отладчиком что возвращает Сотрудник.Подразделение.Получить(ДатаДок);
Кнопочка Спасибо - слева!

Оффлайн didigo

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-02
  • Сайт: 
  • Профессия: Программист 7.7
Посмотри отладчиком что возвращает Сотрудник.Подразделение.Получить(ДатаДок);
Спасибо, Сергей большое за помощь! разобрался! Просто в счетах Субконто был не указанным!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 135
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal