Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 14:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как добавить внутреннюю обработку "Печать ТТН" на управляемую форму???  (Прочитано 8693 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Viktorka

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-27
  • Сайт: 
  • Профессия: Ученик 1С
У меня есть документ "Расходный ордер на товары", в обычной форме есть кнопка печать, по которой я вызываю внутреннюю обработку "Печать ТТН", открывается форма обработки.
Моя задача добавить на управляемую форму кнопку, по которой открывалась форма этой обработки.
Я добавила команду "Печать ТТН" в модуле команды пишу:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
   ОбработкаПечати          = Обработки.ПечатьТТН.ПолучитьФорму("Форма");
   ОбработкаПечати.Документ = Документы.РасходныйОрдерНаТовары.Ссылка;

   ОбработкаПечати.Открыть();
КонецПроцедуры

Запуская пользовательский режим, следующая ошибка
{Документ.РасходныйОрдерНаТовары.Команда.ПечатьТТН.МодульКоманды(12,29)}: Переменная не определена (Обработки)
   ОбработкаПечати          = <<?>>Обработки.ПечатьТТН.ПолучитьФорму("Форма");
{Документ.РасходныйОрдерНаТовары.Команда.ПечатьТТН.МодульКоманды(13,29)}: Переменная не определена (Документы)
   ОбработкаПечати.Документ = <<?>>Документы.РасходныйОрдерНаТовары.Ссылка;

Если в модуле пишу
&НаСервере
Процедура ОбработкаКоманды1(ПараметрКоманды, ПараметрыВыполненияКоманды)
   ОбработкаПечати          = Обработки.ПечатьТТН.ПолучитьФорму("Форма");
   ОбработкаПечати.Документ = Документы.РасходныйОрдерНаТовары.Ссылка;

   ОбработкаПечати.Открыть();
КонецПроцедуры

Он даже к этой процедуре не обращается??? Что делать??? :dfbsdfbsdf: :dfbsdfbsdf: :dfbsdfbsdf:
 


Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1

Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
#Если Клиент Тогда
   ОбработкаПечати          = Обработки.ПечатьТТН.ПолучитьФорму("Форма");
   ОбработкаПечати.Документ = ЭтотОбъект.Ссылка;
   ОбработкаПечати.Открыть();
#КонецЕсли;
КонецПроцедуры

Оффлайн Viktorka

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-27
  • Сайт: 
  • Профессия: Ученик 1С
&НаСервере
Процедура ПечатьТТН()Экспорт
   ОбработкаПечати          = ПолучитьФорму("Обработка.ПечатьТТН.Форма.ФормаУправляемая");
   ОбработкаПечати.Документ = Документы.РасходныйОрдерНаТовары.Ссылка;

   ОбработкаПечати.Открыть();
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
   ПечатьТТН();
КонецПроцедуры

Я уже делаю так, он опять ругается:

{Документ.РасходныйОрдерНаТовары.Команда.ПечатьТТН.МодульКоманды(4,29)}: Процедура или функция с указанным именем не определена (ПолучитьФорму)
   ОбработкаПечати          = <<?>>ПолучитьФорму("Документ.РасходныйОрдерНаТовары.Форма.ФормаВыбораУправляемая");

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
на сервере недоступно получение формы и работа с ними.
В типовых конфигурациях обычно процедуру печати выносят в модуль объекта как экспортную и тогда к ней можно обращаться как из формы объекта, так и из сторонней обработки типо вашей


Теги:
 

Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2051
Последний ответ 18 Янв 2017, 12:32
от sertak
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 3674
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4074
Последний ответ 13 Июн 2017, 12:17
от Whisper
Версия 8.3, при добавлении поля в форму списка не устанавливается вид поля - выпадающий список пустой

Автор Developer.KZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 676
Последний ответ 22 Июн 2017, 10:50
от Developer.KZ
корректировку серий и характеристик добавить в корректировку качества или наоборот

Автор SergiGoof777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1978
Последний ответ 24 Июн 2015, 13:51
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
61 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
buketov.av buketov.av
34 Сообщений
KOI8-R
34 Сообщений
Alter
24 Сообщений
BuhRust
21 Сообщений
alexandr_ll
20 Сообщений

* Кто онлайн

  • Точка Гостей: 855
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal