Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 14:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка закрытия 1с  (Прочитано 5265 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rusroma

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-16
  • Компания: 24pult.ru
  • Профессия: Программист 1С
Вообщем требуется помощь, не могу найти ошибку!
Я хочу автоматизировать РИБ 1с между двумя городами, как все знают обмен РИБ должен выполняться только под полными правами.
Погуглив, и полазив по форумам нашел выход из положения:

1. В 1с завел пользователя Root. Пароль = 1.
2. Написал обработку Close1c.epf.
Ее код:
Перем Тайм;

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    ПодключитьОбработчикОжидания("Таймер",1);
КонецПроцедуры

Процедура Таймер()
    Тайм = Тайм - 1;
    Если Тайм = 0 Тогда
        ЗавершитьРаботуСистемы(Ложь);
    КонецЕсли;
   
    ЭлементыФормы.Надпись1.Заголовок = "1с будет закрыта через: " + Строка(Тайм) + " секунд";
КонецПроцедуры

Процедура ОсновныеДействияФормыОтменитьЗакрытие(Кнопка)
    ОтключитьОбработчикОжидания("Таймер");
    ЭлементыФормы.Надпись1.Заголовок = "";
КонецПроцедуры

Тайм = 60; //Секунд
 

3. Поставил программу: xStarter(бесплатная) можно скачать с сайта. Можно было пользоваться и планировщиком Windows, но xStarter многое умеет, одна из моих любимых программ. xStarter запускает bat-файл по расписанию.

4.Написал бат файл, это его полный текст:
"C:\Program Files\1cv82\8.2.14.533\bin\1cv8.exe" ENTERPRISE /S SERVAK2\mybd /NRoot /P1 /Execute "C:\Close1c.epf" /DisableStartupMessages
/DisableStartupMessages - этот параметр очень важный, я первые полгода без него работал, приходилось удалено заходить на клиента и открывать конфигуратор и обновлять конфигурацию, каждый раз после ее изменения в центре. Потом как включил этот параметр, забыл все свои проблемы.

5. В штатной "Обмен данными", настроил чтобы обмен данными начинался при запуске пользователя Root, потом программа 1с закрывается обработкой Close1c.epf.

6. Настроил расписание xStarter, он запускает bat-файл в 7:00,18:00,19:00,20:00.
7. Настроил расписание xStarter на удаленной базе, он запускает bat-файл в 8:00,18:30,19:30,20:30
Сделал 4 раза чтобы решить вопрос, очередность обмена, плюс фактор сбоев интернета.
1с после запуска закрывается.
Вопрос сам заключается в этой обработке, у меня выскакивают 2 ошиби при сохранении:

( {ВнешняяОбработка.ВнешняяОбработка1.МодульОбъекта(13,5)}: Переменная не определена (ЭлементыФормы)
    <<?>>ЭлементыФормы.Надпись1.Заголовок = "1с будет закрыта через: " + Строка(Тайм) + " секунд"; (Проверка: Толстый клиент (обычное приложение))
{ВнешняяОбработка.ВнешняяОбработка1.МодульОбъекта(18,5)}: Переменная не определена (ЭлементыФормы)
    <<?>>ЭлементыФормы.Надпись1.Заголовок = ""; (Проверка: Толстый клиент (обычное приложение))

Где искать болезнь!


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В МодулеОбъекта недоступны элементы формы, использовать элементы формы стоит в модуле формы
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн rusroma

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-16
  • Компания: 24pult.ru
  • Профессия: Программист 1С
Спасибо! Это исправил! Проблемка только осталась! 1с не закрывается ((( почему

Оффлайн rusroma

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-16
  • Компания: 24pult.ru
  • Профессия: Программист 1С
Может существуют ещё какие то методы

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Проблема с условием! Проверь по шагово, какие действия он выполняет.
Помогли, отблагодари!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal