Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июн 2018, 09:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите пожалуйста  (Прочитано 2598 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн almagkeeva

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Программист 1С
Добрый вечер) Нужна помощь,пожалуйста) Есть документ "Перемещение книг" с реквизитами "ОтделОтправитель" и "ОтделПолучатель" и регистр накопления "Остатки книг" с измерением "Отдел". Если при проведении документа в поле "Отдел получатель" выбран не отдел обслуживания читателей,а другой отдел нужно,чтоб в регистре движения не происходили,т.е. в регистр чтоб ничего не записывалось,а если выбран отдел обслуживания читателей,то записывалось..не знаю как сделать,как написать условие.. Вид движения Приход. кто может-помогите,пожалуйста)  


Оффлайн 090977

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-29
  • Сайт: 
  • Профессия: Бухгалтер
Если ОтделПолучатель= "отдел обслуживания читателей"  Тогда
   Движение=.........
   .....
КонецЕсли;

"отдел обслуживания читателей" - я так понимаю элемент справочника ?  который можно найти по коду или наименованию

Оффлайн almagkeeva

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Программист 1С
Ага.."отдел обслуживания читателей"-это элемент справочника "Отделы") Вот весь мой код,может так легче:
Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

   // регистр ОстаткиКниг Расход
   Движения.ОстаткиКниг.Записывать = Истина;
   Движения.ОстаткиКниг.Очистить();
        Запрос = Новый Запрос;
       Запрос.Текст = "ВЫБРАТЬ
                      |   ОстаткиКнигОстатки.Отдел,
                      |   ПеремещениеКниги.Книга КАК Книга,
                      |   ПеремещениеКниги.Ссылка,
                      |   ЕСТЬNULL(ОстаткиКнигОстатки.КоличествоЭкземпляровОстаток, 0) КАК КоличествоЭкземпляровОстаток,
                      |   ЕСТЬNULL(ПеремещениеКниги.КоличествоЭкземпляров, 0) КАК Количество
                      |ИЗ
                      |   Документ.Перемещение.Книги КАК ПеремещениеКниги
                      |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиКниг.Остатки(&Период, Отдел = &Отдел) КАК ОстаткиКнигОстатки
                      |      ПО ПеремещениеКниги.Книга = ОстаткиКнигОстатки.Книга
                      |ГДЕ
                      |   ПеремещениеКниги.Ссылка = &Ссылка
                      |ИТОГИ
                      |   СУММА(КоличествоЭкземпляровОстаток),
                      |   СРЕДНЕЕ(Количество)
                      |ПО
                      |   Книга";
      
       Запрос.УстановитьПараметр("Период", Дата);
   Запрос.УстановитьПараметр("Ссылка", Ссылка);
   
             Запрос.УстановитьПараметр("Отдел",ОтделОтправитель);


      Результат = Запрос.Выполнить();
        ВыборкаПоГруппировкам = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
   Пока ВыборкаПоГруппировкам.Следующий() Цикл
      Если ВыборкаПоГруппировкам.КоличествоЭкземпляровОстаток<ВыборкаПоГруппировкам.Количество Тогда
         Сообщить("Книги "+ВыборкаПоГруппировкам.Книга+ " нет в наличии");
          Отказ=Истина;
         Возврат;
      КонецЕсли;
          КонецЦикла;

      
          
   Для Каждого ТекСтрокаКниги Из Книги Цикл
      Движение = Движения.ОстаткиКниг.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
      Движение.Период = Дата;
      Движение.Книга = ТекСтрокаКниги.Книга;
      Движение.Отдел = ОтделОтправитель;
      Движение.КоличествоЭкземпляров = ТекСтрокаКниги.КоличествоЭкземпляров;
   КонецЦикла;

          // регистр ОстаткиКниг Приход
          
        Для Каждого ТекСтрокаКниги Из Книги Цикл
   Если ОтделПолучатель= "отдел обслуживания читателей"  Тогда
      Движение=Движения.ОстаткиКниг.Добавить();
   
   Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Книга = ТекСтрокаКниги.Книга;
      Движение.Отдел = ОтделПолучатель;
      Движение.КоличествоЭкземпляров = ТекСтрокаКниги.КоличествоЭкземпляров;
      КонецЕсли;
         КонецЦикла;
           
   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

По идее этот документ в регистре осуществляет движения в виде расхода в любом случае,а приход только при выборе отдела обслуживания читателей. Может я условие не туда вставила(

Оффлайн 090977

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-29
  • Сайт: 
  • Профессия: Бухгалтер
Для Каждого ТекСтрокаКниги Из Книги Цикл
    Если ОтделПолучатель= Справочники.Отделы.НайтиПоКоду("00000001")  Тогда
         Движение=Движения.ОстаткиКниг.Добавить();
         Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
         Движение.Период = Дата;
         Движение.Книга = ТекСтрокаКниги.Книга;
         Движение.Отдел = ОтделПолучатель;
         Движение.КоличествоЭкземпляров = ТекСтрокаКниги.КоличествоЭкземпляров;
     КонецЕсли;
КонецЦикла;

Оффлайн 090977

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-29
  • Сайт: 
  • Профессия: Бухгалтер
Для универсальности я бы добавил в справочник "Отделы" реквизит булевский например "ПроводитьПоРегистру" и условие строил бы соответственно значения этого реквизита

Для Каждого ТекСтрокаКниги Из Книги Цикл
    Если ОтделПолучатель.ПроводитьПоРегистру  Тогда
         Движение=Движения.ОстаткиКниг.Добавить();
         Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
         Движение.Период = Дата;
         Движение.Книга = ТекСтрокаКниги.Книга;
         Движение.Отдел = ОтделПолучатель;
         Движение.КоличествоЭкземпляров = ТекСтрокаКниги.КоличествоЭкземпляров;
     КонецЕсли;
КонецЦикла;

Оффлайн 090977

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-29
  • Сайт: 
  • Профессия: Бухгалтер
И плиз в модуле нажми Ctrl+A ,потом Alt+Shift+F  ,глаза режет код разбегающийся ))))

Оффлайн almagkeeva

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Программист 1С
Спасибо огромное)) работает!) и спасибо за совет,в следующий раз буду знать))))))))


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4717
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5989
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6317
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5168
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2240
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
138 Сообщений
AIFrame AIFrame
130 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
48 Сообщений
alex0402
44 Сообщений
buketov.av buketov.av
37 Сообщений
ilyay ilyay
36 Сообщений
trialex3
22 Сообщений
magnifico61
21 Сообщений
wise wise
18 Сообщений

* Кто онлайн

  • Точка Гостей: 605
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal