Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 10:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка данных  (Прочитано 1452 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Я до этого выгружал обычным методом из справочника без учета иерархии справочника. Но для меня не правильно это. Так как мне надо выгрузить с учетом иерархии. Помогите мне это сделать! Прикладываю код который выгружает без учета иерархии.

&НаСервере
Процедура Запись()
Текст = Новый ТекстовыйДокумент;

Выборка = Справочники.Номенклатура.Выбрать();

Пока Выборка.Следующий() Цикл
   СтрокаТекста = "";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Наименование) + "|";
   Если Выборка.ЭтоГруппа Тогда
      СтрокаТекста = СтрокаТекста + "Группа" + "|";
   Иначе
      СтрокаТекста = СтрокаТекста + "Элемент" + "|";
   КонецЕсли;
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Код) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Артикул) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ВидНоменклатуры) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ЕдиницаИзмерения) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.НаименованиеПолное) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Описание) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.СтавкаНДС) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ЦеноваяГруппа) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Услуга) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Номинал) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ИспользоватьСерийныеНомера) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ТипСерийногоНомера) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ДатаОкончанияДействия) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ТипСрокаДействия) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Периодичность) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.КоличествоПериодовДействия) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ПодарочныйСертификат) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Весовой) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Вес) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.НаборУпаковок) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ТипНоменклатуры) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.ФайлКартинки) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.НоменклатурнаяГруппа) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.СтранаПроисхождения) + "|";
   СтрокаТекста = СтрокаТекста + СокрЛП(Выборка.Родитель) + "|" ;
   Текст.ДобавитьСтроку(СтрокаТекста);
   
КонецЦикла;

Текст.Записать("c:\text2.txt");
КонецПроцедуры


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка данных
« Ответ #1: 05 Апр 2012, 09:17 »
Выборка = Справочники.Номенклатура.ВыбратьВИерархии();

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Выгрузка данных
« Ответ #2: 05 Апр 2012, 09:59 »
Проблема решена. Спасибо.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7459
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3893
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2132
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7388
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6977
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal