Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись из одной ТЧ в другую!  (Прочитано 2549 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Добрый вечер!
Эсть две ТЧ документа....в обоих есть реквизиты (Товар и Количество)....Нужно, чтобы приИзменении Товара в первой ТЧ автоматически менялся Товар во второй ТЧ...и про Количество так же!
Не судите строго!
Все перепробывал!


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Строки связывай из разных таблиц каким нибудь ключом и при изменении в строки из первой ТЧ ищи строку с таким же ключом во второй ТЧ и меняй там что тебе нужно
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
можно пример какой то, а то не совсем понятно!(

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Колонки Номенклатура, Цена, ключ

строка = ТЧ1.Добавить();
Строка.Номенклатура = Номен;
Строка.Цена = Цена;
Строка.ключ = 1;
Строка2 = Тч2.Добавить();
Строка2.Номенклатура = Строка.Номенклатура;
Строка2.Цена = Строка.Цена;
Строка2.ключ = Строка.ключ;


Процедура ПриИзмененииТЧ1(Элемент)

ТекСтрока = ЭлементыФормы.Тч1.ТекущиеДанные; //Для Обычного приложения
Если Не ТекСтрока = Неопределено Тогда
ТекСтрока2 = Тч2.Найти(ТекСтрока.Ключ,"Ключ");
Если Не текСтрока2 = Неопределено Тогда
ТекСтрока2.Номенклатура = ТекСтрока.Номенклатура;
ТекСтрока2.Цена = ТекСтрока.Цена;
КонецЕсли;
конецЕсли;

КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
а если управляемое приложение, то будет типа так?

строка = Элементы.ТЧ1.Добавить();
Строка.Номенклатура = Номен;
Строка.Цена = Цена;
Строка.ключ = 1;
Строка2 = Элементы.Тч2.Добавить();
Строка2.Номенклатура = Строка.Номенклатура;
Строка2.Цена = Строка.Цена;
Строка2.ключ = Строка.ключ;

Процедура ПриИзмененииТЧ1(Элемент) //(ПриИзменении ТЧ или елемента ТЧ??))

ТекСтрока = Элементы.Тч1.ТекущиеДанные;
Если Не ТекСтрока = Неопределено Тогда
ТекСтрока2 = Тч2.Найти(ТекСтрока.Ключ,"Ключ");
Если Не текСтрока2 = Неопределено Тогда
ТекСтрока2.Номенклатура = ТекСтрока.Номенклатура;
ТекСтрока2.Цена = ТекСтрока.Цена;
КонецЕсли;
конецЕсли;

КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТекСтрока = Элементы.Тч1.ТекущиеДанные; //Ну вот тут Да
строка = Элементы.ТЧ1.Добавить(); //а тут врядли
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
  &НаКлиенте
Процедура ТовариПередОкончаниемРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования, Отказ)
     Если ОтменаРедактирования = Ложь Тогда
      Если НоваяСтрока  Тогда
         ТД = Элемент.ТекущиеДанные;
         ТД.Ключ = Новый УникальныйИдентификатор(); // Можно придумать и что-то свое.
         НоваяСтрокаВторойТЧ = Объект.СобівартістьПродукту.Добавить();
         НоваяСтрокаВторойТЧ.Ключ = ТД.Ключ;
         НоваяСтрокаВторойТЧ.Товар = ТД.Товар;
         НоваяСтрокаВторойТЧ.Кількість = ТД.Кількість;
         НоваяСтрокаВторойТЧ.ОдиницяВиміру = ТД.ОдиницяВиміру;
      Иначе
         ТД = Элемент.ТекущиеДанные;
         ПоискПоКлючу = Новый Структура("Ключ",ТД.Ключ);
         Массив = Объект.СобівартістьПродукту.НайтиСтроки(ПоискПоКлючу);
         Если Массив.Количество()>0 Тогда   
            СтрокаВторойТЧДляИзменения = Массив[0];
            СтрокаВторойТЧДляИзменения.Товар = ТД.Товар;
            СтрокаВторойТЧДляИзменения.Кількість = ТД.Кількість;
            СтрокаВторойТЧДляИзменения.ОдиницяВиміру = ТД.ОдиницяВиміру;
         КонецЕсли;      
      КонецЕсли;
   КонецЕсли;   

КонецПроцедуры

вот sergejK74 помого, но реквизит Кількість во вторую ТЧ записывает дважды (в 1 и 2 строки)...
Что посоветуете?

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
  &НаКлиенте
Процедура ТовариПередОкончаниемРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования, Отказ)
  Если ОтменаРедактирования = Ложь Тогда
Если НоваяСтрока  Тогда
ТД = Элемент.ТекущиеДанные;
ТД.Ключ = Новый УникальныйИдентификатор(); // Можно придумать и что-то свое.
НоваяСтрокаВторойТЧ = Объект.СобівартістьПродукту.Добавить();
НоваяСтрокаВторойТЧ.Ключ = ТД.Ключ;
НоваяСтрокаВторойТЧ.Товар = ТД.Товар;
НоваяСтрокаВторойТЧ.Кількість = ТД.Кількість;
НоваяСтрокаВторойТЧ.ОдиницяВиміру = ТД.ОдиницяВиміру;
Иначе
ТД = Элемент.ТекущиеДанные;
ПоискПоКлючу = Новый Структура("Ключ",ТД.Ключ);
Массив = Объект.СобівартістьПродукту.НайтиСтроки(ПоискПоКлючу);
Если Массив.Количество()>0 Тогда   
СтрокаВторойТЧДляИзменения = Массив[0];
СтрокаВторойТЧДляИзменения.Товар = ТД.Товар;
СтрокаВторойТЧДляИзменения.Кількість = ТД.Кількість;
СтрокаВторойТЧДляИзменения.ОдиницяВиміру = ТД.ОдиницяВиміру;
КонецЕсли;
КонецЕсли;
КонецЕсли;

КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Молодца
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Ето sergejK74 помог!
Ето его заслуга!


Теги:
 

Как понять запись ?(НачОстаток = Null,0,НачОстаток)

Автор olgahachnewРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2573
Последний ответ 07 Апр 2011, 17:38
от chuevsf
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14338
Последний ответ 11 Янв 2011, 10:04
от nomer13
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3604
Последний ответ 02 Фев 2014, 21:37
от LordWizard
Запись элемента справочника из модуля объекта другого справочника

Автор 12040Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1408
Последний ответ 05 Май 2016, 09:29
от LexaK
Запись регистра регистра сведений стали не уникальными: РасчетПереоценкиВалютныхСредств

Автор GinayatРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 169
Последний ответ 09 Ноя 2017, 21:42
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 183
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal