Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 20:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Здравствуйте, проблемы при выводе в ТЗ  (Прочитано 1571 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djonbox

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-05
  • Сайт: 
  • Профессия: Бухгалтер
При выводе данных из запроса, почему то не все данных попадают в ТЗ, а именно некоторые позиции из табличной части документа. Я так подозреваю что проблема с выводом данных, потому как при формировании одноуровнего запроса по номерам документов и суммам, результаты сходятся. А если я вывожу дополнительно наименование товара, серию, количество, цену, цену учетную, то тогда у меня не все данные попадают. В чем может быть проблема подскажите пожалуйста.
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Расходная = Документ.Расходная.ТекущийДокумент;
|НомерДок = Документ.Расходная.НомерДок;
|ДатаДок = Документ.Расходная.ДатаДок;
|ГрузПол = Документ.Расходная.ГрузПол.Наименование;
|Товар = Документ.Расходная.Товар.Наименование;   
|Серия = Документ.Расходная.Серия;
|Сер = Документ.Расходная.Серия.Наименование;
|СерГоденДо = Документ.Расходная.Серия.ГоденДо;
|СерДатаПрих = Документ.Расходная.Серия.ДатаПрих;
|СерЦенаУч = Документ.Расходная.Серия.ЦенаИзг;
|Количество = Документ.Расходная.Количество;
|Цена = Документ.Расходная.Цена;
|Сумма = Документ.Расходная.Сумма;
|Группировка Расходная упорядочить по Расходная.ДатаДок, Расходная.НомерДок, Расходная.ГрузПол;
|Группировка Товар Без Групп;
// |Группировка Серия упорядочить по Серия.Наименование, Серия.ГоденДо, Серия.ДатаИзг, Серия.ДатаПрих;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Расходная
Таб.ВывестиСекцию("Расходная");
Пока Запрос.Группировка(2) = 1 Цикл
// Заполнение полей Товар
Таб.ВывестиСекцию("Товар");
//Пока Запрос.Группировка(3) = 1 Цикл
// // Заполнение полей Серия
// Таб.ВывестиСекцию("Серия");
//КонецЦикла;
КонецЦикла;
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вы веткой не ошиблись?
Здесь "обитают" 8шники...
А код у вас - 7.7!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djonbox

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-05
  • Сайт: 
  • Профессия: Бухгалтер
извените, поздно заметил что добавил не туда


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 264
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal