Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 17:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: учусь выводить результаты запроса в таблицу значений подскажите пожалуйста  (Прочитано 12882 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djonbox

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-05
  • Сайт: 
  • Профессия: Бухгалтер
Собственно вопрос, есть пример простого запроса, созданого конструктором запросов:
   
	Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Реализация = Документ.Реализация.ТекущийДокумент;
|Номенклатура = Документ.Реализация.Номенклатура;
|Количество = Документ.Реализация.Количество;
|Цена = Документ.Реализация.Цена;
|Сумма = Документ.Реализация.Сумма;
|Партия = Документ.Реализация.Партия;
|Группировка Реализация упорядочить по Реализация.ДатаДок, Реализация.ВремяДок, Реализация.НомерДок, Реализация.Сумма, Реализация.Цена;
|Группировка Номенклатура упорядочить по Номенклатура.Код, Номенклатура.Наименование, Номенклатура.ВидНоменклатуры;
|"//}}ЗАПРОС
;
Как теперь данный запрос выгрузить в таблицу значений. Не умею выводить результаты в таблицу значений со вложенными таблицами.


Оффлайн djonbox

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-05
  • Сайт: 
  • Профессия: Бухгалтер
Уточню: как вывести табличную часть документа. что бы к примеру выводился номер документа, и табличная часть документа(товар, цена количество). Что то типа реестра документов

Оффлайн Public_enemy

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 6
  • КПД: 12%
  • Регистрация: 2011-10-13
  • Сайт: www.alliancesystems.ru
  • Профессия: Программист 1С
РезультатЗапроса = Выполнить().Выгрузить();
Таким образом запрос выгружается в таблицу значений. Можешь посмотреть через отладчик

Оффлайн djonbox

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-05
  • Сайт: 
  • Профессия: Бухгалтер
РезультатЗапроса = Выполнить().Выгрузить();
Таким образом запрос выгружается в таблицу значений. Можешь посмотреть через отладчик
Это понятно, просто не знал как вложенные запросы выводить, смущала строка "Запрос.Группировка(1)" "Запрос.Группировка(2)" ну вроде разобрался как в цикле выводить. Дописал ручками. Всем спасибо

   // Если ошибка в запросе, то выход из процедуры
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;

   // Подготовка к заполнению выходных форм данными запроса
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   // Заполнение полей "Заголовок"
   Таб.ВывестиСекцию("Заголовок");
   Состояние("Заполнение выходной таблицы...");
   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
   Пока Запрос.Группировка(1) = 1 Цикл
      // Заполнение полей Реализация
      Таб.ВывестиСекцию("Реализация");
      Пока Запрос.Группировка(2) = 1 Цикл
         // Заполнение полей Номенклатура
         Таб.ВывестиСекцию("Номенклатура");
      КонецЦикла;
   КонецЦикла;
   // Вывод заполненной формы
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать", "");

Оффлайн djonbox

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-05
  • Сайт: 
  • Профессия: Бухгалтер
вопрос а как сделать проверку это группа в запросе, что бы в таблицу значений не выводились группы:
//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Реализация = Документ.Реализация.ТекущийДокумент;
|Номенклатура = Документ.Реализация.Номенклатура;
|Ном = Документ.Реализация.Номенклатура.Наименование;
|НомКод = Документ.Реализация.Номенклатура.Код;
|НомДата = Документ.Реализация.ДатаДок;
|Количество = Документ.Реализация.Количество;
|Цена = Документ.Реализация.Цена;
|Сумма = Документ.Реализация.Сумма;
|Партия = Документ.Реализация.Партия;
|Группировка Реализация упорядочить по Реализация.ДатаДок, Реализация.НомерДок;
|Группировка Номенклатура упорядочить по Номенклатура.Наименование;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Реализация
Таб.ВывестиСекцию("Реализация");
Пока Запрос.Группировка(2) = 1 Цикл
// Заполнение полей Номенклатура
Таб.ВывестиСекцию("Номенклатура");
КонецЦикла;
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Группировка Номенклатура упорядочить по Номенклатура.Наименование Без Групп; - как-то так. Без конструктора не помню
Кнопочка Спасибо - слева!

Оффлайн djonbox

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-05
  • Сайт: 
  • Профессия: Бухгалтер
о точно Группировка Номенклатура упорядочить по Номенклатура.Наименование без групп; спасибо:)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
100 Сообщений
AIFrame
66 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
18 Сообщений
Norfolk
16 Сообщений
andron81_81
16 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 377
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal