Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Загрузка из Excel в 1с  (Прочитано 6021 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!У меня тут не большая проблема...Есть справочник в нем создаётся множество других справочников (т.е. они созданы и пустые в данные момент)и в их табличные части должны загружаться данные из Excel,но у меня тут какойто баг выходит не пойму почему...Заранее благодарен за помощь.
&НаКлиенте
Процедура ЗагрузитьИзExcel(Команда)
   Эксель = Новый COMОбъект("Excel.Application");
           Книга = Эксель.WorkBooks.Open("C:\Users\Администратор\Downloads\1с");
   Лист = Книга.WorkSheets(1);   
           ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
   ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;     
   
   Док = Справочники.Журнал.Выбрать();   
   Пока Док.Следующий() Цикл   
         
      ТЧ = Док.Ведомость;     
      Для каждого Стр из ТЧ Цикл     
         
      КонецЦикла;   
   КонецЦикла;      
   Для Строка = 1 По ВсегоСтрок Цикл
      
      Для Колонка = 1 По ВсегоКолонок Цикл
      Студент = Справочники.Студенты.НайтиПоНаименованию(СокрЛП(Лист.Cells(Строка,Колонка).Value));     
      Если Студент.Пустая() Тогда
         Сообщить("В строке "+ Строка+ " введен неверно студент.")
      Иначе   
         ТЧ.Студент = Студент;
      КонецЕсли;   
      Попытка
         ТЧ.Понедельник = Перечисления.Оценки.Получить(Лист.Cells(Строка,2).Value);
      Исключение
      КонецПопытки;
      Попытка
         ТЧ.Вторник = Перечисления.Оценки.Получить(Лист.Cells(Строка,3).Value);
      Исключение
      КонецПопытки;
      Попытка
         ТЧ.Среда = Перечисления.Оценки.Получить(Лист.Cells(Строка,4).Value);
      Исключение
      КонецПопытки;
      Попытка
         ТЧ.Пятница = Перечисления.Оценки.Получить(Лист.Cells(Строка,5).Value);
      Исключение
      КонецПопытки;
      Попытка
         ТЧ.Суббота = Перечисления.Оценки.Получить(Лист.Cells(Строка,6).Value);
      Исключение
      КонецПопытки;
      Попытка
         ТЧ.Воскресенье = Перечисления.Оценки.Получить(Лист.Cells(Строка,7).Value);
      Исключение;
      КонецПопытки;
         
   
      КонецЦикла;       
       КонецЦикла;
       Док.Записать();

КонецПроцедуры


Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
ошибку то забыл написать)
{Справочник.Журнал.Форма.ФормаСписка.Форма(207)}: Поле объекта не обнаружено (Студент)
         ТЧ.Студент = Студент;

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Тоже в попытку занеси и не будет такой Ошибки =)))))))
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТЧ[0].Студент = Студент; 
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Тоже в попытку занеси и не будет такой Ошибки =)))))))
я заносил)
но он ничего не менят в тч справочника...

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Тоже в попытку занеси и не будет такой Ошибки =)))))))
я заносил)
но он ничего не менят в тч справочника...
БуГаГа... Красавчик=))))
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Тоже в попытку занеси и не будет такой Ошибки =)))))))
я заносил)
но он ничего не менят в тч справочника...
БуГаГа... Красавчик=))))
я понимаю,что всё оч смешно))но так что делать то?)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТЧ[0].Студент = Студент; 
Я же тебе написал!!!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТЧ - Это же табличная часть? Вот ты как думаешь в какую строку положить твоего СТУДЕНТА платформа сама должна догадаться????????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
да это табличная часть.ну нет конечно же))
вот какая штука
{Справочник.Журнал.Форма.ФормаСписка.Форма(181,17)}: Переменная не определена (Студент)
ТЧ[0].Студент = <<?>>Студент;


Теги:
 

Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8576
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
загрузка из "клиента банка"

Автор miximlРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2694
Последний ответ 19 Июн 2012, 09:49
от miximl
Загрузка в 1С Управление Торговлей 11.1.5.16 электронных выписок из клиент банка "Альфа-Банк"

Автор regnusРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 12004
Последний ответ 11 Июл 2014, 17:22
от regnus
Проблема с внешней обработкой "Загрузка банк-клиент.erp"

Автор razielРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2156
Последний ответ 24 Сен 2015, 20:13
от Kironten
Загрузка из "нестандартного" табличного документа (exel) в справочник

Автор uchenichokРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1000
Последний ответ 03 Июн 2016, 07:15
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 121
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal