Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вытащить значение выбранного контрагента  (Прочитано 4247 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн edison

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-31
  • Сайт: 
  • Профессия: Ученик 1С
Я создал в справочнике контрагентов реквизит и назвал его СтопПродажи (булево). Теперь хочу сделать так, чтобы в документе реализация товаров и услуг при выборе контрагента, программа сообщила пользователю, что данному контрагенту отгрузка приостановлена и закрыла нафиг этот документ. Что мне добавить в эту процедуру?

Процедура КонтрагентПриИзменении(Элемент)

   ПриИзмененииКонтрагента();
   
КонецПроцедуры // КонтрагентПриИзменении()


Оффлайн edison

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-31
  • Сайт: 
  • Профессия: Ученик 1С
Все ведь просто я так понимаю. Если стоит галочка у контрагента, то выводим сообщение об этом, если нет, то ничего не делаем.

Оффлайн edison

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-31
  • Сайт: 
  • Профессия: Ученик 1С
Неужели это так сложно и никто не знает?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Скорее наверное просто и все подумали, что уже не актуально. Для УФ
&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
Если ПроверитьНаСтоп(Объект.Контрагент) Тогда
                Предупреждение("Клиент не очень");
ЭтаФорма.Модифицированность=Ложь;
ЭтаФорма.Закрыть();
КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПроверитьНаСтоп(Контрагент)
Возврат Контрагент.СтопПродажи;
КонецФункции // ПроверитьНаСтоп()
Кнопочка Спасибо - слева!

Оффлайн edison

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-31
  • Сайт: 
  • Профессия: Ученик 1С
{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3252,26)}: Переменная не определена (Объект)
    Если ПроверитьНаСтоп(<<?>>Объект.Контрагент) Тогда (Проверка: Толстый клиент (обычное приложение))
{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3252,10)}: Процедура или функция с указанным именем не определена (ПроверитьНаСтоп)
    Если <<?>>ПроверитьНаСтоп(Объект.Контрагент) Тогда (Проверка: Толстый клиент (обычное приложение))

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ответ кроется в ЭТОМ - "Толстый клиент (обычное приложение)", тебе написали пример для "Управляемого приложения" =)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн edison

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-31
  • Сайт: 
  • Профессия: Ученик 1С
У меня комплексная автоматизация, как мне решить мою задачу? Я еще только начинаю знакомиться с 1с, со вчерашнего дня я стал обучаться по курсу в ведение в конфигурирование... Помогите решить эту задачу. Если будет готовое решение, ну а дальше я разберусь, мне главное для усвоения.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура КонтрагентПриИзменении(Элемент)
    Если Контрагент.СтопПродажи Тогда
        Предупреждение("Клиент не очень");
        ЭтаФорма.Модифицированность=Ложь;
        ЭтаФорма.Закрыть();   
    КонецЕсли;   
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн edison

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-31
  • Сайт: 
  • Профессия: Ученик 1С
Огромное вам спасибо! Все оказалось так просто! И все заработало как надо ))) Завтра у меня опять учеба! ))))

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6874
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3240
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 973
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1089
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8539
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 139
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal