Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Типы  (Прочитано 4195 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Типы
« Первое сообщение: 29 Мар 2012, 22:23 »
ругается на строчки где типы указаны Справочники.Ссылка и Перечисления.Ссылка - объясните в чем ошибка(как правильно типы прописывать) а то не пойму

И еще я справочник создаю иерархический с группами. Подскажите в каком порядке я должен создавать(элементы в корень, иерархию и группы)

Процедура КнопкаВыполнитьНажатие(Кнопка)
   Текст = Новый ТекстовыйДокумент;

Текст.Прочитать("c:\text2.txt");

СимволРазделитель = "|";

Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл
   Стр = Текст.ПолучитьСтроку(НомерСтроки);
   ТемпСтрока = Стр;
   НомерСимвола = Найти(ТемпСтрока,СимволРазделитель);
   Наименование = СокрЛП(Лев(ТемпСтрока,НомерСимвола - 1));
   ТемпСтрока = Сред(ТемпСтрока,НомерСимвола + 1);
   НомерСимвола = Найти(ТемпСтрока,СимволРазделитель);
   Наименование = СтрЗаменить(Наименование, "|", Символ(34));

   МассивСтрок = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(Стр, "|");
   
   Для каждого ЭлементМассива из МассивСтрок Цикл
      Сообщить(ЭлементМассива)
   КонецЦикла; 
   
   Наименование = МассивСтрок[0];
   Код = МассивСтрок[1];
   Артикул = МассивСтрок[2];
   ВидНоменклатуры = МассивСтрок[3];
   БазоваяЕдиницаИзмерения = МассивСтрок[4];
   НаименованиеПолное = МассивСтрок[5];
   Описание = МассивСтрок[6];
   СтавкаНДС = МассивСтрок[7];
   ЦеноваяГруппа = МассивСтрок[8];
   Услуга = МассивСтрок[9];
   Номинал = МассивСтрок[10];
   ИспользоватьСерийныеНомера = МассивСтрок[11];
   ТипСерийногоНомера = МассивСтрок[12];
   ДатаОкончанияДействия = МассивСтрок[13];
   ТипСрокаДействия = МассивСтрок[14];
   Периодичность = МассивСтрок[15];
   КоличествоПериодовДействия = МассивСтрок[16];
   ПодарочныйСертификат = МассивСтрок[17];
   Весовой = МассивСтрок[18];
   Вес = МассивСтрок[19];
   НаборУпаковок = МассивСтрок[20];
   ТипНоменклатуры = МассивСтрок[21];
   ФайлКартинки = МассивСтрок[22];
   НоменклатурнаяГруппа = МассивСтрок[23];
   СтранаПроисхождения = МассивСтрок[24];
   
   Справочник = Справочники.Номенклатура.ПустаяСсылка();
   
   // Ищем товар по наименованию
   Если Наименование <> "" Тогда
     Справочник = Справочники.Номенклатура.НайтиПоНаименованию(Наименование);
   Конецесли;
   
   //Если не нашли создаем новый товар
   Если Справочник.Пустая() Тогда
     НовыйЭлемент = Справочники.Номенклатура.СоздатьЭлемент();
     НовыйЭлемент.Наименование = Строка(МассивСтрок[0]);
     НовыйЭлемент.Код = Строка(МассивСтрок[1]);
     НовыйЭлемент.Артикул = Строка(МассивСтрок[2]);
     Родитель = Справочники.Номенклатура.НайтиПоКоду(МассивСтрок[2]);
     НовыйЭлемент.НаименованиеПолное = Строка(МассивСтрок[5]);
     НовыйЭлемент.Родитель = Родитель;
     НовыйЭлемент.БазоваяЕдиницаИзмерения = Справочники.Ссылка.КлассификаторЕдиницИзмерения(МассивСтрок[4]);
     НовыйЭлемент.ТипНоменклатуры = Перечисления.Ссылка.ТипыНоменклатуры(МассивСтрок[21]);
     НовыйЭлемент.Описание = Строка(МассивСтрок[6]);
     НовыйЭлемент.СтавкаНДС = Перечисления.Ссылка.СтавкиНДС(МассивСтрок[7]);
     НовыйЭлемент.НоменклатурнаяГруппа = Справочники.Ссылка.НоменклатурныеГруппы(МассивСтрок[23]);
     НовыйЭлемент.СтранаПроисхождения = Справочники.Ссылка.КлассификаторСтранМира(МассивСтрок[24]);
     НовыйЭлемент.ВидНоменклатуры = Справочники.Ссылка.ВидыНоменклатуры(МассивСтрок[3]);
     //НовыйЭлемент.Услуга = Булево(МассивСтрок[9]);
     //НовыйЭлемент.ЦеноваяГруппа = СправочникСсылка;
     //НовыйЭлемент.Номинал = Число(МассивСтрок[10]);
     //НовыйЭлемент.ИспользоватьСерийныеНомера = Булево(МассивСтрок[11]);
     //НовыйЭлемент.ТипСерийногоНомера = ПеречислениеСсылка;
     //НовыйЭлемент.ДатаОкончанияДействия = Дата(МассивСтрок[13]);
     //НовыйЭлемент.ТипСрокаДействия = ПеречислениеСсылка;
     //НовыйЭлемент.Периодичность = ПеречислениеСсылка;
     //НовыйЭлемент.КоличествоПериодовДействия = Число(МассивСтрок[16]);
     //НовыйЭлемент.ПодарочныйСертификат = Булево(МассивСтрок[17]);
     //НовыйЭлемент.Весовой = Булево(МассивСтрок[18]);
     //НовыйЭлемент.Вес = Число(МассивСтрок[19]);
     //НовыйЭлемент.НаборУпаковок = Справочники.Ссылка;
     //НовыйЭлемент.ФайлКартинки = СправочникСсылка;
    

     НовыйЭлемент.Записать();
   Иначе
    
     //Если нашли, получим объект
     Справочник = Справочник.ПолучитьОбъект();
    
     //....Заполняем реквизиты  (если нужно)
   Конецесли;
   
КонецЦикла;
КонецПроцедуры


Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Типы
« Ответ #1: 29 Мар 2012, 22:33 »
Странно выложился код, поэтому я его прицепляю в файле

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Типы
« Ответ #2: 29 Мар 2012, 22:42 »
Так ты ищешь в справочнике номенклатура
Наименование = МассивСтрок[0];
Справочник = Справочники.Номенклатура.НайтиПоНаименованию(Наименование);

Значит и здесь 
НовыйЭлемент.БазоваяЕдиницаИзмерения = Справочники.Ссылка.КлассификаторЕдиницИзмерения(МассивСтрок[4]);
делай также (ищи по наименованию или по коду, если Найти = Неопределено ,то создавай новый).
Кнопочка Спасибо - слева!

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Типы
« Ответ #3: 29 Мар 2012, 22:53 »
Как должна выглядеть эта строчка в правильном состояние?

НовыйЭлемент.БазоваяЕдиницаИзмерения = Справочники.Ссылка.КлассификаторЕдиницИзмерения(МассивСтрок[4]);

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Типы
« Ответ #4: 29 Мар 2012, 23:11 »
и как прописывать типы Число и Булево?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Типы
« Ответ #5: 30 Мар 2012, 07:20 »
Для преобразования значений есть соответственно функции Булево() и Число().
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Типы
« Ответ #6: 30 Мар 2012, 08:32 »
Как должна выглядеть эта строчка в правильном состояние?

НовыйЭлемент.БазоваяЕдиницаИзмерения = Справочники.Ссылка.КлассификаторЕдиницИзмерения(МассивСтро�

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Типы
« Ответ #7: 30 Мар 2012, 08:55 »
Форум не любит квадратные скобки...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Re: Типы
« Ответ #8: 30 Мар 2012, 09:08 »
Как должна выглядеть эта строчка в правильном состояние?

НовыйЭлемент.БазоваяЕдиницаИзмерения = Справочники.Ссылка.КлассификаторЕдиницИзмерения

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Типы
« Ответ #9: 30 Мар 2012, 09:15 »
Кнопочка Спасибо - слева!


Теги:
 

Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2111
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
Получить все типы документов, генеривших проводки по счету

Автор LeviathanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 7710
Последний ответ 11 Мар 2011, 11:02
от cska-fanat-kz
Графа журнала содержит несовместимые типы данных

Автор SuareРаздел Пользователям "1С - Предприятие 8"

Ответов: 8
Просмотров: 2040
Последний ответ 22 Янв 2016, 12:59
от Suare
Как узнать разрешенные типы для поля формы?

Автор igwtboxРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 503
Последний ответ 18 Авг 2016, 13:06
от igwtbox
Как сопоставить разные типы регистров?

Автор ЛейсанРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 3089
Последний ответ 19 Фев 2012, 23:42
от Лейсан

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 803
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal