Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 окт 2021, 16:18

Отчет по отстаткам товара

Автор AmoZ, 04 окт 2009, 17:25

0 Пользователей и 1 гость просматривают эту тему.

AmoZ

Доброго времени суток!
1С 8.1 Бухгалтерия 1.6.15.6.
Была задача написать отчет, который выводит остаток по товарам... При это пользователь выбирает в форме цифру меньше которой будут выводится товары. Т.е. если ввела 5, то будут выведены товары, которых меньше или равно 5.
Функция КнопкаВыполнитьНажатие(Кнопка)

Форма = ПолучитьФорму("Форма");

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Остаток";

Макет = ПолучитьМакет("Макет");

ОбластьШапка   = Макет.ПолучитьОбласть("Шапка");
ОбластьСтрока  = Макет.ПолучитьОбласть("Строка");
ОбластьСтрока1 = Макет.ПолучитьОбласть("Строка1");
   
ТабДокумент.Вывести(ОбластьШапка);

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Кол", Номер);
Запрос.Текст = "ВЫБРАТЬ
| ПартииТоваровНаСкладахНалоговыйУчетОстатки.Номенклатура,
| ПартииТоваровНаСкладахНалоговыйУчетОстатки.КоличествоОстаток
|ИЗ
| РегистрНакопления.ПартииТоваровНаСкладахНалоговыйУчет.Остатки КАК ПартииТоваровНаСкладахНалоговыйУчетОстатки
|ГДЕ
| ПартииТоваровНаСкладахНалоговыйУчетОстатки.КоличествоОстаток <= &Кол";
Выборка = Запрос.Выполнить();
Результат = Выборка.Выбрать();
Ном = 0;
Флаг_цвет = 1;

Пока Результат.Следующий() Цикл
Ном = Ном + 1;
Если Флаг_Цвет = 1 Тогда
ОбластьСтрока.Параметры.Номенклатура = Результат.Номенклатура;
ОбластьСтрока.Параметры.Ном = Ном;
ОбластьСтрока.Параметры.Остаток = Результат.КоличествоОстаток;
ТабДокумент.Вывести(ОбластьСтрока);
Флаг_Цвет = 0;
Иначе
Флаг_Цвет = 1;
ОбластьСтрока1.Параметры.Номенклатура = Результат.Номенклатура;
ОбластьСтрока1.Параметры.Ном = Ном;
ОбластьСтрока1.Параметры.Остаток = Результат.КоличествоОстаток;
ТабДокумент.Вывести(ОбластьСтрока1);
КонецЕсли;

КонецЦикла;

ТабДокумент.Показать();

КонецФункции

Проблема в том, что если вводить 0, то товары, которых нет вообще на складе не выводится, т.к. в регистре "ПартииТоваровНаСкладахНалоговыйУчетОстатки" их нет.

Подскажите, плз, как исправить?

rassini

Прошу прощения если что не так, новичок я :)

При выводе товаров которых нет на складе, предлагаю попробовать объединять результаты запросов примерно как

ПРАВОЕ СОЕДИНЕНИЕ РезультатЗапросаЧтоЕстьвРегистре

ПО ЧегоНетвРегистре

----------------

Возможно с синтаксисом напутал, надеюсь идея понятна.

AmoZ

Уже решил
Функция КнопкаВыполнитьНажатие(Кнопка)
Форма = ПолучитьФорму("Форма");

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Остаток";

Макет = ПолучитьМакет("Макет");

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");

ОбластьШапка   = Макет.ПолучитьОбласть("Шапка");
ОбластьСтрока  = Макет.ПолучитьОбласть("Строка");
ОбластьСтрока1 = Макет.ПолучитьОбласть("Строка1");

//ОбластьЗаголовок.Параметры.Получить(ДанныеДляПечати);

ТабДокумент.Вывести(ОбластьЗаголовок);
ТабДокумент.ПовторятьПриПечатиСтроки = ТабДокумент.Область("Заголовок");

ТабДокумент.Вывести(ОбластьШапка);


Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Кол", Номер);
Запрос.Текст = "ВЫБРАТЬ
               | НоменклатураСпр.Ссылка КАК Номенклатура,
               | НоменклатураСпр.Представление,
               | ЕСТЬNULL(ПартииТоваровНаСкладахНалоговыйУчетОстатки.КоличествоОстаток, 0) КАК КоличествоОстаток
               |ИЗ
               | Справочник.Номенклатура КАК НоменклатураСпр
               | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ПартииТоваровНаСкладахНалоговыйУчет.Остатки КАК ПартииТоваровНаСкладахНалоговыйУчетОстатки
               | ПО (ПартииТоваровНаСкладахНалоговыйУчетОстатки.Номенклатура = НоменклатураСпр.Ссылка)
               |ГДЕ
               | ЕСТЬNULL(ПартииТоваровНаСкладахНалоговыйУчетОстатки.КоличествоОстаток, 0) <= &Кол
               | И НоменклатураСпр.ЭтоГруппа = ЛОЖЬ";
Выборка = Запрос.Выполнить();
Результат = Выборка.Выбрать();
Ном = 0;
Флаг_цвет = 1;

Пока Результат.Следующий() Цикл
        Ном = Ном + 1;
Если Флаг_Цвет = 1 Тогда
ОбластьСтрока.Параметры.Номенклатура = Результат.Номенклатура;
ОбластьСтрока1.Параметры.Ном = Ном;
ОбластьСтрока.Параметры.Остаток = Результат.КоличествоОстаток;
ТабДокумент.Вывести(ОбластьСтрока);
Флаг_Цвет = 0;
Иначе
Флаг_Цвет = 1;
ОбластьСтрока1.Параметры.Номенклатура = Результат.Номенклатура;
ОбластьСтрока1.Параметры.Ном = Ном;
ОбластьСтрока1.Параметры.Остаток = Результат.КоличествоОстаток;
ТабДокумент.Вывести(ОбластьСтрока1);
КонецЕсли;

КонецЦикла;

ТабДокумент.Показать();
КонецФункции

Belgafood

Подпись

AmoZ

Belgafood
Не совсем Вас понял... Что Вы не уидели?

Теги:

Похожие темы (5)

29147

Ответов: 2
Просмотров: 3006

36980

Ответов: 1
Просмотров: 9144

45198

Ответов: 2
Просмотров: 1343

75000

Ответов: 0
Просмотров: 391

Рейтинг@Mail.ru Rambler's Top100

Поиск