Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 22:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавить(Узел), ошибка при добавлении узла.  (Прочитано 2856 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн laki_stshel

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-17
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте!
У меня такая проблема.
Необходимо настроить обмен данными между двумя базами:
1) 1С:Предприятие 8.2 (8.2.15.301) Управление производственным предприятием, редакция 1.2 (1.2.29.1), режим совместимости с версией 8.2.13  и
2) 1С:Предприятие 8.2 (8.2.15.301)  Управление производственным предприятием, редакция 1.2 (1.2.16.1), в котором установлен режим совместимости с версией 8.1
 по средствам Com-соединения.
   Так как в конфигураторе 2) стоит совместимость с 8.1 (отключить ее нельзя, т.к. полностью не перевели организацию на 8.2), то в запросах пропадает поле ВерсияДанных объектов, а в отладчике выводится значение ВерсияДанных  не определено…
Само соединение отработает, т. е. одна база подключается к другой
ИС = Новый COMОбъект("V82.Application");

Попытка
   СоединениеУстановлено = ИС.Connect("Srvr = """+СокрЛП(ИмяСервера1С)+"""; Ref = """+СокрЛП(ИмяБазыНаСервере)+"""; Usr = """+СокрЛП(Пользователь)+"""; Pwd = """+СокрЛП(Пароль)+"""");   
      Исключение
   ВывестиСообщение(ОписаниеОшибки(),СтатусСообщения.Важное);
КонецПопытки;


При записи номенклатуры сделала добавление узла:

Процедура ПриЗаписиОбменСПЭО(Источник, Отказ) Экспорт
Если ПараметрыСеанса.ОбменСПЭО Тогда
      Возврат;
   Иначе
      Узел =  ПланыОбмена.ОбменСППЭО.НайтиПоРеквизиту("ПЭО",Истина);
      Если ЗначениеЗаполнено(Узел) Тогда
         Если ТипЗнч(Источник) = Тип("СправочникОбъект.Номенклатура") ИЛИ (ТипЗнч(Источник) = Тип("СправочникОбъект.ЕдиницыИзмерения") И ТипЗнч(Источник.Владелец) = Тип("СправочникСсылка.Номенклатура")) Тогда
            Запрос = Новый Запрос;
            Запрос.Текст = "ВЫБРАТЬ
                           |   Номенклатура.Ссылка
                           |ИЗ
                           |   Справочник.Номенклатура КАК Номенклатура
                           |ГДЕ
                           |   Номенклатура.Ссылка В ИЕРАРХИИ
                           |         (ВЫБРАТЬ
                           |            ДанныеДляПереносаВПЭО.ОтборПоДанным
                           |         ИЗ
                           |            РегистрСведений.ДанныеДляПереносаВПЭО КАК ДанныеДляПереносаВПЭО)
                           |   И Номенклатура.Ссылка = &Ссылка";
            Если ТипЗнч(Источник) = Тип("СправочникОбъект.Номенклатура") Тогда 
               Запрос.УстановитьПараметр("Ссылка", Источник.Ссылка);
            Иначе
               Запрос.УстановитьПараметр("Ссылка", Источник.Владелец.Ссылка);
            КонецЕсли;
            Выборка = Запрос.Выполнить().Выбрать();
            Если Выборка.Следующий() Тогда
               Источник.ОбменДанными.Получатели.Добавить(Узел);
            КонецЕсли;
         Иначе
            Источник.ОбменДанными.Получатели.Добавить(Узел);
         КонецЕсли;
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры

Но при этом в момент записи выдается ошибка:

Ошибка при выполнении обработчика - 'ПриЗаписи'
по причине:
{ОбщийМодуль.ОбщегоНазначения.Модуль(5596)}: Ошибка при вызове метода контекста (Добавить)

по причине:
Недопустимое значение параметра (параметр номер '1')

Подскажите, пожалуйста, в чем может быть причина.


Оффлайн laki_stshel

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-17
  • Сайт: 
  • Профессия: Программист 8.1
Получилось исправить ошибку: в плане обмена неправильно добавила узел для обмена (сделала как Этот узел). Теперь добавила в план обмена  ОбменСППЭО еще одну запись, назвала пэо, ошибку больше не выдает.


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4526
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6080
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4195
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8488
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8555
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 293
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal