Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 19:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Еще один вопрос про заполнение при условии  (Прочитано 3505 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
Имеется внешняя обработка на которой имеется макет, в макете есть строка:
Температура хранения:   " тут пишется значение"
И в " тут пишется значение", мне нужно, чтобы текст подставлялся автоматически, исходя из того, к какой группе принадлежит номенклатура, вот мой код:
Если СсылкаНаОбъект.НоменклатураАнализа.Родитель = Справочники.Номенклатура.НайтиПоНаименованию("Квас") Тогда
         ОбластьДетальныхЗаписей.Параметры.Температура.Сообщить("+5...+20 С");
      КонецЕсли;

Ругается, что

{ВнешняяОбработка.ПечатнаяФормаУдостоверениеКачестваИБезопастности.МодульОбъекта(31)}: Значение не является значением объектного типа (Сообщить)
      ОбластьДетальныхЗаписей.Параметры.Температура.Сообщить("+5...+20 С");


как решить проблему?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Сами придумали?

а просто...

ОбластьДетальныхЗаписей.Параметры.Температура = "+5...+20 С";

никак?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
блин, точно, спасибо)

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
мм, а если нужно сделать, чтобы определенный реквизит показывался только при его заполнении, это как?

Если ЗначениеЗаполнено(ОбластьДетальныхЗаписей.Параметры.Тип = ПланыВидовХарактеристик.ОпцииТМЦиУслуг.ДИТ_ТипВоды) Тогда
      Видимость = ОбластьДетальныхЗаписей.Параметры.Тип;
      Видимость = Истина;
      КонецЕсли;


как нить так, но не прокатывает

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
Нужно Если Тип поле заполнено, тогда оно выводится( причем выводится не только параметр, но и сама надпись в поле), Т.е.
Если у нас ЗАПОЛНЕНО значение ТИП, то будет на макете так:
Тип        добрый
Если у нас НЕ ЗАПОЛНЕНО значение ТИП, то будет на макете так:
(пустая, невидимая строка)

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
можно просто сделать область новую, и для нее прописать условие

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
блин, отстой, условие не помогает:

Если ЗначениеЗаполнено(ОбластьТип.Параметры.Тип = ПланыВидовХарактеристик.ОпцииТМЦиУслуг.ДИТ_ТипВоды) Тогда
      Видимость = ОбластьДетальныхЗаписей.Параметры.Тип;
      
      КонецЕсли;


Вроде должно правильно работать, но все равно отображается на макете эта область

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
НайденнаяСтрока = Найти(ПланыВидовХарактеристик.ОпцииТМЦиУслуг.ДИТ_ТипВоды, "ОпцияТМЦиУслуг");
   Если НайденнаяСтрока <> Неопределено Тогда
      ТабДок.Вывести(ОбластьТип);
      КонецЕсли;
все равно не рабоает(

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"Видимость = ОбластьДетальныхЗаписей.Параметры.Тип;"

Сами придумали?

1. Заполнение проверяйте того значения, которое вы присваиваете параметру, а не обращайтесь к самому параметру

Если ЗначениеЗаполнено(ААА) Тогда
Область.Параметры.ААА = ААА;
КонецЕсли;

2. Если еще и надпись не надо выводить, то и ее сделайте параметром


Если ЗначениеЗаполнено(ААА) Тогда
Область.Параметры.ААА_Надпись = "ААА: ";
Область.Параметры.ААА = ААА;
КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9206
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5842
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3289
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3435
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2363
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 280
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal