Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вывести отчет горизонтально!  (Прочитано 3491 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SpiritDark

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Программист 8.1
Скажите плз как вывести отчет по горизонтали??? Заранее огромное спасибо)


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вместо Вывести() делай Присоединить()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн SpiritDark

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Программист 8.1
Сделал как ты написал но горизонтально не вывел

   Макет = Отчеты.ОстаткиТМЦ.ПолучитьМакет("Макет1");
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ОстаткиТоваровОстаткиИОбороты.Номенклатура КАК Номенклатура,
      |   ОстаткиТоваровОстаткиИОбороты.КоличествоКонечныйОстаток,
      |   ОстаткиПоСкладамОстаткиИОбороты.Склад КАК Склад
      |ИЗ
      |   РегистрНакопления.ОстаткиТоваров.ОстаткиИОбороты КАК ОстаткиТоваровОстаткиИОбороты
      |      ПОЛНОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиПоСкладам.ОстаткиИОбороты КАК ОстаткиПоСкладамОстаткиИОбороты
      |      ПО ОстаткиТоваровОстаткиИОбороты.Номенклатура = ОстаткиПоСкладамОстаткиИОбороты.Номенклатура
      |ИТОГИ ПО
      |   Номенклатура,
      |   Склад";

   Результат = Запрос.Выполнить();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
   ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
   ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура");
   ОбластьСклад = Макет.ПолучитьОбласть("Склад");
   ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

   ТабДок.Очистить();
   ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.Вывести(ОбластьШапкаТаблицы);

   ВыборкаНоменклатура = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

   Пока ВыборкаНоменклатура.Следующий() Цикл
      ОбластьНоменклатура.Параметры.Заполнить(ВыборкаНоменклатура);
      ТабДок.Вывести(ОбластьНоменклатура);

      ВыборкаСклад = ВыборкаНоменклатура.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

      Пока ВыборкаСклад.Следующий() Цикл
         ОбластьСклад.Параметры.Заполнить(ВыборкаСклад);
         ТабДок.Присоединить(ОбластьСклад);

         ВыборкаДетальныеЗаписи = ВыборкаСклад.Выбрать();

         Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
            ТабДок.Присоединить(ОбластьДетальныхЗаписей);
         КонецЦикла;
      КонецЦикла;
   КонецЦикла;

   ТабДок.Вывести(ОбластьПодвалТаблицы);
   ТабДок.Вывести(ОбластьПодвал);

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Областью в этом случае должны быть не строки, а колонки.
Мне так кажется...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Областью в этом случае должны быть не строки, а колонки.
Мне так кажется...
+ либо их пересечение


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 140
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal