Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 09:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: active document, заполнение документа реквизитами из модуля менеджера  (Прочитано 8951 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vodez

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-25
  • Сайт: 
  • Профессия: Бухгалтер
Добрый день! 1с 8.2, управляемая форма,  макет печати как Active Document, при нажатии на кнопку "Печать"  документ word заполняется заполненными на форме реквизитами, в модуле менеджера считываем реквизит и заполняем вордовский документ,
подскажите, как считать значение реквизита с формы?
пробовал по разному, логическим кажется например такой вариант, но все неправильно (

       //    ФИО = Документы.СогласиеНаОбследование.НайтиПоРеквизиту().ФИО;

//Модуль Менеджера

Процедура Печать(ТабДок, Ссылка) Экспорт

     Договор = ПолучитьМакет("МакетСогласиеФорма");
             MSWord = Договор.Получить();
Попытка
   Документ = MSWord.Application.Documents(1);
   Документ.Activate();

//!!!!!!!!!!!!!!!!!!   
           ФИО = Документы.СогласиеНаОбследование.НайтиПоРеквизиту().ФИО;
//!!!!!!!!!!!!!!!!!      
   Замена = Документ.Content.Find;
   Замена.Execute("[ФИО]", Ложь, Истина, Ложь, , , Истина, , Ложь, ФИО);
   MSWord.Application.Visible = Истина;
   MSWord.Activate();
Исключение
   Сообщить(ОписаниеОшибки());
   MSWord.Application.Quit();
КонецПопытки;


//Модуль команды

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   ТабДок = Новый ТабличныйДокумент;
   Печать(ТабДок, ПараметрКоманды);

   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}
КонецПроцедуры

&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
   Документы.СогласиеНаОбследование.Печать(ТабДок, ПараметрКоманды, Объект);
КонецПроцедуры


Оффлайн vodez

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-25
  • Сайт: 
  • Профессия: Бухгалтер
может непонятно написал.. вот по материалам этой статьи
http://www.nastroy-ka.ru/system1c/83--word-active-document.html

только вместо уже заполненных строковых значений надо считать значения реквизитов с формы,  из модуля менеджера как понимаю элементы формы не видятся, так как же их получить?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн vodez

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-25
  • Сайт: 
  • Профессия: Бухгалтер
тут тоже на всякий случай напишу )

спасибо за ответ,   как понимаю, передаем параметр Объект при вызове процедуры в модуле менеджера и 2 параметр - сам документ, с Объектом что-то не получается

мОбъект =  ДанныеФормыВЗначение(Объект,Тип "ДокументОбъект.СогласиеНаОбследование"));

Ошибка при вызове метода контекста (ДанныеФормыВЗначение): Несоответствие типов (параметр номер '1')


// модуль команды

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды, Объект)
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   ТабДок = Новый ТабличныйДокумент;
   Печать(ТабДок, ПараметрКоманды, Объект);
    ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}
КонецПроцедуры

&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды, Объект)
   Документы.СогласиеНаОбследование.Печать(ТабДок, ПараметрКоманды, Объект);
КонецПроцедуры



//модуль менеджера

Процедура Печать(ТабДок, Ссылка, Объект) Экспорт
   Договор = ПолучитьМакет("МакетСогласиеФорма");
   MSWord = Договор.Получить(); 
Попытка
   Документ = MSWord.Application.Documents(1);
   Документ.Activate();
   мОбъект =  ДанныеФормыВЗначение(Объект,Тип "ДокументОбъект.СогласиеНаОбследование")); 
   ЯФИОРодителя = мОбъект.ФИОРодителя.Значение;
   Замена = Документ.Content.Find;
   Замена.Execute("[ФИОРодителя]", Ложь, Истина, Ложь, , , Истина, , Ложь, ЯФИОРодителя);
   MSWord.Application.Visible = Истина;
   MSWord.Activate();
Исключение
   Сообщить(ОписаниеОшибки());
   MSWord.Application.Quit();
КонецПопытки;   
КонецПроцедуры

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Эта строчка наверное не там, где должна быть
мОбъект =  ДанныеФормыВЗначение(Объект,Тип "ДокументОбъект.СогласиеНаОбследование")); 
Какие могут быть данные формы в модуле объекта?
Кнопочка Спасибо - слева!


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4483
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7757
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4789
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8556
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7347
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 173
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal