Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите пожалуйста  (Прочитано 2560 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн almagkeeva

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Программист 1С
Доброй ночи!Кто может,помогите,пожалуйста. Создаю обработку,которая по выбранной в поле ввода книге записывает в поле списка ее шифр и название самой книги. Все данные берутся из одного справочника "Книги". Делаю вот так-не работает,не знаю,в чем проблема(

Процедура КнопкаВыполнитьНажатие(Кнопка)
Выборка=Справочники.Книги.Выбрать();
   Пока Выборка.Следующий()Цикл
         Стр=Выборка.Наименование+" "+Выборка.ББК;
    Если Выборка.Наименование=ПолеВвода1 Тогда
   ПолеСписка1.Добавить(Выборка.Ссылка,Стр);
    КонецЕсли;
    КонецЦикла;

КонецПроцедуры


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
 а что он у тебя выдает?
Помогли, отблагодари!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
На первый взгляд - все нормально...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн almagkeeva

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Программист 1С
Вообще ничего не выдает...нажимаю на кнопку "Выполнить" и ничего вообще не происходит( хоть бы ошибку выдавал,но нет...

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Перед "Если..." впишите "Сообщить(Стр)" и проверьте - цикл вообще крутится или нет...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
 Если Выборка.Наименование=ПолеВвода1 Тогда

у них тип одинаковый?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Хотяяя...
(*далее делается взгляд а ля "Хауса осенило" ;)) )

ПолеВвода1 у  вас типа "СправочникСсылка.Книги"
Значит и выборка из справочника вам не нужна совершенно!
Делается просто:

Процедура КнопкаВыполнитьНажатие(Кнопка)
Стр=ПолеВвода1.Наименование+" "+ПолеВвода1.ББК;
ПолеСписка1.Добавить(ПолеВвода1,Стр);
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Боюсь, что поле ввода у него текст. И он хочет по фрагменту названия найти все книги.....
Скорее у него не соответствие типов.

Оффлайн almagkeeva

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Программист 1С
Урааа! Работает!!!! Спасибо большущеее всем! Даже не верится:)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Боюсь, что поле ввода у него текст. И он хочет по фрагменту названия найти все книги.....
Скорее у него не соответствие типов.

Ключевая фраза в самом начале:
"...по ВЫБРАННОЙ в поле ввода книге..."
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4289
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5544
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5879
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4358
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 327
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal