Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 06:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получение из ПТ РТ на основании  (Прочитано 14164 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
нужно сделать, чтобы при нажатии в документе поступление товаров на кнопку, открывался журнал документов реаализация товаров, далее нужно выбрать организации, и на основании их заполнить ТЧ поступления товаров, надеюсь понятно объяснил, делал аналогично типконфе, и вот столкнулся с проблемой, выдает ошибку:
Значение не является значением объектного типа (ВалютаДокумента)
    Если ДокументОбъект.ВалютаДокумента = ВалютаРегламентированногоУчета ИЛИ ДокументОбъект.ВалютаДокумента.Пустая() Тогда

как избавиться от этого? пишу внешнюю обработку


Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(Док, Основание);
      Док.ВидПоступления = Перечисления.Док.ВидыПоступленияТоваров.НаСклад;
      Док.СкладОрдер     = Основание.Склад;

      ОрганизацияКонтрагента = ЗаполнениеДокументов.ПолучитьОрганизациюПоКонтрагенту(Основание.Контрагент);

      Если ЗначениеЗаполнено(ОрганизацияКонтрагента) Тогда
         
         // Документ не отражается в управленческом учете (внутреняя передача товара),
         // поменяем организацию и контрагента местами.
         Док.Организация = ОрганизацияКонтрагента;
         Док.Контрагент  = ЗаполнениеДокументов.ПолучитьКонтрагентаПоОрганизации(Основание.Организация);

         Док.ВидОперации = Перечисления.ВидыОперацийПоступлениеТоваровУслуг.ПокупкаКомиссия;

         // Заполним номер и дату вхоящего документа.
         Док.НомерВходящегоДокумента = Основание.Номер;
         Док.ДатаВходящегоДокумента  = Основание.Дата;
         
         ЗаполнениеДокументов.ПриИзмененииЗначенияКонтрагента(Объект, мСтруктураПараметровДляПолученияДоговора);
         
      Иначе
         //переносить контрагента и договор нет смысла при такой цепочке
         Док.Контрагент = Справочники.Контрагенты.ПустаяСсылка();
         Док.ДоговорКонтрагента = Справочники.ДоговорыКонтрагентов.ПустаяСсылка();
      КонецЕсли;

      СтруктураКурсаВзаиморасчетов = МодульВалютногоУчета.ПолучитьКурсВалюты(Док.ДоговорКонтрагента.ВалютаВзаиморасчетов, Док.Дата);
      Док.КурсВзаиморасчетов           = СтруктураКурсаВзаиморасчетов.Курс;
      Док.КратностьВзаиморасчетов      = СтруктураКурсаВзаиморасчетов.Кратность;
;

от суда походу перекидывается в главный модуль, а там мне никак не изменить, как обойти ошибку, и сделать чтоб заработало?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Давай код внешней обработки и ошибку в студию (прямо скопируй ее а не пререписывай)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
Перем мСтруктураПараметровДляПолученияДоговора Экспорт;
 Перем мВалютаРегламентированногоУчета Экспорт;



Процедура Инициализировать (Объект, ИмяТабличнойЧасти) Экспорт
   
   ФормаРеализация = Документы.РеализацияТоваровУслуг.ПолучитьФормуВыбора();
   ФормаРеализация.Отбор.Организация.Использование = Истина;
   ФормаРеализация.Отбор.Организация.Значение      = Объект.Организация;
   Реализация = ФормаРеализация.ОткрытьМодально();
   Если Не ЗначениеЗаполнено(Реализация) Тогда
      Возврат;
   КонецЕсли;

    //ЗаполнитьТоварыПоПоступлениюТоваров(Объект.РеализацияТоваровУслуг, Объект.ТабЧасть);
    Заполнение(Объект);
КонецПроцедуры





Процедура Заполнение(Основание)
      Док = Объект.ПолучитьОбъект();
         ТипОснования = ТипЗнч(Основание);
      ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(Док, Основание);
      Док.ВидПоступления = Перечисления.Док.ВидыПоступленияТоваров.НаСклад;
      Док.СкладОрдер     = Основание.Склад;

      ОрганизацияКонтрагента = ЗаполнениеДокументов.ПолучитьОрганизациюПоКонтрагенту(Основание.Контрагент);

      Если ЗначениеЗаполнено(ОрганизацияКонтрагента) Тогда
         
         // Документ не отражается в управленческом учете (внутреняя передача товара),
         // поменяем организацию и контрагента местами.
         Док.Организация = ОрганизацияКонтрагента;
         Док.Контрагент  = ЗаполнениеДокументов.ПолучитьКонтрагентаПоОрганизации(Основание.Организация);

         Док.ВидОперации = Перечисления.ВидыОперацийПоступлениеТоваровУслуг.ПокупкаКомиссия;

         // Заполним номер и дату вхоящего документа.
         Док.НомерВходящегоДокумента = Основание.Номер;
         Док.ДатаВходящегоДокумента  = Основание.Дата;
         
         ЗаполнениеДокументов.ПриИзмененииЗначенияКонтрагента(Объект, мСтруктураПараметровДляПолученияДоговора);
         
      Иначе
         //переносить контрагента и договор нет смысла при такой цепочке
         Док.Контрагент = Справочники.Контрагенты.ПустаяСсылка();
         Док.ДоговорКонтрагента = Справочники.ДоговорыКонтрагентов.ПустаяСсылка();
      КонецЕсли;

      СтруктураКурсаВзаиморасчетов = МодульВалютногоУчета.ПолучитьКурсВалюты(Док.ДоговорКонтрагента.ВалютаВзаиморасчетов, Док.Дата);
      Док.КурсВзаиморасчетов           = СтруктураКурсаВзаиморасчетов.Курс;
      Док.КратностьВзаиморасчетов      = СтруктураКурсаВзаиморасчетов.Кратность;

      // Заполним табличные части.
      ЗаполнитьТоварыПоОснованиюРеализация(Основание);
      ЗаполнитьУслугиПоОснованиюРеализация(Основание);
      ЗаполнитьВозвратнуюТаруПоОснованиюРеализация(Основание);

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Приведите место, где вы вызываете процедуру Инициализировать().
Очень хочется узнать, чему равен ее параметр "Объект"...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Просто возможно вот в этом месте не...

 //ЗаполнитьТоварыПоПоступлениюТоваров(Объект.РеализацияТоваровУслуг, Объект.ТабЧасть);
    Заполнение(Объект);
КонецПроцедуры

а...

 //ЗаполнитьТоварыПоПоступлениюТоваров(Объект.РеализацияТоваровУслуг, Объект.ТабЧасть);
    Заполнение(РЕАЛИЗАЦИЯ);
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
хм, теперь пишет ошибку:

Заполнение ТЧ не произведено!
Слишком много фактических параметров



Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
{ОбщийМодуль.ЗаполнениеДокументов.Модуль(625)}: Значение не является значением объектного типа (ВалютаДокумента)
   Если ДокументОбъект.ВалютаДокумента = ВалютаРегламентированногоУчета ИЛИ ДокументОбъект.ВалютаДокумента.Пустая() Тогда


вот ошибка про валюту документа, как е еобойти?

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
хм, теперь пишет ошибку:

Заполнение ТЧ не произведено!
Слишком много фактических параметров




такая ошибка выпадает при вызове из самого документа(то есть в ПТ выбираем заполнить, нажимаем реализация товаров, и выпадает эта ошибка)



Про валюту же ошибка выпадает, когда просто открываем файл, выбираем документ ПТ, и на его основании так же пытаемся получить Реализацию, но тоже падает ошибка.

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
Приведите место, где вы вызываете процедуру Инициализировать().
Очень хочется узнать, чему равен ее параметр "Объект"...
Тип объекта - ДокументСсылка.РеализацияТоваровИУслуг


Теги:
 

Получение начальных и конечных остатков из таблицы остатков и таблицы оборотов

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 131
Последний ответ 24 Дек 2017, 17:12
от Dmitry Qwe
Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9532
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3312
Последний ответ 21 Мар 2015, 20:24
от дфтын
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 280
Последний ответ 18 Авг 2017, 11:57
от ZSS
Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4705
Последний ответ 23 Апр 2015, 08:45
от Golickoff

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
100 Сообщений
alex0402
30 Сообщений
kiksi
19 Сообщений
pavl_vs
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal