Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 08:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При выборе одного реквизита, подстановка значений других  (Прочитано 3152 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vodez

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-25
  • Сайт: 
  • Профессия: Бухгалтер
Добрый день!
1с 8.2, управляемая форма, подскажите как сделать чтобы при выборе ФИО из справочника Учащиеся, в форму документа автоматически подставлялся его возраст, пробовал разные варианты, но ничего не выводится..
для начала хотябы чтобы в Возрасте выводилась ДатаРождения (оба реквизита типа Дата)

ЗЫ ногами не пинайте, в Радченко только с табличными частями пример нашел )

&НаСервере
Функция ПолучитьГодРождения(Наименование)
   Возврат Справочники.Учащиеся.Выбрать(Наименование).ДатаРождения;
КонецФункции


 &НаКлиенте
Процедура ФИОПриИзменении(Элемент)
   Объект.Возраст = ПолучитьГодРождения(Объект.ФИО);
КонецПроцедуры


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
А если учащиеся однофамильцы и полные тезки - как им быть?
&НаСервере
Функция ПолучитьГодРождения(Объект)
   Возврат Объект.ДатаРождения;
КонецФункции
Кнопочка Спасибо - слева!

Оффлайн vodez

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-25
  • Сайт: 
  • Профессия: Бухгалтер
sergejK74, спасибо большое! все просто так оказывается!
  плюсанул ;)


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 693
Последний ответ 20 Мар 2018, 16:54
от alex0402
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1452
Последний ответ 02 Дек 2016, 12:58
от Jalib
КД, Перенос Реквизита справочника (7.7) в ТЧ справочника 8.2.

Автор EvgenyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4083
Последний ответ 17 Сен 2014, 13:39
от Kironten
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1320
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5488
Последний ответ 24 Ноя 2015, 15:38
от welldone

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
32 Сообщений

* Кто онлайн

  • Точка Гостей: 459
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal