Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 13:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка произвольной накладной в формате dbf 8.2  (Прочитано 13838 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alex9910

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-01
  • Сайт: 
  • Профессия: Ученик 1С
Всем доброго времени суток.
Кто может подсказать как переделать данную обработку под 8.2 (профф) ?
Всем спасибо)
Процедура Сформировать()
//Создаем объект
База = СоздатьОбъект("XBASE");

//Указываем кодировку файла 1- DOS, 0 – Windows

База.КодоваяСтраница(1);

//Добавляем поля в DBF файл

База.ДобавитьПоле("TOVAR","C",25,);

База.ДобавитьПоле("KOLICH","N",14,3);

База.ДобавитьПоле("COST","N",15,2);

База.ДобавитьПоле("SUMMA","N",15,2);

//Создаем новый файл C:\nakl.dbf

//База.СоздатьФайл("C:\nakl.dbf");

Путь = "C:\nakl.DBF";

База.СоздатьФайл(Путь);

//Очищаем файл от записей, если они там есть

База.ОчиститьФайл();

//Будем выгружать данные из документа

Документ.ВыбратьСтроки();

Пока Документ.ПолучитьСтроку () = 1 Цикл

//Добавляем новую запись в DBF

База.Добавить();

База.TOVAR = Документ.Номенклатура.Наименование;

База.KOLICH = Документ.Количество;

База.COST = Документ.Цена;

База.SUMMA = Документ.Сумма;

//Записываем файл DBF

База.Записать();

КонецЦикла

КонецПроцедуры


Оффлайн alex9910

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-01
  • Сайт: 
  • Профессия: Ученик 1С
Вот  что получилось но как организовать цикл или подобное что бы считать переменные...

Процедура Сформировать()
//Создаем объект
//База = СоздатьОбъект("XBASE");
База = Новый XBase;

//База.КодоваяСтраница(0);
База.Кодировка = КодировкаXBase.OEM;
//Добавляем поля в DBF файл

База.Поля.Добавить ("TOVAR","C",25,);

База.Поля.Добавить ("KOLICH","N",14,3);

База.Поля.Добавить ("COST","N",15,2);

База.Поля.Добавить ("SUMMA","N",15,2);

База.СоздатьФайл("C:\nakl.DBF");
База.Записать();

//Очищаем файл

База.ОчиститьФайл();

Для Каждого Стр из Т Цикл

База.Добавить();

База.TOVAR = Стр.Нуменклатура;


 База.Записать();

КонецЦикла;

База.Записать();
База.ЗакрытьФайл();

КонецПроцедуы


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
//Вот же у тебя цикл
Для Каждого Стр из Т Цикл

База.Добавить();

База.TOVAR = Стр.Нуменклатура;


 База.Записать();

КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн alex9910

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-01
  • Сайт: 
  • Профессия: Ученик 1С
Dethmontt, что-то не работает..


Переменная не определена (Т)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Для каждого Стр Из ИмяТабличнойЧасти Цикл
База.TOVAR = Стр.Номенклатура.Наименование;
КонецЦикла;
//Это если в модуле документа
//Если из обработки то нужно сначала указать документ
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Книженция - Радченко там все есть, открывай и читай...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн alex9910

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-01
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Что тоже самое? Я тебе пример написал а не готовый код....
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн alex9910

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-01
  • Сайт: 
  • Профессия: Ученик 1С
Смог выгрузить наименования, кол-во и суммы

Номера и даты док-тов никак... Обыскал все

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
База.Date = Дата; (или Документ.Дата, зависит от твоего кода)
База.Number = Номер; (или Документ.Номер)
Как в дбф файл добавить поля дата и номер догадайся сам.
Кнопочка Спасибо - слева!


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4091
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2415
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8553
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 941
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1226
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 849
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal