Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 22:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите, в чем проблема не печатается отчет  (Прочитано 3128 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С

Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

   Макет = Документы.Выработка_Кк.ПолучитьМакет("Макет");
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Выработка_Кк.ТабличнаяЧасть1.(
      |      кол_во
      |   ),
      |   Выработка_Кк.Дата,
      |   Номенклатура.Наименование,
      |   Номенклатура.ТабличнаяЧасть1.(
      |      НаименованиеСырья,
      |      ПРЕДСТАВЛЕНИЕ(Номенклатура.ТабличнаяЧасть1.НаименованиеСырья),
      |      ПроцентВвода
      |   ) КАК ТабличнаяЧасть11
      |ИЗ
      |   Документ.Выработка_Кк КАК Выработка_Кк
      |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
      |      ПО Выработка_Кк.ТабличнаяЧасть1.Наименование_корма = Номенклатура.Наименование";
       запрос.Параметры.Вставить(Ссылка);
   Результат = Запрос.Выполнить();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
   ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
   ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
   ТабличнаяЧасть11ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ТабличнаяЧасть11ШапкаТаблицы");
   ТабличнаяЧасть11ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ТабличнаяЧасть11ПодвалТаблицы");
   ТабличнаяЧасть11ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("ТабличнаяЧасть11Детали");
   ТабличнаяЧасть1ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ТабличнаяЧасть1ШапкаТаблицы");
   ТабличнаяЧасть1ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ТабличнаяЧасть1ПодвалТаблицы");
   ТабличнаяЧасть1ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("ТабличнаяЧасть1Детали");

   ТабДок.Очистить();
   ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.Вывести(ОбластьШапкаТаблицы);
   ТабДок.НачатьАвтогруппировкуСтрок();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
      ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());

      ТабДок.НачатьГруппуСтрок();
      ТабДок.Вывести(ТабличнаяЧасть11ОбластьШапкаТаблицы);
      ТабДок.НачатьАвтогруппировкуСтрок();

      ТабличнаяЧасть11ВыборкаДетальныеЗаписи = ВыборкаДетальныеЗаписи.ТабличнаяЧасть11.Выбрать();

      Пока ТабличнаяЧасть11ВыборкаДетальныеЗаписи.Следующий() Цикл
         ТабличнаяЧасть11ОбластьДетальныхЗаписей.Параметры.Заполнить(ТабличнаяЧасть11ВыборкаДетальныеЗаписи);
         ТабДок.Вывести(ТабличнаяЧасть11ОбластьДетальныхЗаписей, ТабличнаяЧасть11ВыборкаДетальныеЗаписи.Уровень());
      КонецЦикла;

      ТабДок.ЗакончитьАвтогруппировкуСтрок();
      ТабДок.Вывести(ТабличнаяЧасть11ОбластьПодвалТаблицы);
      ТабДок.Вывести(ТабличнаяЧасть1ОбластьШапкаТаблицы);
      ТабДок.НачатьАвтогруппировкуСтрок();

      ТабличнаяЧасть1ВыборкаДетальныеЗаписи = ВыборкаДетальныеЗаписи.ТабличнаяЧасть1.Выбрать();

      Пока ТабличнаяЧасть1ВыборкаДетальныеЗаписи.Следующий() Цикл
         ТабличнаяЧасть1ОбластьДетальныхЗаписей.Параметры.Заполнить(ТабличнаяЧасть1ВыборкаДетальныеЗаписи);
         ТабДок.Вывести(ТабличнаяЧасть1ОбластьДетальныхЗаписей, ТабличнаяЧасть1ВыборкаДетальныеЗаписи.Уровень());
      КонецЦикла;

      ТабДок.ЗакончитьАвтогруппировкуСтрок();
      ТабДок.Вывести(ТабличнаяЧасть1ОбластьПодвалТаблицы);
      ТабДок.ЗакончитьГруппуСтрок();
   КонецЦикла;

   ТабДок.ЗакончитьАвтогруппировкуСтрок();
   ТабДок.Вывести(ОбластьПодвалТаблицы);
   ТабДок.Вывести(ОбластьПодвал);

   //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   
КонецПроцедуры


Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
вот каак

Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
почему нифига не печатается??

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Наверное запрос нужно написать по нормальному
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Public_enemy

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 6
  • КПД: 12%
  • Регистрация: 2011-10-13
  • Сайт: www.alliancesystems.ru
  • Профессия: Программист 1С
Ели я не ошибаюсь то надо дописать ТабДок.Показать() и все получится


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 325
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal