Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка из 1с в Ексель  (Прочитано 17992 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
Добры день, стоит такая задача. Есть документ Поступление товаров, на нем есть кнопка, при нажатии на которую данные из поступления товаров отправляются в Ексель, как это реализовать?


Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
Добры день, стоит такая задача. Есть документ Поступление товаров, на нем есть кнопка, при нажатии на которую данные из поступления товаров отправляются в Ексель, как это реализовать?
нужно сделать внешнюю обработку УПП

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А если сформировать печатную форму поступления и сохранить ее в xls файле?

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
А если сформировать печатную форму поступления и сохранить ее в xls файле?

думал так сделать, но нельзя, нужно чтобы при нажатии сразу открывался документ в виде экселя

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
в инете куча инфы по работе 1с и эксель

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
в инете куча инфы по работе 1с и эксель
есть для выгрузки в эксель из 1ски справочников, а про выгрузку документов не могу найти. У меня есть вид, как должно из 1с выгружаться в эксель, мне для этого во внешней обработке нужно макет рисовать так?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Макет тут не нужен, если печатать будешь. А если принципиально чтобы файл экселя отрывался, то просто выгружать в эксель через COMОбъект

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
у меня такая же проблема с выгрузкой......нет разницы откуда выгружать справочник или документ
вот тебе код того как я выгружаю из 1с в эксель
&НаКлиенте
Процедура СохранитьВЭксель(Команда)
    ВыгрузитьВЭксель();   
КонецПроцедуры


Ты помоему даже в моей теме что-то писал...


&НаСервере
Процедура ВыгрузитьВЭксель()     
ВыборкаДокументов= Документы.Задание.Выбрать();   
Пока ВыборкаДокументов.Следующий() цикл 
Попытка
Эксель = Новый COMОбъект("Excel.Application")
Исключение
Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
Возврат;
КонецПопытки;



Книга = Эксель.WorkBooks.Add();
Лист = Книга.WorkSheets(1);

НомерСтроки=НомерСтроки+1;

Лист.Cells(НомерСтроки, 1).Value = Строка(Строка.Студент);
Лист.Cells(НомерСтроки, 2).Value = Строка(Строка.ПН);
Лист.Cells(НомерСтроки, 3).Value = Строка(Строка.ВТ);
Лист.Cells(НомерСтроки, 4).Value = Строка(Строка.СР);
Лист.Cells(НомерСтроки, 5).Value = Строка(Строка.ЧТ);
Лист.Cells(НомерСтроки, 6).Value = Строка(Строка.ПТ);
Лист.Cells(НомерСтроки, 7).Value = Строка(Строка.СБ);
Лист.Cells(НомерСтроки, 8).Value = Строка(Строка.ВС);


КонецЦикла;   
КонецЦикла;   
Попытка
Книга.SaveAs("C:\Users\Администратор\Downloads\1с");
Исключение
Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
Возврат;
КонецПопытки;
Эксель.Application.Quit();

КонецПроцедуры

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
у меня такая же проблема с выгрузкой......нет разницы откуда выгружать справочник или документ
вот тебе код того как я выгружаю из 1с в эксель
&НаКлиенте
Процедура СохранитьВЭксель(Команда)
    ВыгрузитьВЭксель();   
КонецПроцедуры


Ты помоему даже в моей теме что-то писал...


&НаСервере
Процедура ВыгрузитьВЭксель()     
ВыборкаДокументов= Документы.Задание.Выбрать();   
Пока ВыборкаДокументов.Следующий() цикл 
Попытка
Эксель = Новый COMОбъект("Excel.Application")
Исключение
Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
Возврат;
КонецПопытки;



Книга = Эксель.WorkBooks.Add();
Лист = Книга.WorkSheets(1);

НомерСтроки=НомерСтроки+1;

Лист.Cells(НомерСтроки, 1).Value = Строка(Строка.Студент);
Лист.Cells(НомерСтроки, 2).Value = Строка(Строка.ПН);
Лист.Cells(НомерСтроки, 3).Value = Строка(Строка.ВТ);
Лист.Cells(НомерСтроки, 4).Value = Строка(Строка.СР);
Лист.Cells(НомерСтроки, 5).Value = Строка(Строка.ЧТ);
Лист.Cells(НомерСтроки, 6).Value = Строка(Строка.ПТ);
Лист.Cells(НомерСтроки, 7).Value = Строка(Строка.СБ);
Лист.Cells(НомерСтроки, 8).Value = Строка(Строка.ВС);


КонецЦикла;   
КонецЦикла;   
Попытка
Книга.SaveAs("C:\Users\Администратор\Downloads\1с");
Исключение
Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
Возврат;
КонецПопытки;
Эксель.Application.Quit();

КонецПроцедуры

это ведь для управляемого приложения, а у меня обычное

Оффлайн Вожак

  • ***
  • Сообщений: 118
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-20
  • Сайт: 
  • Профессия: Бухгалтер
Процедура ВыборДокументаПриИзменении(Элемент)
  // Получить список реквизитов выбранного справочника
  КоллекцияРеквизитов = Метаданные.Документы[Элемент.Значение];
  ТП.Очистить();
  // Добавим предопределенные реквизиты справочника
  стр = ТП.Добавить();
  стр.НазваниеРеквизита = "Код";
  стр = ТП.Добавить();
  стр.НазваниеРеквизита = "Наименование";
  // Добавим реквизит родитель для справочников с установленным видом Иерархии
  Если Строка(КоллекцияРеквизитов.ВидИерархии) = "ИерархияГруппИЭлементов" Тогда
    стр = ТП.Добавить();
    стр.НазваниеРеквизита = "Родитель";
  КонецЕсли;
   // Обход коллекции реквизитов метаданных для формирования табличного поля выбора
  Для каждого пРек из КоллекцияРеквизитов.Реквизиты Цикл
    стр = ТП.Добавить();
    стр.НазваниеРеквизита = пРек.Имя;
  КонецЦикла;
  // Поставим заначение истина для всех реквизитов справочника
  Для каждого стр из ТП Цикл
    стр.Выгружать = истина;
  КонецЦикла;
  // Установим имя файла по умолчанию и сохраним значение имени выбранного справочника
  ИмяФайла = "C:\" + Элемент.Значение + ".xls";
  ИмяДокумента = Элемент.Значение;
КонецПроцедуры



вот ТП это ТабличноеПоле так ведь? а где его определить?


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4109
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2424
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8570
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 946
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1231
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 130
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal