Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 13:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите!!!!!!  (Прочитано 5244 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
начинающий програмист....не судите строго!

1с 8.2 управляемое приложение...

у модули формы справочника пишу листинг..


&НаКлиенте
Процедура ВидПриИзменении(Элемент)
   Если Элементы.Вид = Перечисления.Вид.ФіізичнаОсоба Тогда
      Элементы.ЄДРПОУ.Видимость = Ложь;
   Иначе Элементы.ЄДРПОУ.Видимость = Истина;
      КонецЕсли;
КонецПроцедуры


видайот ошыбку


{Справочник.Клієнти.Форма.ФормаЭлемента.Форма(5,22)}: Переменная не определена (Перечисления)
   Если Элементы.Вид = <<?>>Перечисления.Вид.ФіізичнаОсоба Тогда (Проверка: Тонкий клиент)


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #1: 18 Мар 2012, 14:02 »
ПредопределенноеЗначение("Перечисление.Вид.ФіізичнаОсоба")
Кнопочка Спасибо - слева!

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #2: 18 Мар 2012, 14:05 »
Предопределенное значение "Перечисления.Вид.ФіізичнаОсоба" не найдено.

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #3: 18 Мар 2012, 14:17 »
Из предопределонным проблема решена....а как сделать, штоб видимость реквизита была ложь???

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #4: 18 Мар 2012, 14:32 »
&НаКлиенте
Процедура ВидПриИзменении(Элемент)
УстановитьВидимость();
КонецПроцедуры
 
&НаСервере
Процедура УстановитьВидимость()
Если Элементы.Вид = Перечисления.Вид.ФіізичнаОсоба Тогда
Элементы.ЄДРПОУ.Видимость = Ложь;
Иначе
Элементы.ЄДРПОУ.Видимость = Истина;
КонецЕсли;
КонецПроцедуры // УстановитьВидимость()
Кнопочка Спасибо - слева!

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #5: 18 Мар 2012, 14:43 »
а как определить процедуру УстановитьВидимость ();  ???

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #6: 18 Мар 2012, 14:54 »
 &НаСервере
 Процедура УстановитьВидимость ();
    Если Элементы.Вид = Перечисления.Вид.ФіізичнаОсоба тогда
       Элементы.ЄДРПОУ.Видимость = Ложь;
    Иначе Элементы.ЄДРПОУ.Видимость = Истина;
       КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ВидПриИзменении(Элемент)
   УстановитьВидимость();
КонецПроцедуры



не пашет!

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #7: 18 Мар 2012, 15:09 »
Скопировал не глядя
&НаСервере
 Процедура УстановитьВидимость();
    Если Объект.Вид = Перечисления.Вид.ФіізичнаОсоба тогда
       Элементы.ЄДРПОУ.Видимость = Ложь;
    Иначе Элементы.ЄДРПОУ.Видимость = Истина;
       КонецЕсли;
   КонецПроцедуры

&НаКлиенте
   Процедура ВидПриИзменении(Элемент)
   УстановитьВидимость();
   КонецПроцедуры
Кнопочка Спасибо - слева!

Оффлайн МаксимВікторович

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #8: 18 Мар 2012, 15:15 »
Thank you!

Спасибо!

Велике Дякую із України!

Посоветуйте какую литературу прочитать, чтобы изучить азы 8.2 (чтобы не обращатца по пустекам)????

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите!!!!!!
« Ответ #9: 18 Мар 2012, 15:25 »
Обычно Радченко советуют - наверное кому-то помог.
Кнопочка Спасибо - слева!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4302
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5559
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5898
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4386
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1985
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
56 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal