Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 19:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Цикл  (Прочитано 5622 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Цикл
« Первое сообщение: 16 Мар 2012, 17:58 »
Здравствуйте!У меня есть справочник в котором я что-то делаю...каждый оформленный документ попадает в форму списка...как организовать цикл что бы все эти документы автоматически выгружались в Excel??(сама выгрузка есть, но она работает из документа непосредственно,а надо как сказали чтобы после фильтрации  всё, что осталось в  этой форме выгрузилось).Заранее благодарен...


Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл
« Ответ #1: 17 Мар 2012, 17:44 »
Наверно я не совсем правильно выразился попробую ещё раз...)
Здравствуйте!!Помогите пожалуйста разобраться с тем как правильно организовать цикл (прикрепил файл)т.е я сделал так чтобы можно было выгружать из каждого документа непосредственно (но это очень долго и сразу отпадает), а как организовать цикл по всем этим документам чтобы из них выгружалась табличная часть я не знаю...Подскажите пожалуйста.
Код процедуры выгрузки из документа
Процедура Команда1(Команда)
// Вставить содержимое обработчика.
Попытка
Эксель = Новый COMОбъект("Excel.Application")
Исключение
Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
Возврат;
КонецПопытки;
Книга = Эксель.WorkBooks.Add();
Лист = Книга.WorkSheets(1);
Лист = Книга.Sheets.Add();
//Ведомость=<<?>>ТекущийДокумент.Ведомость;
НомерСтроки=0;
Для Каждого Строка из Объект.Ведомость цикл
НомерСтроки=НомерСтроки+1;

Лист.Cells(НомерСтроки, 1).Value = Строка.Студент;
Лист.Cells(НомерСтроки, 2).Value = Строка.Понедельник;
Лист.Cells(НомерСтроки, 3).Value = Строка.Вторник;
Лист.Cells(НомерСтроки, 4).Value = Строка.Среда;
Лист.Cells(НомерСтроки, 5).Value = Строка.Четверг;
Лист.Cells(НомерСтроки, 6).Value = Строка.Пятница;
Лист.Cells(НомерСтроки, 7).Value = Строка.Суббота;
Лист.Cells(НомерСтроки, 8).Value = Строка.Воскресенье;
// и так далее, по всем нужным колонкам таб.части
КонецЦикла;

Попытка
Книга.SaveAs("C:\Users\Администратор\Downloads\1с");
Исключение
Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
Возврат;
КонецПопытки;

КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Цикл
« Ответ #2: 17 Мар 2012, 17:50 »
Ну вот же у тебя пример прямо в коде есть
Для Каждого Строка из Объект.Ведомость цикл
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл
« Ответ #3: 17 Мар 2012, 17:55 »
Ну вот же у тебя пример прямо в коде есть
Для Каждого Строка из Объект.Ведомость цикл
например
для каждого строка из объект.наименование цикл
или надо писать про форму списка????

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл
« Ответ #4: 17 Мар 2012, 18:20 »
или
для каждого строка из формасписка.наименование  цикл
??

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Цикл
« Ответ #5: 17 Мар 2012, 20:29 »
В модуле твоего журнала
Для каждого Строка Из Объект.ИмяТабличнойЧастиТвоегоЖурнала Цикл
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл
« Ответ #6: 18 Мар 2012, 09:25 »
В модуле твоего журнала
Для каждого Строка Из Объект.ИмяТабличнойЧастиТвоегоЖурнала Цикл
а как сделать ссылку на кнопку "Выгрузить в excel" ???

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл
« Ответ #7: 18 Мар 2012, 09:40 »
т.е если я пишу в модуле объекта   а кнопка то в форме списка..

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл
« Ответ #8: 18 Мар 2012, 13:37 »
Значит я делаю так:создаю процедуру для кнопки в форме списка в ней делаю ссылку на процедуру которую буду вызывать из модуля объекта  и всёравно косяк...

&НаКлиенте
Процедура Команда1(Команда)
      ДляКоманда();   
КонецПроцедуры


мод объекта

Процедура ДляКоманда1() Экспорт
Возврат 

   // Вставить содержимое обработчика.
   Попытка
Эксель = Новый COMОбъект("Excel.Application")
Исключение
Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
Возврат;
КонецПопытки;
Книга = Эксель.WorkBooks.Add();
Лист = Книга.WorkSheets(1);
Лист = Книга.Sheets.Add();
//Ведомость=<<?>>ТекущийДокумент.Ведомость;
НомерСтроки=0;
Для каждого Строка Из Объект.Ведомость Цикл 
//Для Каждого Строка из Объект.Ведомость цикл
НомерСтроки=НомерСтроки+1;

Лист.Cells(НомерСтроки, 1).Value = Строка.Студент;
Лист.Cells(НомерСтроки, 2).Value = Строка.Понедельник;
Лист.Cells(НомерСтроки, 3).Value = Строка.Вторник;
Лист.Cells(НомерСтроки, 4).Value = Строка.Среда;
Лист.Cells(НомерСтроки, 5).Value = Строка.Четверг;
Лист.Cells(НомерСтроки, 6).Value = Строка.Пятница;
Лист.Cells(НомерСтроки, 7).Value = Строка.Суббота;
Лист.Cells(НомерСтроки, 8).Value = Строка.Воскресенье;
// и так далее, по всем нужным колонкам таб.части
КонецЦикла;

Попытка
Книга.SaveAs("C:\Users\Администратор\Downloads\1с");
Исключение
Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
Возврат;
КонецПопытки;

КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Цикл
« Ответ #9: 19 Мар 2012, 02:03 »
МойСписокДокументов = ПолучитьСписокТрамПамПам();//Как ты получишь список нужных тебе документов я надеюсь объяснять не надо
Для каждого Документ Из МойСписокДокументов Цикл
МойМегаСуперОбъект = Документ.получитьОбъект();
//Дальше твой мега супер код выгрузки в ЭКСЕЛЬ где ты поменяешь СЛОВО (Переменную) ОБЪЕКТ на МойМегаСуперОбъект
//ВМЕСТО:
Для каждого Строка Из Объект.Ведомость Цикл
//ВОТ ТАК:
Для каждого Строка Из МойМегаСуперОбъект.Ведомость Цикл  
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Условие запроса, цикл, конструктор запроса

Автор mashamashaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 349
Последний ответ 31 Янв 2017, 14:29
от Oldman06
Форма Списка. Печать по всем записям справочника. как организовать цикл?

Автор SnakeyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2436
Последний ответ 10 Дек 2012, 16:58
от Dethmontt
Не могу понять как правильно написать цикл Помогите!

Автор ПрокофийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 4960
Последний ответ 15 Апр 2011, 10:55
от Klyacksa
Как сделать цикл по всем строкам в табличной части

Автор it-logicРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1942
Последний ответ 19 Мар 2014, 09:52
от KrivosheevEV
Помогите составить Цикл Повтора операции

Автор siralexРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 661
Последний ответ 09 Окт 2015, 15:23
от siralex

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 283
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal