Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Настройки печати  (Прочитано 6555 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kvarts

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 7.7
Здравствуйте.
Платформа 7.7 (7.70.025)
Конфигурация  Торговля и склад (7.70.941)
1. Настраиваю печатную форму для товарного чека (документ Реализация). Документ этот обычно небольшой, поэтому нужно, чтобы 2 экземпляра печатались на одном листе, один под другим. А сейчас у меня печатается 1 экземпляр на 2 листах, причем второй лист выходит абсолютно чистым. Пробовал сжимать таблицу (справа и слева большие поля)-все равно второй чистый лист печатается.
2. И второй простой вопрос, чтобы не создавать тему. Как обратиться к единице измерения из справочника? Хочу сделать примерно следующее:
Если Единица=м2 Тогда [Расчет1] Иначе [Расчет2] КонецЕсли
У меня выводится ошибка, что "м2"-неопознанная переменная.


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Настройки печати
« Ответ #1: 15 Мар 2012, 10:48 »
Если Единица.ОКЕИ.Наименование = "м2" Тогда [Расчет1] Иначе [Расчет2] КонецЕсли
или
Если Единица.ОКЕИ.Код = "055" Тогда [Расчет1] Иначе [Расчет2] КонецЕсли
Кнопочка Спасибо - слева!

Оффлайн kvarts

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 7.7
Re: Настройки печати
« Ответ #2: 15 Мар 2012, 13:50 »
sergejK74, спасибо, помогло.
А что насчет печати документа?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Настройки печати
« Ответ #3: 15 Мар 2012, 13:57 »
Насчет печати - чаще всего танцы с бубном. А если еще и дистанционно. Поставь масштаб по ширине листа - выяснишь нет ли какой-то ячейки далеко вправо, которая хочет непременно напечатяться
Кнопочка Спасибо - слева!

Оффлайн kvarts

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 7.7
Re: Настройки печати
« Ответ #4: 16 Мар 2012, 08:04 »
А вобще откуда танцевать нужно? Из конфигуратора, Предприятия, или из настроек принтера?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Настройки печати
« Ответ #5: 16 Мар 2012, 08:44 »
В режиме предприятия Поставь масштаб по ширине листа - выяснишь нет ли какой-то ячейки далеко вправо, которая хочет непременно напечататься
Кнопочка Спасибо - слева!

Оффлайн kvarts

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 7.7
Re: Настройки печати
« Ответ #6: 16 Мар 2012, 09:16 »
Ура, помогло!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 178
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal