Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 20:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при формировании отчета  (Прочитано 3330 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн macropode

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-14
  • Сайт: 
  • Профессия: Ученик 1С
помогите пожалуйста пытаюсь создать отчет по остатками товаров выдает ошибку:
Прецедура <<?>>Сформировать()
{Отчет.новый1.Форма.Модуль(2)}: Переменная не определена (Сформировать)
Таб<<?>>.НоаваяКолонка("Наим,"Строка",50,0);
{Отчет.новый1.Форма.Модуль(5)}: Переменная не определена (Таб)
Таб<<?>>.НоваяКолонка("Цена","Строка",15,0);
{Отчет.новый1.Форма.Модуль(6)}: Переменная не определена (Таб)
Таб<<?>>.НоваяКолонка("Количество","Справочник.Подразделение");
{Отчет.новый1.Форма.Модуль(7)}: Переменная не определена (Таб)
Таб<<?>>.НоваяСтрока();   //не забываем про это
{Отчет.новый1.Форма.Модуль(19)}: Переменная не определена (Таб)
Таб<<?>>.Наим=сотр.Наименование;
{Отчет.новый1.Форма.Модуль(20)}: Переменная не определена (Таб)
Таб<<?>>.Цена=сотр.Цена;
{Отчет.новый1.Форма.Модуль(21)}: Переменная не определена (Таб)
Таб<<?>>.Количество=сотр.Количество;
{Отчет.новый1.Форма.Модуль(24)}: Переменная не определена (Таб)
КонецЦикла;<<?>>
{Отчет.новый1.Форма.Модуль(26)}: Обнаружено логическое завершение исходного текста модуля

Ссылка на конфигурацию вот: http://narod.ru/disk/43695387001.57a9fae7392bcd79c43e790a121c05af/Config.rar.html

Буду очень благодарен если поможете!


Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Ві хотябі прочли то что написали...
Прецедура А должно быть Процедура

и вообще проверте текст....

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Дальше, имя таблицы значение и печатной таблицы не должны совпадать

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
И вообще посмотрев на тот "шедевр" который Вы пытаетесь создать, вопросов будет уж очень много.

Оффлайн macropode

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-14
  • Сайт: 
  • Профессия: Ученик 1С
Понимаю, вообще в создании отчета я ничего не понимаю (это наверно и видно :) )

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Это какое-то учебное задание?
Процедура Сформировать()
Таб = СоздатьОбъект("ТаблицаЗначений");
//не забываем указывать тип и размерность
Таб.НоваяКолонка("Наим","Строка",50,0);
Таб.НоваяКолонка("Цена","Число",15,2);
Таб.НоваяКолонка("Количество","Число",15,3);
сотр = СоздатьОбъект("Справочник.Товары");
сотр.ВыбратьЭлементы(); //выбираем всех из справочника
Пока сотр.ПолучитьЭлемент()=1 Цикл //читаем по одному
Если Сотр.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;
Таб.НоваяСтрока();
        Таб.Наим=сотр.Наименование;
        Таб.Цена=сотр.Цена;
        //Таб.Количество=сотр.Количество;
КонецЦикла;
КонецПроцедуры;
Кнопочка Спасибо - слева!

Оффлайн macropode

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-14
  • Сайт: 
  • Профессия: Ученик 1С
Это какое-то учебное задание?
Да, это было учебное задание. но я всё сделал =) всё работает всё супер! и изменение количества и отчет по количеству. всё благодаря этой методички! Спасибо большое!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal