Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 16:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пропадают параметры в Страница3  (Прочитано 1630 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
   Если ПриемСДиагнозом = 1 Тогда
         ДатаКарты = СокрЛП(Формат(ТекДокумент.Дата,"ДЛФ=ДД"));
         ДатаКарты = Лев(ДатаКарты,СтрДлина(ДатаКарты)-2);
         ОбластьМакета.Параметры.ДатаКарты = ДатаКарты;
         ПеренесенныеЗаболевания = ТекДокумент.ПеренесенныеЗаболевания;
         РазвитиеЗаболевания = ТекДокумент.РазвитиеЗаболевания;
         Прикус = ТекДокумент.Прикус;
         Эпикриз = ТекДокумент.Эпикриз;
         Рекомендации = ТекДокумент.Рекомендации;
         
         ЛечениеТекст1 = ТекДокумент.ЛечениеТекст;
         ПланЛечения = ТекДокумент.ПланЛеченияТекст;
         Консультации = ТекДокумент.Консультации;
         
         ОбластьМакета.Параметры.ДиагнозПредставление = ДиагнозПредставление;
         ОбластьМакета.Параметры.ЖалобыПредставление = ЖалобыПредставление;
         ОбластьМакета.Параметры.ПеренесенныеЗаболевания = ПеренесенныеЗаболевания;
         ОбластьМакета.Параметры.РазвитиеЗаболевания = РазвитиеЗаболевания;
      
         ТабДокумент.Вывести(ОбластьМакета);
         ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
//----------------------------------------------------------------------------------------------------------------
            ОбластьМакета = Макет.ПолучитьОбласть("Страница2");
         
         Для Н = 0 По 31 Цикл
            ОбластьМакета.Параметры.Установить(Н, ""+z[Н]);
         КонецЦикла;
      
         ОбластьМакета.Параметры.ВнешнийОсмотр = ВнешнийОсмотр;
         ОбластьМакета.Параметры.Прикус = Прикус;
         ОбластьМакета.Параметры.СостояниеСлизистойОболочки = СостояниеСлизистойОболочки;
         ОбластьМакета.Параметры.ДанныеОбъективногоИсследования = ДанныеОбъективногоИсследования;
         ОбластьМакета.Параметры.ДанныеРентгеновскихИсследований = ДанныеРентгеновскихИсследований;
      
           ОбластьМакета = Макет.ПолучитьОбласть("Страница2");
         Запрос = Новый Запрос;
         Запрос.Текст = "ВЫБРАТЬ
                        |   КартинкиИФайлы.Данные,
                        |   КартинкиИФайлы.Идентификатор КАК Идентификатор
                        |ИЗ
                        |   РегистрСведений.КартинкиИФайлы КАК КартинкиИФайлы
                        |ГДЕ
                        |   КартинкиИФайлы.Объект.Пациент.Ссылка = &Ссылка
                        |   И КартинкиИФайлы.Идентификатор = &Идентификатор";
            Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);   
            Запрос.УстановитьПараметр("Идентификатор", "Первый");    //Справочник ссылка: Пациенты
            Выборка = Запрос.Выполнить().Выбрать();
            Если Выборка.Следующий() Тогда
            Попытка
               ОбластьМакета.Рисунки.ФСД.Картинка = Выборка.Данные.Получить();
            Исключение
             //
            КонецПопытки;
         КонецЕсли;
      ТабДокумент.Вывести(ОбластьМакета);
   ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
//---------------------------------------------------------------------------------------------------------------         
      ИначеЕсли ПриемСДиагнозом > 1 Тогда
         ОбластьМакета = Макет.ПолучитьОбласть("Страница3");
         ОбластьМакета.Параметры.ЖалобыПредставление = ЖалобыПредставление;
         ОбластьМакета.Параметры.ВнешнийОсмотр = ВнешнийОсмотр;
         ОбластьМакета.Параметры.СостояниеСлизистойОболочки = СостояниеСлизистойОболочки;
         ОбластьМакета.Параметры.ДанныеОбъективногоИсследования = ДанныеОбъективногоИсследования;
         ОбластьМакета.Параметры.ДанныеРентгеновскихИсследований = ДанныеРентгеновскихИсследований;
         ОбластьМакета.Параметры.ДиагнозПредставление = ДиагнозПредставление;
         ОбластьМакета.Параметры.ЛечениеТекст = ЛечениеТекст;
         ОбластьМакета.Параметры.ДатаПриема = Формат(ТекДокумент.Дата,"ДЛФ=ДД");
         ОбластьМакета.Параметры.Специалист = ФИО(ТекДокумент.Специалист);
         
        ТабДокумент.Вывести(ОбластьМакета);
   ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();   
КонецЕсли;   
КонецЦикла;

После вывода рисунка на страница2, то в старница3 не заполняеться. пустое появляеться


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Чего-чего?
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Чем отличаются параметры "валидное" от "отключить" в правилах регистрации обмена

Автор Bulat-ITРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3526
Последний ответ 12 Мар 2012, 20:39
от Bulat-IT
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2998
Последний ответ 15 Май 2013, 23:27
от Березин
скд неверные параметры "*"

Автор svv1979Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5235
Последний ответ 13 Фев 2015, 20:39
от svv1979
Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3973
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
ошибка проведения реализации "При списании комиссионных товаров не определены параметры партии ""

Автор WelllaryРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3728
Последний ответ 15 Апр 2015, 17:58
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 709
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal