Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 10:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сетевой маркетинг через 1C v.8 ?  (Прочитано 2840 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vaylandt

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-13
  • Сайт: 
  • Профессия: Программист 8.1
Приветствую, коллеги!
Есть такая задача, подскажите правильную логику как это реализовать!?

Логика:
1. У каждого клиента могут быть связанные клиенты. Т.е. Клиент1 связан с Клиентом21 и Клиентом22, а Клиент21 с К31, К32, К33, Клиент 22 с К35, К36. Дальше логику вы понимаете надеюсь.

2. При покупке клиентом ему на "персональный счет" (дисконтная накопительная карточка?) начисляется x% от покупки. Так же ему начисляется x% от покупок "привязанных" к нему Клиентов.

Вопросы:
1. Я так понимаю связи можно организовать отностиельно просто - создать тип связи Клиент-Реферал и связывать клиентов?
2. Самый важный вопрос - как организовать "персональный счет"? При этом физические дисконтные карты не желетельно выпускать.
3. Как начислять проценты от покупок привязанных клиентов?

PS Прошу сильно не бить ) лучше поделитесь мнением "как бы вы это сделали" хотябы в общих чертах! Буду очень благодарен!!!

ЗЫ стоит "Управление торговлей" v11 под 1С 8.2


Оффлайн wolf3d

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 7
  • КПД: 17%
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 8.1
я тебе уже на другом форуме все разжевал ипример привел
зы. зачем плодить темы

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
я тебе уже на другом форуме все разжевал ипример привел
зы. зачем плодить темы

Так это же на другом форуме ;)
Закопи-пастите теперь сюда.
Повторение - мать заикания.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн wolf3d

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 7
  • КПД: 17%
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 8.1
допустим каждый ВЫШЕСТОЯЩИЙ в дереве от текущего клиента получает +1 балл за покупку нижестоящими, тогда

 создаем справочник клиенты
 реквизиты - Наименование (тут имя клиента),КоличествоБаллов (тип число) и Владелец(тип справочники.Клиенты)

 создаем какой нить документ тпа Покупки
 в нем реквизит - клиент(справочники.Клиенты), ЧтоКупил и тд

 при проведении обрабатываем:


Процедура ПриПроведении
перем вв;
// проверяем - является ли клиент "самым верхним" в дереве
вв="";
вв1=неопределено;
Если пустаястрока(сокрлп(клиент.владелец.наименование)) = ложь тогда
 вв1=клиент.владелец.получитьобьект();
 вв=вв1.наименование;
КонецЕсли;

пока пустаястрока(сокрлп(вв)) = ложь цикл
 вв1.КоличествоБаллов = вв1.КоличествоБаллов +1;
 вв1.записать();
 вв1=вв1.владелец.получитьобьект();
 вв=вв1.наименование;
КонецЦикла;
КонецПроцедуры


 это навскидку

Оффлайн wolf3d

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 7
  • КПД: 17%
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 8.1
ммм...модератор - отредактируйте плс сообщение  выше - нет прав на редактирование


Теги:
 

Как объединить объект в реквизите формы с типом "ДокументОбъект" и объект формы, созданной через "ПолучитьФорму()"?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 255
Последний ответ 06 Авг 2017, 21:22
от alex0402
Здравствуйте!!! Необходимо востановить ИБ на определенную дату. Копии через конфигуратор на эту дату не сделали, но есть файл в формате CD в rar (Это программа сама сделала резервную копию). Возможно ли востановит ее в 1с и работать (как при загрузке копи

Автор Лариса198888Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1883
Последний ответ 24 Май 2016, 17:17
от Kironten
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8582
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Обмен УТ 11 и БП 3.0 через универсальный обмен данными

Автор magnifico61Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 7119
Последний ответ 25 Дек 2014, 13:40
от cska-fanat-kz
Нужен совет в подключении к системе спутникового мониторинга "renault-trucks(Optifleet)", через web-сервис!

Автор snoop82Раздел Беседка

Ответов: 0
Просмотров: 795
Последний ответ 11 Дек 2015, 06:56
от snoop82

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal